Bug 478408 - Physical Device Required error dialog nitpick
Physical Device Required error dialog nitpick
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
i686 Linux
low Severity low
: ---
: ---
Assigned To: Daniel Berrange
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-29 13:06 EST by Daniel Bass
Modified: 2010-03-16 13:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 21:23:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Bass 2008-12-29 13:06:44 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.10 (intrepid) Firefox/3.0.5

If you try to setup networking with a physical device, but don't select a physical device (because the list is empty), you get an error. It says, "You must select one of the physical devices".

1. This should have a period at the end, as it's a sentence. (This seems to be a common error in virt-manager and the various error messages should all be checked and corrected as needed.)

2. This wording assumes there was a device, which there wasn't. Instead of "...select one of the physical...", it should say, "...select a physical...". Alternatively, if the first item in the list is always selected (making it impossible to select nothing if the list is non-empty), then the physical device radio button could be greyed out when the list is empty; this would make this error message entirely unnecessary.

Perhaps this dialog (or the wizard) should mention installing hal if the list is empty (which was the reason the list was empty for me).

Reproducible: Always
Comment 1 Richard Laager 2009-01-23 19:44:57 EST
The text changes were applied here: http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virt-manager--devel/rev/e2056d9074e5

Cole Robinson had this to say on the et-mgmt-tools list:
> > Alternatively, if the first item in the list is always selected (making it
> > impossible to select nothing if the list is non-empty), then the physical
> > device radio button could be greyed out when the list is empty; this would
> > make this error message entirely unnecessary.  
> 
> Yes, this is a reasonable change.
> 
> > 
> > Perhaps this dialog (or the wizard) should mention installing hal if the list
> > is empty (which was the reason the list was empty for me).
> 
> Maybe if any hal calls fail, we disable the drop down and put up add a
> tooltip or something like that.
Comment 2 Cole Robinson 2009-03-09 21:23:56 EDT
This UI has been completely redesigned upstream, and the above suggestions no longer apply. Thanks for following up with this nonetheless.

(If you wiktel folk wanted to check out the new designs and file another slew of bugs, I'd be psyched. You guys have good eyes for this stuff!)

Closing as UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.