Bug 478410 - gnome-subtitles crash on start
gnome-subtitles crash on start
Status: CLOSED DUPLICATE of bug 468594
Product: Fedora
Classification: Fedora
Component: gnome-subtitles (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Julian Sikorski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-29 13:27 EST by Alexey Kuznetsov
Modified: 2008-12-29 14:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-29 13:33:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Kuznetsov 2008-12-29 13:27:41 EST
[axet@axet-laptop ~]$ gnome-subtitles 
Got 22 languages.

(gnome-subtitles:9565): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(gnome-subtitles:9565): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(gnome-subtitles:9565): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(gnome-subtitles:9565): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(gnome-subtitles:9565): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(gnome-subtitles:9565): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(gnome-subtitles:9565): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(gnome-subtitles:9565): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(gnome-subtitles:9565): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
Marshaling output signal
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.InvalidCastException: Cannot cast from source type to destination type.
  at GLib.Value.set_Val (System.Object value) [0x00000] 
  at GLib.SignalClosure.MarshalCallback (IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data) [0x00000] 
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at GLib.SignalClosure.MarshalCallback(IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data)
   at GLib.Object.g_object_set_property(IntPtr , IntPtr , Value ByRef )
   at GLib.Object.SetProperty(System.String name, Value val)
   at Gtk.Widget.set_Visible(Boolean value)
   at GnomeSubtitles.GUI..ctor(GnomeSubtitles.EventHandlers handlers, Glade.XML ByRef glade)
   at GnomeSubtitles.Global.Init(GnomeSubtitles.Execution exec)
   at GnomeSubtitles.Global.Run(GnomeSubtitles.Execution execution)
   at GnomeSubtitles.Executable.Main(System.String[] args)
[axet@axet-laptop ~]$
Comment 1 Julian Sikorski 2008-12-29 13:33:28 EST
Install gtk-sharp-2.12.7 from testing, it should help.

*** This bug has been marked as a duplicate of bug 468594 ***
Comment 2 Alexey Kuznetsov 2008-12-29 13:40:14 EST
i have no gtk-sharp2 installed, missing depenency?
Comment 3 Julian Sikorski 2008-12-29 13:59:16 EST
the package is called gtk-sharp2: gtk-sharp2-2.12.7-1.fc10.1.x86_64. It is required for gnome-subtitles to work at all.
Comment 4 Alexey Kuznetsov 2008-12-29 14:23:54 EST
ok, after i install it everyting works fine (almost, still crashed in other place).

but i told about missing depenency for gnome-subtitles. he should have gtk-sharp2 as requirements.

Note You need to log in before you can comment on or make changes to this bug.