This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 478415 - user cannot access DVD-ROM created in MS Windows (Joliet extension)
user cannot access DVD-ROM created in MS Windows (Joliet extension)
Status: CLOSED DUPLICATE of bug 160945
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-29 14:21 EST by Jaroslav Franek
Modified: 2009-05-24 03:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-24 03:32:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Franek 2008-12-29 14:21:10 EST
Description of problem:

Using KDE 4.1.3. When DVD-ROM is inserted into the drive, it is shown in Device Notifier. When clicking the icon in Device Notifier (it says Open with Dolphin), the DVD-ROM is mounted. However as a user I cannot access it. Access works under root. I had no such problem in Fedora 7 or 9.

This happens now for all my DVDs created in MS Windows using Joliet extension. For DVDs created under Linux with both Linux/Windows support, the access for user works well. Original/printed DVDs work well, too.

The problem appears on two of my notebooks installed separately (i386 and x86_64).


Version-Release number of selected component (if applicable):
KDE 4.1.3
kernel-2.6.27.9-159.fc10.i686
hal-0.5.12-12.20081027git.fc10.i386
udev-127-3.fc10.i386

How reproducible:
see description of the problem

Steps to Reproduce:
1. Start a KDE session
2. insert a DVD created in MS Windows using Joliet extension (no UDF)
3. use Device Notifier to mount the DVD
4. try access the DVD as a user
  
Actual results:
Access denied to /media/<volume name>

/var/log/messages :
Dec 29 19:52:40 localhost kernel: UDF-fs: Partition marked readonly; forcing readonly mount
Dec 29 19:52:40 localhost kernel: UDF-fs INFO UDF: Mounting volume 'P001', timestamp 2004/08/26 15:36 (103c)
Dec 29 19:52:40 localhost gnome-keyring-daemon[4126]: adding removable location: volume_label_P001 at /media/P001
Dec 29 19:52:40 localhost hald: mounted /dev/sr0 on behalf of uid 500

ll /media :
dr--r--r--  8 franekj 4294967295  508 2004-08-26 16:36 P001
(here I miss the x permission to enter the directory)

/etc/mtab :
/dev/sr0 /media/P001 udf ro,nosuid,nodev,uhelper=hal,uid=500 0 0


Expected results:
DVD accessible to user.


Additional info:
I guess this feature (user access to Joliet DVD-ROMs) should work by default without requiring a poor user to configure it.

For comparison when using DVD-ROM created under Linux I got:

/var/log/messages :
Dec 29 20:11:49 localhost gnome-keyring-daemon[4126]: adding removable location: volume_label_P089 at /media/P089
Dec 29 20:11:49 localhost hald: mounted /dev/sr0 on behalf of uid 500

ll /media :
dr-xr-xr-x  4 franekj root    2048 2008-11-30 00:17 P089
(you see the difference, the x permission allows me to access the DVD)

/etc/mtab :
/dev/sr0 /media/P089 iso9660 ro,nosuid,nodev,uhelper=hal,uid=500,utf8 0 0
Comment 1 Axel Thimm 2009-05-23 17:15:33 EDT
"Me too"

The real bug seems to be in the authoring software, and one could argue that Fedora is doing the proper thing by accepting the missing executable bits as offered on the DVD.

But there are too many such home made DVDs out there and users switching (or trying to switch) to Fedora cannot understand that their DVDs that worked under Windows and conventional DVD players don't work under Fedora.

Therefore Fedora should offer a workaround to relax permissions on video DVDs.

FWIW I tested this on rawhide/F11.
Comment 2 Axel Thimm 2009-05-24 03:32:46 EDT

*** This bug has been marked as a duplicate of bug 160945 ***

Note You need to log in before you can comment on or make changes to this bug.