Bug 478424 - kernel-2.6.29-0.6.rc0.git2.fc11.x86_64 (and -0.5.rc0) "white screens" compiz....
kernel-2.6.29-0.6.rc0.git2.fc11.x86_64 (and -0.5.rc0) "white screens" compiz....
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-29 16:29 EST by Tom London
Modified: 2009-10-26 07:40 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-26 07:40:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of dmesg obtained from alternate console with "white screen" (45.30 KB, text/plain)
2008-12-29 16:29 EST, Tom London
no flags Details
Xorg.0.log generated with "white screen" (387.55 KB, text/plain)
2008-12-29 16:30 EST, Tom London
no flags Details
~/.xsession-errors generated with "white screen" (3.15 KB, text/plain)
2008-12-29 16:31 EST, Tom London
no flags Details

  None (edit)
Description Tom London 2008-12-29 16:29:42 EST
Created attachment 327930 [details]
Output of dmesg obtained from alternate console with "white screen"

Description of problem:
Downloaded kernel-2.6.29-0.6.rc0.git2.fc11.x86_64 from koji.

Appears to boot up fine, gdm login promt is OK, and gnome stuff displays fine, until compiz is started.  Then I get the "white screen of indifference": can see/move cursor, but screen is 100% white.

Ctrl-alt-F2 works fine, as does booting up kernel-2.6.28-3.fc11.x86_64.

I'll attach dmesg, .xsession-errors and Xorg.0.log.

I spotted this in /var/log/messages/dmesg:

Xorg:2606 map pfn expected mapping type write-back for e1800000-e1e40000, got uncached-minus
Xorg:2606 freeing invalid memtype e1800000-e1e40000

Haven't seen this with previous kernels.

I did try to revert to previous version of xorg-x11-server-*, but that did not resolve the issue.

It does seem that booting without compiz may work..... I believe there is a command line command to turn off compiz.  I'll try to locate and try.

Version-Release number of selected component (if applicable):
kernel-2.6.29-0.6.rc0.git2.fc11.x86_64

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-12-29 16:30:52 EST
Created attachment 327931 [details]
Xorg.0.log generated with "white screen"
Comment 2 Tom London 2008-12-29 16:31:26 EST
Created attachment 327932 [details]
~/.xsession-errors generated with "white screen"
Comment 3 Tom London 2008-12-29 16:32:00 EST
Oops, forgot to add:

System is Thinkpad X61 with Intel 965 graphics.
Comment 4 Tom London 2008-12-29 22:53:56 EST
Looking at Xorg.0.log, I see:

(II) AIGLX: Screen 0 is not DRI2 capable
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 15, (OK)
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 15, (OK)
drmOpenByBusid: drmOpenMinor returns 15
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
(EE) AIGLX error: drmMap of framebuffer failed (Resource temporarily unavailable)(EE) AIGLX: reverting to software rendering
(II) AIGLX: Loaded and initialized /usr/lib64/dri/swrast_dri.so
(II) GLX: Initialized DRISWRAST GL provider for screen 0


Equivalent lines from a "working" Xorg.0.log:

(II) AIGLX: Screen 0 is not DRI2 capable
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 15, (OK)
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 15, (OK)
drmOpenByBusid: drmOpenMinor returns 15
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
(II) AIGLX: enabled GLX_SGI_make_current_read
(II) AIGLX: enabled GLX_MESA_copy_sub_buffer
(II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
(II) AIGLX: enabled GLX_texture_from_pixmap with driver support
(II) AIGLX: Loaded and initialized /usr/lib64/dri/i965_dri.so
(II) GLX: Initialized DRI GL provider for screen 0


Sorry if this is an xorg-x11 issue.....
Comment 5 Tom London 2008-12-30 09:55:08 EST
Disabling "Desktop Effects" allows system to boot up to gnome/etc.
Comment 6 Tom London 2008-12-30 11:34:37 EST
Noticed this similar message when running with compiz disabled:

Dec 30 07:49:38 tlondon kernel: gnome-screensav:3900 map pfn expected mapping type write-back for e1800000-e1e40000, got uncached-minus
Dec 30 07:49:38 tlondon kernel: gnome-screensav:3900 freeing invalid memtype e1800000-e1e40000

Looks similar to the one above....
Comment 7 Sachin Garg 2008-12-30 13:11:32 EST
I am also having the similar issue with GM965 and i386. But no issues with metacity composite manager "metacity -c". White screen is only with compiz
Comment 8 Tom London 2008-12-30 19:16:04 EST
For completeness:

Also see the following (similar) messages:

Dec 30 15:59:28 tlondon kernel: glxgears:3589 map pfn expected mapping type write-back for e1800000-e1e40000, got uncached-minus
Dec 30 15:59:28 tlondon kernel: glxgears:3589 freeing invalid memtype e1800000-e1e40000
Comment 9 Sachin Garg 2008-12-30 19:56:12 EST
when booted with 2.6.29-0.6.rc0.git2.fc11.i686 (output of glxinfo)
-----------------------------------------------
OpenGL vendor string: Mesa Project
OpenGL renderer string: Software Rasterizer
OpenGL version string: 2.1 Mesa 7.3-devel
OpenGL shading language version string: 1.10


when booted with 2.6.28-3.fc11.i686 (output of glxinfo)
------------------------------------

OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 965GM GEM 20080716 x86/MMX/SSE2
OpenGL version string: 2.1 Mesa 7.3-devel
OpenGL shading language version string: 1.10
Comment 10 sangu 2008-12-30 20:57:41 EST
in NVidia proprietary  driver
$dmesg 
[skip]
Xorg:2576 map pfn expected mapping type write-combining for d8000000-d88e8000, g
ot uncached-minus
Xorg:2576 freeing invalid memtype d8000000-d88e8000
Xorg:2589 map pfn expected mapping type write-combining for d8000000-d88e8000, g
ot uncached-minus
Xorg:2589 freeing invalid memtype d8000000-d88e8000
eth0: no link during initialization.
ADDRCONF(NETDEV_UP): eth0: link is not ready
...
Comment 11 Horst H. von Brand 2009-01-02 16:33:12 EST
(In reply to comment #5)
> Disabling "Desktop Effects" allows system to boot up to gnome/etc.

I have "Desktop Effects" disabled here, white screen.

kernel-2.6.29-0.6.rc0.git2.fc11.x86_64
kernel-2.6.29-0.7.rc0.git3.fc11.x86_64

Sorry, just noticed that System --> Preferences --> Look and Feel --> Desktop Effects always offers to enable, never to disable...
Comment 12 Horst H. von Brand 2009-01-03 08:56:17 EST
After really setting Desktop Effects off, and rebooting into kernel-2.6.29-0.7.rc0.git3.fc11.x86_64, after a short while X hangs completely. No mouse movement, ctrl-alt-BS or ctrl-alt-F2 do nothing. Had to turn off (notebook, no reset button).
Comment 13 Tom London 2009-01-03 11:02:28 EST
Yeah, I've seen this too.

When this happened, I tried to ssh into the laptop from another system, but this failed.

Suspect the system is "really, really dead".

On subsequent boot, I could find no evidence or spew from the crash: I checked /var/log/messages, /var/log/Xorg.0.log, ~/.xsession-errors, etc.
Comment 14 drago01 2009-01-04 12:21:16 EST
Does passing "nopat" to the kernel help?
Comment 15 Tom London 2009-01-04 12:40:53 EST
Helps a bit....

Booting with "nopat": I no longer get the the Xorg messages about "invalid mapping type" in /var/log/messages, and glxgears runs much faster (about 930 fps vs. about 250).

But compiz won't start:
compiz (core) - Error: Could not acquire compositing manager selection on screen 0 display ":0.0"
compiz (core) - Fatal: No manageable screens found on display :0.0
gtk-window-decorator: Screen 0 on display ":0.0" already has a decoration manager; try using the --replace option to replace the current decoration manager.
compiz (core) - Error: Could not acquire compositing manager selection on screen 0 display ":0.0"
compiz (core) - Fatal: No manageable screens found on display :0.0

But it no longer "white screens".....
Comment 16 Sachin Garg 2009-01-04 12:52:43 EST
thnx .. "nopat" works for me.

Tom,

check if you have metacity compositing enabled. if it is please disable it and try

/apps/metacity/general/compositing_manager
Comment 17 Sachin Garg 2009-01-04 12:55:19 EST
glxinfo output is again following

OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 965GM GEM 20080716 x86/MMX/SSE2
OpenGL version string: 2.1 Mesa 7.3-devel
OpenGL shading language version string: 1.10
Comment 18 Tom London 2009-01-04 21:35:24 EST
(In reply to comment #16)
> thnx .. "nopat" works for me.
> 
> Tom,
> 
> check if you have metacity compositing enabled. if it is please disable it and
> try
> 
> /apps/metacity/general/compositing_manager

Yeah, that fixed it for me.

Not sure how that got set, since I've been using compiz for quite a while....

So is "nopat" a fix or a workaround?  Is this something I should be adding to my grub.conf?
Comment 19 drago01 2009-01-05 01:43:14 EST
(In reply to comment #18)
> (In reply to comment #16)
> > thnx .. "nopat" works for me.
> > 
> > Tom,
> > 
> > check if you have metacity compositing enabled. if it is please disable it and
> > try
> > 
> > /apps/metacity/general/compositing_manager
> 
> Yeah, that fixed it for me.
> 
> Not sure how that got set, since I've been using compiz for quite a while....
> 
> So is "nopat" a fix or a workaround?  Is this something I should be adding to
> my grub.conf?

Its a workaround. 
This is a regression in the upstream kernel. A upstream report (lkml) wouldn't hurt.
Comment 20 Horst H. von Brand 2009-01-05 08:10:15 EST
(In reply to comment #12)
> After really setting Desktop Effects off, and rebooting into
> kernel-2.6.29-0.7.rc0.git3.fc11.x86_64, after a short while X hangs completely.
> No mouse movement, ctrl-alt-BS or ctrl-alt-F2 do nothing. Had to turn off
> (notebook, no reset button).

Yesterday it did work for quite a while with kernel-2.6.29-0.9.rc0.git4.fc11.x86_64, today it hang in GDM after entering the password.
Comment 21 Tom London 2009-01-05 10:13:49 EST
(In reply to comment #20)
> (In reply to comment #12)
> > After really setting Desktop Effects off, and rebooting into
> > kernel-2.6.29-0.7.rc0.git3.fc11.x86_64, after a short while X hangs completely.
> > No mouse movement, ctrl-alt-BS or ctrl-alt-F2 do nothing. Had to turn off
> > (notebook, no reset button).
> 
> Yesterday it did work for quite a while with
> kernel-2.6.29-0.9.rc0.git4.fc11.x86_64, today it hang in GDM after entering the
> password.

I've had random "hard freezes" (one or two) too.

Not sure this is the same problem or another issue.

When I reboot, I see no evidence or error logging, so I'm at a loss of what to report.
Comment 22 Horst H. von Brand 2009-01-08 11:38:27 EST
With kernel-2.6.29-0.12.rc0.git7.fc11.x86_64 no mouse works at all (USB mouse or touchpad).
Comment 23 Tom London 2009-01-08 12:33:09 EST
I've noticed that on some boots, HAL fails to start properly, and when this happens, I get gdm login screen, but no mouse or keyboard.

I haven't been able to track this down further, but rebooting "fixes this" until it happens again.....
Comment 24 Masao Takahashi 2009-01-09 01:46:14 EST
I have experienced this problem.
Disabling PAT using "menuconfig" resolves this problem.
But compiz does not work. 
 The previous stable kernel-2.6.28 is good.
Comment 25 Tom London 2009-01-14 17:43:47 EST
compiz "works for me" (without whitescreen!) with kernel-2.6.29-0.35.rc1.git4.fc11.x86_64 without "nopat".

Running Thinkpad X200 (with Intel Corporation Cantiga Integrated Graphics Controller) without xorg.conf.
Comment 26 keith 2009-02-14 06:19:06 EST
I have been seeing the white screen (where everything locks) using 2.6.29-0.112.rc4.git3.fc11.x86_64.

This happens regardless of driver (NVidia GeForce 7000 series); I have tried, nv, nouveau and proprietary.

If I use the Desktop effects applet (as opposed to commpand line 'compiz --replace') it will not lock so hard, at this time in dmesg I can see:

compiz[3805]: segfault at 3ff782ebd0 ip 0000003ff782ebd0 sp 00007fffa1933328 error 14 in libxml2.so.2.7.3[3ff8400000+152000]
Comment 27 keith 2009-02-14 06:28:05 EST
nopat stops the white screen, but compiz still fails .. can't find anything logged regards to why
Comment 28 Bug Zapper 2009-06-09 06:32:46 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 29 Vedran Miletić 2009-10-26 07:40:15 EDT
Closing per comment #25.

From keith, what you are seeing is a separate bug and has nothing to do with this one. However:
1) nouveau and nv don't support 3D (and therefore compiz),
2) nvidia proprietary driver is not supported by Fedora.

And, from my experience, this could be an example of broken hardware.

Note You need to log in before you can comment on or make changes to this bug.