Bug 478445 - mozilla-config.h not on cflags include path
mozilla-config.h not on cflags include path
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-30 02:36 EST by Troy A. Griffitts
Modified: 2009-01-08 05:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-08 05:49:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Troy A. Griffitts 2008-12-30 02:36:39 EST
Description of problem:
When attempting to compile an application which uses libxul, pkg-config --cflags libxul reports an -I include path of:

-I/usr/include/xulrunner-sdk-1.9/stable

but the critical mozilla-config.h header is distributed in the path:

/usr/include/xulrunner-sdk-1.9/mozilla-config.h

This results in libxul being unusable without a manual patch.

mozilla-config.h used to be distributed in the ../unstable directory in previous packages, which was on the include path.

Suggest to distribute in ../stable or add .. to the .pc file distributed with the package.


Version-Release number of selected component (if applicable):

xulrunner-devel-1.9.0.5-1.fc10.x86_64
xulrunner-devel-1.9.0.5-1.fc10.i386


How reproducible:

pkg-config --cflags libxul
rpm -ql xulrunner-devel|grep mozilla-config.h

Actual results:

-fshort-wchar -I/usr/include/xulrunner-sdk-1.9/stable -I/usr/include/nspr4  
/usr/include/xulrunner-sdk-1.9/mozilla-config.h

Expected results:

-fshort-wchar -I/usr/include/xulrunner-sdk-1.9/stable -I/usr/include/nspr4  
/usr/include/xulrunner-sdk-1.9/stable/mozilla-config.h

Additional info:
Comment 1 Troy A. Griffitts 2008-12-30 02:42:54 EST
actually, probably better expected results:

-fshort-wchar -I/usr/include/xulrunner-sdk-1.9/stable -I/usr/include/xulrunner-sdk-1.9 -I/usr/include/nspr4  
/usr/include/xulrunner-sdk-1.9/mozilla-config.h
Comment 2 Martin Stransky 2009-01-07 16:02:07 EST
We need to add mozilla-config.h to stable directory because it's important for NPAPI plugins.
Comment 3 Martin Stransky 2009-01-08 05:49:24 EST
added to xulrunner-1.9.0.5-2.fc10
Comment 4 Fedora Update System 2009-01-08 05:51:04 EST
seamonkey-1.1.14-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/seamonkey-1.1.14-4.fc10

Note You need to log in before you can comment on or make changes to this bug.