Bug 478448 - RHEL 5.3. Release Notes page under Japanese installation is chaos
RHEL 5.3. Release Notes page under Japanese installation is chaos
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: redhat-release-notes (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Ryan Lerch
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-30 04:46 EST by lihuang
Modified: 2009-08-20 00:24 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:01:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (757.57 KB, image/png)
2008-12-30 04:46 EST, lihuang
no flags Details
fix - prepend html header with charset info also in case we get mime info (756 bytes, patch)
2009-01-05 09:22 EST, Radek Vykydal
no flags Details | Diff

  None (edit)
Description lihuang 2008-12-30 04:46:03 EST
Created attachment 327956 [details]
screen shot

Description of problem:
see the screen shot 

Version-Release number of selected component (if applicable):
RHEL5.3-Client-20081218.0  and 
RHEL5.3-Client-20081229.0

How reproducible:
Every Time 

Steps to Reproduce:
1.Choose Japanese to install the RHEL5.3 nightly release
2.Click "リリースノート"button to check the release note.
3.
  
Actual results:
see the screen shot 

Expected results:
decode the Japanese correctly 

Additional info:
Comment 1 Radek Vykydal 2009-01-05 09:22:24 EST
Created attachment 328197 [details]
fix - prepend html header with charset info also in case we get mime info

The patch fixes the bug.
I am going to investigate a little more why the bug occured
and whether the patch is the best way.
Comment 2 Radek Vykydal 2009-01-05 11:29:17 EST
> I am going to investigate a little more why the bug occured
> and whether the patch is the best way.

It is not good, the tagging is broken with the patch,
so 
xmlns="http://www.w3.org/1999/xhtml">
line appears at the top of relnotes and other bad things could
happen.

We moved to XHTML 1.0 for release notes in 5.3
and it seems that we need to add a meta http-equiv statement
with encoding:
<meta http-equiv="Content-type" content="charset=utf-8" />)
into relnotes html file (it is also recommended in
xhtml 1.0 specification).
Comment 3 Denise Dumas 2009-01-05 11:33:53 EST
Since the fix is to the release notes file itself, reassigning to that component.
Comment 5 Vladimir Benes 2009-01-05 13:22:07 EST
other issues also seen when using i.e. French or Spanish
Comment 6 Michael Hideo 2009-01-05 17:00:29 EST
Ryan please generate the html and send them to me so i can investigate the rendering issue.
Comment 7 Don Domingo 2009-01-05 23:08:15 EST
problem fixed by adding the meta statement between the <head> and <title> tags for all htmls.

<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
Comment 13 errata-xmlrpc 2009-01-20 16:01:04 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0106.html

Note You need to log in before you can comment on or make changes to this bug.