Bug 478464 - /usr/bin/ecryptfs-setup-private errors out.
/usr/bin/ecryptfs-setup-private errors out.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ecryptfs-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-30 11:23 EST by Sachin Garg
Modified: 2009-01-12 12:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 12:06:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachin Garg 2008-12-30 11:23:26 EST
Description of problem:

On the running the /usr/bin/ecryptfs-setup-private. I get following error

[sachin@sachin-laptop ~]$ ecryptfs-setup-private 
/usr/bin/ecryptfs-setup-private: line 117: syntax error near unexpected token `exit'
/usr/bin/ecryptfs-setup-private: line 117: `			exit 0'


Version-Release number of selected component (if applicable):

ecryptfs-utils-67-1.fc11.i386

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Michal Hlavinka 2008-12-31 06:32:59 EST
This is fixed in version 68. I have update commit prepared, but this version requires some binary ('line') for passphrase input and I can't find out what package provides it... I'll update ecryptfs-utils as soon as I find it out :o)

This bug is caused by "undo()" command in ecryptfs-setup-private, if you replace "undo()" on this line with just "undo", it'll work.
Comment 2 Sachin Garg 2008-12-31 10:40:24 EST
Thank you ..
Comment 3 Michal Hlavinka 2009-01-12 12:06:19 EST
fixed since ecryptfs-utils-68-0.fc11

Note You need to log in before you can comment on or make changes to this bug.