Bug 478551 - New autodl.glade file for autodownloader
New autodl.glade file for autodownloader
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: autodownloader (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-31 15:25 EST by Mohd Izhar Firdaus Ismail
Modified: 2009-02-13 03:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 03:05:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
new autodl.glade (22.64 KB, application/x-glade)
2008-12-31 15:26 EST, Mohd Izhar Firdaus Ismail
no flags Details

  None (edit)
Description Mohd Izhar Firdaus Ismail 2008-12-31 15:25:05 EST
Description of problem:

I noticed the UI for autodownloader is quite inconsistent with GTK apps. It seems the glade uses a lot of GtkFixed for layout which is quite messy.

I've recreated the autodl.glade to use GTK Hbox/Vbox packing and cleaned up the UI where I feel fit. 

Attached together the glade file. Its a drop in replacement for the original autodl.glade file.

Thank you
Comment 1 Mohd Izhar Firdaus Ismail 2008-12-31 15:26:25 EST
Created attachment 328019 [details]
new autodl.glade
Comment 2 Hans de Goede 2009-01-11 14:43:00 EST
Thanks, I've given it a try, but there are some issues:
1) The 2 initial screens are somewhat smaller then original
2) The progressbar screen takes the width of the URL of the file being downloaded
   instead of being the same size as the initial screens, also when downloading
   multiple files it keeps changing size

Can you please fix these 2 issues?

Question what problem exactly are you trying to solve? Yes the old version is static, but it is non resizable, so I see no issues with it.
Comment 3 Hans de Goede 2009-02-13 03:05:58 EST
Closing due to lack of response from reporter, feel free to re-open if you can fix the issues with your patch mentioned in comment #2.

Note You need to log in before you can comment on or make changes to this bug.