Bug 478562 - clock-applet crashes.
clock-applet crashes.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libsoup (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-31 20:40 EST by sangu
Modified: 2009-01-30 09:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-30 09:10:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 563145 None None None Never

  None (edit)
Description sangu 2008-12-31 20:40:42 EST
Description of problem:
Distribution: Fedora release 10.90 (Rawhide)
Gnome Release: 2.25.3 2008-12-17 (Red Hat, Inc)
BugBuddy Version: 2.25.2

System: Linux 2.6.28-3.fc11.i686 #1 SMP Fri Dec 26 08:07:00 EST 2008 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10503000
Selinux: No
Accessibility: Disabled
GTK+ Theme: Clearlooks
Icon Theme: gnome
GTK+ Modules: canberra-gtk-module, gnomebreakpad

Memory status: size: 88588288 vsize: 88588288 resident: 37167104 share: 16338944 rss: 37167104 rss_rlim: 18446744073709551615
CPU usage: start_time: 1230764723 rtime: 284 utime: 256 stime: 28 cutime:0 cstime: 0 timeout: 0 it_real_value: 0 frequency: 100

Backtrace was generated from '/usr/libexec/clock-applet'

[Thread debugging using libthread_db enabled]
0x00130416 in __kernel_vsyscall ()
#0  0x00130416 in __kernel_vsyscall ()
#1  0x021220db in waitpid () from /lib/libpthread.so.0
#2  0x00f4cfe7 in IA__g_spawn_sync (working_directory=0x0, argv=0x8db9680, 
    envp=0x0, flags=<value optimized out>, child_setup=0, user_data=0x0, 
    standard_output=0x0, standard_error=0x0, exit_status=0x0, 
    error=0xbfac1a88) at gspawn.c:382
#3  0x00f4d32c in IA__g_spawn_command_line_sync (
    command_line=0x8d5cfe0 "bug-buddy --appname=\"clock-applet\" --pid=3165", 
    standard_output=0x0, standard_error=0x0, exit_status=0x0, 
    error=0xbfac1a88) at gspawn.c:694
#4  0x049f25ae in run_bug_buddy (appname=0x813c498 "clock-applet", pid=3165, 
    minidump_path=0x0) at gnome-breakpad.cc:369
#5  0x049f2c38 in check_if_gdb () at gnome-breakpad.cc:440
#6  bugbuddy_segv_handle (signum=11) at gnome-breakpad.cc:223
#7  <signal handler called>
#8  free_proxy_settings (priv=0x0) at soup-proxy-resolver-gconf.c:114
#9  0x0122c622 in gconf_value_changed (client=0x8192af8, 
    key=0x8dbc568 "/apps/panel/applets/clock/prefs/cities", value=0x8d389b0, 
    user_data=0x8d13e50) at soup-proxy-resolver-gconf.c:186
#10 0x00765f93 in gconf_marshal_VOID__STRING_POINTER (closure=0x81cf808, 
    return_value=0x0, n_param_values=3, param_values=0x8d45b50, 
    invocation_hint=0xbfac22dc, marshal_data=0x122c5f0) at gconfmarshal.c:84
#11 0x00e9e22b in IA__g_closure_invoke (closure=0x81cf808, return_value=0x0, 
    n_param_values=3, param_values=0x8d45b50, invocation_hint=0xbfac22dc)
    at gclosure.c:767
#12 0x00eb5c25 in signal_emit_unlocked_R (node=0x81a1320, detail=0, 
    instance=0x8192af8, emission_return=0x0, instance_and_params=0x8d45b50)
    at gsignal.c:3244
#13 0x00eb733e in IA__g_signal_emit_valist (instance=0x8192af8, 
    signal_id=150, detail=0, var_args=0xbfac2484 "\001") at gsignal.c:2977
#14 0x00eb77e6 in IA__g_signal_emit (instance=0x8192af8, signal_id=150, 
    detail=0) at gsignal.c:3034
#15 0x007625bf in gconf_client_value_changed (client=0x8192af8, 
    key=0x8e08df0 "/apps/panel/applets/clock/prefs/cities", value=0x8d389b0)
    at gconf-client.c:1891
#16 0x00762638 in notify_one_entry (client=0x8192af8, entry=0x8db2b30)
    at gconf-client.c:2398
#17 0x00762760 in gconf_client_flush_notifies (client=<value optimized out>)
    at gconf-client.c:2450
#18 notify_idle_callback (data=0x8192af8) at gconf-client.c:2344
#19 0x00f117a1 in g_idle_dispatch (source=0x8d72450, callback=0, 
    user_data=0x8192af8) at gmain.c:3924
#20 0x00f136d8 in g_main_dispatch (context=<value optimized out>)
    at gmain.c:1814
#21 IA__g_main_context_dispatch (context=0x815f430) at gmain.c:2367
#22 0x00f16d83 in g_main_context_iterate (context=0x815f430, block=1, 
    dispatch=1, self=0x8146b10) at gmain.c:2448
#23 0x00f172a2 in IA__g_main_loop_run (loop=0x81996b0) at gmain.c:2656
#24 0x004c0a13 in bonobo_main () at bonobo-main.c:311
#25 0x004bebd9 in bonobo_generic_factory_main_timeout (
    act_iid=0x8199500 ":0.0,OAFIID:GNOME_ClockApplet_Factory", 
    factory_cb=0x137400 <panel_applet_factory_callback>, user_data=0x81994f0, 
    quit_timeout=2000) at bonobo-generic-factory.c:411
#26 0x004bec63 in bonobo_generic_factory_main (
    act_iid=0x8199500 ":0.0,OAFIID:GNOME_ClockApplet_Factory", 
    factory_cb=0x137400 <panel_applet_factory_callback>, user_data=0x81994f0)
    at bonobo-generic-factory.c:368
#27 0x00137c9d in panel_applet_factory_main_closure (
    iid=0x8069ecc "OAFIID:GNOME_ClockApplet_Factory", applet_type=135894024, 
    closure=<value optimized out>) at panel-applet.c:1742
#28 0x00137d8b in panel_applet_factory_main (
    iid=0x8069ecc "OAFIID:GNOME_ClockApplet_Factory", applet_type=135894024, 
    callback=0x805ca70 <clock_factory>, data=0x0) at panel-applet.c:1766
#29 0x08056c84 in main (argc=1, argv=0xbfac2804) at clock.c:3800

Thread 1 (Thread 0xb808e760 (LWP 3165)):
#0  0x00130416 in __kernel_vsyscall ()
No symbol table info available.
#1  0x021220db in waitpid () from /lib/libpthread.so.0
No locals.
#2  0x00f4cfe7 in IA__g_spawn_sync (working_directory=0x0, argv=0x8db9680, 
    envp=0x0, flags=<value optimized out>, child_setup=0, user_data=0x0, 
    standard_output=0x0, standard_error=0x0, exit_status=0x0, 
    error=0xbfac1a88) at gspawn.c:382
	outpipe = -1
	errpipe = -1
	pid = 15651
	fds = {__fds_bits = {15842742, 160, 0, 8, 16512536, 0, 148919960, 
    -1079240296, 15940241, 8, 148919960, 4, 16512536, 0, 148608652, 
    -1079240200, 15926813, 148919960, 15842688, 0, 18288628, 18293056, 
    148934632, 10, -1079240216, -1079240220, 148608640, 3, 0, 2, 891429572, 
    148919960}}
	ret = <value optimized out>
	outstr = (GString *) 0x0
	errstr = (GString *) 0x0
	failed = 0
	status = <value optimized out>
	__PRETTY_FUNCTION__ = "IA__g_spawn_sync"
#3  0x00f4d32c in IA__g_spawn_command_line_sync (
    command_line=0x8d5cfe0 "bug-buddy --appname=\"clock-applet\" --pid=3165", 
    standard_output=0x0, standard_error=0x0, exit_status=0x0, 
    error=0xbfac1a88) at gspawn.c:694
	retval = 0
	argv = (gchar **) 0x8db9680
	__PRETTY_FUNCTION__ = "IA__g_spawn_command_line_sync"
#4  0x049f25ae in run_bug_buddy (appname=0x813c498 "clock-applet", pid=3165, 
    minidump_path=0x0) at gnome-breakpad.cc:369
	res = <value optimized out>
	warning_file = 0x8e002f0 "\220$\027\001\220$\027\001è\002à\bè\002à\b"
	exec_str = 0x8d5cfe0 "bug-buddy --appname=\"clock-applet\" --pid=3165"
	args_str = <value optimized out>
	error = (GError *) 0x0
#5  0x049f2c38 in check_if_gdb () at gnome-breakpad.cc:440
	mypath = 0x8dbea20 "p\"\027\001p\"\027\001exec/clock-applet"
	gdb = (gchar *) 0x81570b0 "/usr/bin/gdb"
	has_debug_symbols = true
	appname = (gchar *) 0x813c498 "clock-applet"
	pid = 3165
#6  bugbuddy_segv_handle (signum=11) at gnome-breakpad.cc:223
	in_segv = 1
#7  <signal handler called>
No symbol table info available.
#8  free_proxy_settings (priv=0x0) at soup-proxy-resolver-gconf.c:114
	l = <value optimized out>
#9  0x0122c622 in gconf_value_changed (client=0x8192af8, 
    key=0x8dbc568 "/apps/panel/applets/clock/prefs/cities", value=0x8d389b0, 
    user_data=0x8d13e50) at soup-proxy-resolver-gconf.c:186
No locals.
#10 0x00765f93 in gconf_marshal_VOID__STRING_POINTER (closure=0x81cf808, 
    return_value=0x0, n_param_values=3, param_values=0x8d45b50, 
    invocation_hint=0xbfac22dc, marshal_data=0x122c5f0) at gconfmarshal.c:84
	data1 = (gpointer) 0x8192af8
	data2 = <value optimized out>
	__PRETTY_FUNCTION__ = "gconf_marshal_VOID__STRING_POINTER"
#11 0x00e9e22b in IA__g_closure_invoke (closure=0x81cf808, return_value=0x0, 
    n_param_values=3, param_values=0x8d45b50, invocation_hint=0xbfac22dc)
    at gclosure.c:767
	marshal = (
    GClosureMarshal) 0x765f00 <gconf_marshal_VOID__STRING_POINTER>
	marshal_data = (gpointer) 0x0
	__PRETTY_FUNCTION__ = "IA__g_closure_invoke"
#12 0x00eb5c25 in signal_emit_unlocked_R (node=0x81a1320, detail=0, 
    instance=0x8192af8, emission_return=0x0, instance_and_params=0x8d45b50)
    at gsignal.c:3244
	tmp = <value optimized out>
	handler = (Handler *) 0x8d60540
	accumulator = (SignalAccumulator *) 0x0
	emission = {next = 0x0, instance = 0x8192af8, ihint = {
    signal_id = 150, detail = 0, run_type = G_SIGNAL_RUN_FIRST}, 
  state = EMISSION_RUN, chain_type = 4}
	class_closure = (GClosure *) 0x81a1548
	handler_list = (Handler *) 0x8d60540
	return_accu = (GValue *) 0x0
	accu = {g_type = 0, data = {{v_int = 0, v_uint = 0, v_long = 0, 
      v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0, 
      v_pointer = 0x0}, {v_int = 0, v_uint = 0, v_long = 0, v_ulong = 0, 
      v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0, v_pointer = 0x0}}}
	signal_id = 150
	max_sequential_handler_number = 1242
	return_value_altered = 0
#13 0x00eb733e in IA__g_signal_emit_valist (instance=0x8192af8, 
    signal_id=150, detail=0, var_args=0xbfac2484 "\001") at gsignal.c:2977
	signal_return_type = 4
	param_values = (GValue *) 0x8d45b64
	node = (SignalNode *) 0x81a1320
	i = 2
	n_params = 2
	__PRETTY_FUNCTION__ = "IA__g_signal_emit_valist"
#14 0x00eb77e6 in IA__g_signal_emit (instance=0x8192af8, signal_id=150, 
    detail=0) at gsignal.c:3034
No locals.
#15 0x007625bf in gconf_client_value_changed (client=0x8192af8, 
    key=0x8e08df0 "/apps/panel/applets/clock/prefs/cities", value=0x8d389b0)
    at gconf-client.c:1891
	__PRETTY_FUNCTION__ = "gconf_client_value_changed"
#16 0x00762638 in notify_one_entry (client=0x8192af8, entry=0x8db2b30)
    at gconf-client.c:2398
No locals.
#17 0x00762760 in gconf_client_flush_notifies (client=<value optimized out>)
    at gconf-client.c:2450
	entry = (GConfEntry *) 0x8db2b30
	tmp = (GSList *) 0x8db31a8
	last_entry = (GConfEntry *) 0x0
#18 notify_idle_callback (data=0x8192af8) at gconf-client.c:2344
No locals.
#19 0x00f117a1 in g_idle_dispatch (source=0x8d72450, callback=0, 
    user_data=0x8192af8) at gmain.c:3924
No locals.
#20 0x00f136d8 in g_main_dispatch (context=<value optimized out>)
    at gmain.c:1814
No locals.
#21 IA__g_main_context_dispatch (context=0x815f430) at gmain.c:2367
No locals.
#22 0x00f16d83 in g_main_context_iterate (context=0x815f430, block=1, 
    dispatch=1, self=0x8146b10) at gmain.c:2448
	max_priority = 200
	timeout = 0
	some_ready = 1
	nfds = 14
	allocated_nfds = <value optimized out>
	fds = (GPollFD *) 0x8db9d50
	__PRETTY_FUNCTION__ = "g_main_context_iterate"
#23 0x00f172a2 in IA__g_main_loop_run (loop=0x81996b0) at gmain.c:2656
	self = (GThread *) 0x8146b10
	__PRETTY_FUNCTION__ = "IA__g_main_loop_run"
#24 0x004c0a13 in bonobo_main () at bonobo-main.c:311
	loop = <value optimized out>
#25 0x004bebd9 in bonobo_generic_factory_main_timeout (
    act_iid=0x8199500 ":0.0,OAFIID:GNOME_ClockApplet_Factory", 
    factory_cb=0x137400 <panel_applet_factory_callback>, user_data=0x81994f0, 
    quit_timeout=2000) at bonobo-generic-factory.c:411
	context = (BonoboObject *) 0x8198630
	signal = 11
	factory = (BonoboGenericFactory *) 0x8198690
#26 0x004bec63 in bonobo_generic_factory_main (
    act_iid=0x8199500 ":0.0,OAFIID:GNOME_ClockApplet_Factory", 
    factory_cb=0x137400 <panel_applet_factory_callback>, user_data=0x81994f0)
    at bonobo-generic-factory.c:368
No locals.
#27 0x00137c9d in panel_applet_factory_main_closure (
    iid=0x8069ecc "OAFIID:GNOME_ClockApplet_Factory", applet_type=135894024, 
    closure=<value optimized out>) at panel-applet.c:1742
	retval = <value optimized out>
	display_iid = 0x8199500 ":0.0,OAFIID:GNOME_ClockApplet_Factory"
	__PRETTY_FUNCTION__ = "panel_applet_factory_main_closure"
#28 0x00137d8b in panel_applet_factory_main (
    iid=0x8069ecc "OAFIID:GNOME_ClockApplet_Factory", applet_type=135894024, 
    callback=0x805ca70 <clock_factory>, data=0x0) at panel-applet.c:1766
	closure = <value optimized out>
	__PRETTY_FUNCTION__ = "panel_applet_factory_main"
#29 0x08056c84 in main (argc=1, argv=0xbfac2804) at clock.c:3800
	context = (GOptionContext *) 0x8139478
	error = (GError *) 0x0
	retval = <value optimized out>
The program is running.  Quit anyway (and detach it)? (y or n) [answered Y; input not from terminal]


----------- .xsession-errors (57 sec old) ---------------------
** (gnome-screensaver:3040): WARNING **: Unable to find watch for alarm
** (gnome-screensaver:3040): WARNING **: Unable to find watch for alarm
** (gnome-screensaver:3040): WARNING **: Unable to find watch for alarm
** (gnome-screensaver:3040): WARNING **: Unable to find watch for alarm
** (gnome-screensaver:3040): WARNING **: Unable to find watch for alarm
(evolution:3400): e-data-server-DEBUG: Loading categories from "/home/sangu/.evolution/categories.xml"
(evolution:3400): e-data-server-DEBUG: Loaded 29 categories
Changing the queries (contains? "summary" "") 
W[ 1230772775.915635]:The length of feedback isn't aligned to 4 bytes: 0
W[ 1230772777.959529]:Error while processing a value type NestedList: Error while processing a value type CARD32: 예기치 않게 일찍 스트림이 끝났습니다
W[ 1230772777.962757]:The length of feedback isn't aligned to 4 bytes: 0
--------------------------------------------------


Version-Release number of selected component (if applicable):
2.25.3-3.fc11.i386

How reproducible:


Steps to Reproduce:
1. Add location
2. Click location
3. Click Edit
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Clasen 2009-01-30 00:09:35 EST
Looks like a crash in libsoup
Comment 2 Matthew Barnes 2009-01-30 09:10:08 EST
This is http://bugzilla.gnome.org/show_bug.cgi?id=563145.

It's already fixed in libsoup-2.25.4.

Note You need to log in before you can comment on or make changes to this bug.