This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 478575 - screensaver replace modified config file with the unmodified version
screensaver replace modified config file with the unmodified version
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-01 05:18 EST by cornel panceac
Modified: 2009-01-01 11:32 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-01 08:05:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cornel panceac 2009-01-01 05:18:42 EST
Description of problem:
updating xscreensaver-extras-gss replace the modified 

/usr/share/applications/screensavers/xscreensaver-phosphor.desktop 

with a version from the package, thus losing the 

-program fortune 

change.

Version-Release number of selected component (if applicable):

$ rpm -qf /usr/share/applications/screensavers/xscreensaver-phosphor.desktop 
xscreensaver-extras-gss-5.08-1.fc10.i386

How reproducible:


Steps to Reproduce:
1.update xscreensaver-extras-gss
2.lock the screen
3.
  
Actual results:

see (again) the annoying, boring etc story of the assistive technology on linux

Expected results:

see more fun fortune quotes


Additional info:

of course we appreciate the work different developers and organizations put on assistive technology, but seeing it again and again is too much. 
the update script should have left the original config file in place and if it is necessary just create and rpmnew config file.
Comment 1 Mamoru TASAKA 2009-01-01 08:05:07 EST
Files under %_datadir/ are not "configuration" files in your sense,
not expected to be modified, so this is not a bug.

Actually xscreensaver has a command to set options for each hack
per user named "xscreensaver-demo", so if you are using xscreensaver
as screensaver daemon you don't have to do such a thing.
From your bug report it seems gnome-screensaver cannot set options
for each hacks and always uses system settings for hacks. 

By the way phosphor calls xscreensaver-text to get the strings to
display, and xscreensaver-text reads ~/.xscreensaver to check the "mode"
of the string to output. So if you are using gnome-screensaver
as screensaver daemon and not using xscreensaver as daemon (i.e.
using xscreensaver for getting xscreensaver hacks only),

$ echo -e "textMode: program\ntextProgram: fortune" > .xscreensaver

will do what you expect.
Comment 2 Mamoru TASAKA 2009-01-01 08:07:00 EST
(In reply to comment #1)
 
> $ echo -e "textMode: program\ntextProgram: fortune" > .xscreensaver

More exactly,
$ echo -e "textMode: program\ntextProgram: fortune" > ~/.xscreensaver
Comment 3 cornel panceac 2009-01-01 08:18:24 EST
thnx a lot, it worked! however, it would be great if this could be done from system>preferences>?>screensaver so that any new user can do it without some bash strange commands :) or at least it has to be somewhere in the documentation, imho.

thnx again, have a happy new year.
Comment 4 Mamoru TASAKA 2009-01-01 10:18:42 EST
(In reply to comment #3)
> thnx a lot, it worked! 
Thank you for confirming.

> however, it would be great if this could be done from
> system>preferences>?>screensaver so that any new user can do it without some
> bash strange commands :) 
Well, the problem is, in short, xscreensaver _can_, but gnome-screensaver
cannot (perhaps.. as I use xscreensaver)

That is, when xscreensaver(-base) is installed (note: as you have phosphor
installed so xscreensaver-base must already be installed on your system)
and gnome-screensaver is _not_ be installed, when you try
"GNOME panel -> System -> Settings -> Looks & Feel -> Screensaver"
(the string may be different as I am using in Japanese environment)
then "xscreensaver-demo" launches and you can do such settings.

However when gnome-screensaver is installed, this behavior is overwritten
by gnome-screensaver. Now when "GNOME panel -> ... -> Screensaver" is
chosen, gnome-screensaver related setting program launches.

> or at least it has to be somewhere in the
> documentation, imho.
> 
> thnx again, have a happy new year.

Have a happy new year, too! (Now it is Jan 2th in Japan)
Comment 5 Mamoru TASAKA 2009-01-01 10:51:06 EST
Or to change this behavior system-widely, follow:

- Edit /etc/xscreensaver/XScreenSaver.ad.header
  (change the line "textMode" from "file" to "program"),
  save the change.
- execute $ update-xscreensaver-hacks as root
Comment 6 cornel panceac 2009-01-01 11:32:31 EST
thnx a lot, i'll try this asap.

Note You need to log in before you can comment on or make changes to this bug.