Bug 478619 - Augeas does not see /files on EPEL4
Augeas does not see /files on EPEL4
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: augeas (Show other bugs)
el4
All Linux
low Severity medium
: ---
: ---
Assigned To: David Lutterkort
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-02 05:08 EST by Arnaud Gomes-do-Vale
Modified: 2013-04-30 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-04 23:37:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -o /tmp/augeas.txt augtool quit (3.49 KB, text/plain)
2009-01-04 05:52 EST, Arnaud Gomes-do-Vale
no flags Details
Patch for building on GNU make < 3.81 (984 bytes, patch)
2009-01-04 11:05 EST, Arnaud Gomes-do-Vale
no flags Details | Diff

  None (edit)
Description Arnaud Gomes-do-Vale 2009-01-02 05:08:45 EST
Description of problem:

The /files hierarchy in augeas does not exist on EL4 (works fine on EL5).

Version-Release number of selected component (if applicable):

augeas-0.3.5-1.el4

How reproducible:

Always

Steps to Reproduce:
1. augtool ls /files
  
Actual results:

[root@swara ~]# augtool ls /files
[root@swara ~]#

Expected results:

[root@dedale ~]# augtool ls /files
etc/ = (none)
[root@dedale ~]#

Additional info:
Comment 1 David Lutterkort 2009-01-03 23:15:51 EST
Mysterious .. there was a similar bug report on the mailing list.

I need to set up a RHEL4 machine before I can try to reproduce that - in the meantime, it might help if you could run 'strace -o /tmp/augeas.txt augtool quit' and attach the file /tmp/augeas.txt to this bug (or email it to me)
Comment 2 Arnaud Gomes-do-Vale 2009-01-04 05:52:12 EST
Created attachment 328130 [details]
strace -o /tmp/augeas.txt augtool quit

Here is the output of strace.
Comment 3 Arnaud Gomes-do-Vale 2009-01-04 10:53:00 EST
I guess I have found the bug. The files src/Makefile.in and src/Makefile.am in the augeas sources contain the following line:

      echo '#define DATADIR "$(abspath $(datadir))"' > datadir.h1

This is used to define the path to the augeas/lenses subdirectory (${datadir}/augeas/lenses, that is /usr/share/augeas/lenses by default).

As far as I know, abspath has only been defined since GNU make 3.81; RHEL4 and its clones have version 3.80. So the search path becomes /augeas/lenses and obviously augtool find nothing there.
Comment 4 Arnaud Gomes-do-Vale 2009-01-04 11:05:20 EST
Created attachment 328136 [details]
Patch for building on GNU make < 3.81

Rebuilding the package with this patch fixes the issue.
Comment 5 David Lutterkort 2009-01-04 23:37:25 EST
Nice work ... excellent find.

I committed your patch upstream and built augeas-0.3.5-2 for EL-4.

Please let me know if there are still issues.

Note You need to log in before you can comment on or make changes to this bug.