Bug 478625 - copy and cut in the XmTextWidget don't work
copy and cut in the XmTextWidget don't work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openmotif22 (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Thomas Woerner
BaseOS QE
: Patch, Upstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-02 06:48 EST by Albert Flügel
Modified: 2013-04-15 05:01 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, cut and copy did not work in XmText widgets at all times. With this update, this problem has been solved.
Story Points: ---
Clone Of:
: 481170 834191 (view as bug list)
Environment:
Last Closed: 2011-11-21 16:00:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the but explained at motifzone. (584 bytes, patch)
2009-01-02 06:48 EST, Albert Flügel
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 62252 None None None Never
MotifZone 1399 None None None Never

  None (edit)
Description Albert Flügel 2009-01-02 06:48:26 EST
Created attachment 328061 [details]
Patch to fix the but explained at motifzone.

Description of problem:
Copy and Cut in the XmTextWidget don't work.

Version-Release number of selected component (if applicable):
2.3.0-0.5.el5

How reproducible:
See URL. There you see, that motifzone has accepted and included the
fix, i've explained there.

Steps to Reproduce:
1. Download the text editor
2. compile like explained in URL
3. run the text editor
4. try to copy or cut and paste text in the text editor using the Edit menu
  
Actual results:
nothing is cut or copied

Expected results:
copy and cut do work

Additional info:
see URL.
Comment 1 Albert Flügel 2009-01-02 08:16:19 EST
openmotif22 is affected in the same way and can be fixed using the same patch
Comment 2 Michal Nowak 2009-01-21 07:16:31 EST
Considering it's almost a year when the bug was fixed upstream and in Red Hat Enterprise Linux 5.3 we have, pretty recent, openmotif-2.3.1-2.el5, could you please have a look whether the bug is still present? 

W.r.t. openmotif22, feel free to clone this bug for Red Hat Enterprise Linux 4.

Thank you.
Comment 3 Albert Flügel 2009-01-21 07:52:16 EST
In openmotif-2.3.1-2.el5.src.rpm it's fixed according to the sources, in
openmotif22-2.2.3-18.src.rpm it's not fixed.
Comment 4 Michal Nowak 2009-01-21 08:12:00 EST
Thanks for the investigation, changed the component to openmotif22; openmotif is unaffected then.
Comment 6 RHEL Product and Program Management 2009-11-06 13:56:26 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 RHEL Product and Program Management 2010-08-09 15:01:53 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2011-05-31 10:16:28 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 15 Petr Kovar 2011-10-05 09:20:08 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, cut and copy did not work in XmText widgets at all times. With this update, this problem has been solved.
Comment 16 Lukas Zachar 2011-11-21 10:24:55 EST
Reproduced for old version.
Problem is fixed in the new version.
Comment 17 errata-xmlrpc 2011-11-21 16:00:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1467.html

Note You need to log in before you can comment on or make changes to this bug.