Bug 47863 - network upgrading to 7.1 (alpha) fails - missing file
network upgrading to 7.1 (alpha) fails - missing file
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
alpha Linux
high Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-08 02:34 EDT by Alexei Podtelezhnikov
Modified: 2007-03-26 23:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-19 14:55:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexei Podtelezhnikov 2001-07-08 02:34:29 EDT
From Bugzilla Helper:

Description of problem:
Post-intallation fails because anaconda
* didn't find /mnt/sysimage/usr/sbin/inetdconvert

How reproducible:
Didn't try

Steps to Reproduce:
1. Upgrading from 7.0 to 7.1 Alpha via FTP 
2. post-instalation freezes at missing inetdconverter
3.
	

Actual Results:  non-upgrade

Expected Results:  smooth upgrade

Additional info:

I tried two mirrors.. both are missing this file
Comment 1 Alexei Podtelezhnikov 2001-07-10 14:23:15 EDT
Can somebody check this bug report and assign it to a proper maintainer? I 
think it's important. I just want to add that clean install went smoothly on 
that machine. The problem is related to upgrades only.
Comment 2 Matt Wilson 2001-07-12 12:47:12 EDT
inetdconvert is part of the xinetd package.  Is that not being upgraded?  If you
didn't have inetd installed this shouldn't be a problem.  I'm guessing that the
failure is elsewhere and it's just the last thing printed.
Comment 3 Michael Fulbright 2001-07-27 16:22:20 EDT
This is a warning message - are there any other error messages on VC3 or VC4
when this happens?
Comment 4 Alexei Podtelezhnikov 2001-07-27 16:56:34 EDT
I don't remember seeing any other error.messages. The machine now runs RH 7.1
after a _clean_ network install. I have no intention of reproducing the error by
going back to 7.0 and forward again.
It is very possible that it had xinetd (surely, either inetd or xinetd) before
and tried to upgrade it. Bottom line is that inetdconvert is absent from
install-time mounted images. It's not there. Whoever will try to use it under
whatever upgrade scenario will fail aborting the upgrade.  Something definately
tried it. You know better who that was.

Again, the problem was worked around by clean install.
Comment 5 Brent Fox 2001-08-10 17:46:42 EDT
Bryce, have you seen anything like this before?
Comment 6 Phil Copeland 2001-08-13 12:48:39 EDT
*blink* erm,...
no. I've not seen this before.
It's part of the QA tests that we actually do an upgrade from 7.0 to 7.1

lets see.... in the install the anaconda routine is question is this

    def migrateXinetd(self):
        if not os.access (self.instPath + "/usr/sbin/inetdconvert", os.X_OK):
            log("did not find %s" % self.instPath + "/usr/sbin/inetdconvert")
            return

        if not os.access (self.instPath + "/etc/inetd.conf.rpmsave", os.R_OK):
            log("did not run inetdconvert because no inetd.conf.rpmsave found")
            return

        argv = [ "/usr/sbin/inetdconvert", "--convertremaining",
                 "--inetdfile", "/etc/inetd.conf.rpmsave" ]
        
        log("found inetdconvert, executing %s" % argv)

        logfile = os.open (self.instLogName, os.O_APPEND)
        iutil.execWithRedirect(argv[0], argv, root = self.instPath,
                               stdout = logfile, stderr = logfile)
        os.close(logfile)

Basically:	does /usr/sbin/inetdconvert exists and is it executable?
	if not, report that file is missing CONTINUE (non destructive)
	else
	if there is a inetd.conf.rpmsave from the rpm upgrade
	then use inetdconvert to conver the saved version and restore it as the default
config

So.... in theory whats happening is that it can't find the conversion utility,
but even so, it should simply mention 'oh dear, not available, continuing' and
complete the rest of the process

[root@localhost lib]# rpm -qf /usr/sbin/inetdconvert
xinetd-2.3.0-1.71

The utility should have been dropped on as part of xinetd.

Humm,...

Ok well, a way out would be, while in the 7.0 enviroment, to get the xinetd src
rpm, recompile it using rpm --rebuild xinetd.-..rpm then install the binary that
gets written out (rpm -Uvh /usr/src/redhat/RPMS/alpha/xinetd...) Then, making
sure /usr/sbin/inetdconvert exists before the upgrade try the ftp 7.0->7.1
migration again

Phil
=--=

Comment 7 Brent Fox 2001-09-19 14:55:06 EDT
Have you tried following Phil's recommendations?
Comment 8 Brent Fox 2001-10-01 12:01:40 EDT
Closing due to inactivity.  Please reopen if you have more information.

Note You need to log in before you can comment on or make changes to this bug.