Bug 478630 - x11 video output error: X11 request 140.19 failed with error code 11: BadAlloc (insufficient resources for operation)
x11 video output error: X11 request 140.19 failed with error code 11: BadAll...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-02 09:44 EST by eric@christensenplace.us
Modified: 2009-01-26 14:52 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-26 12:54:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg Log File 0 (66.52 KB, text/plain)
2009-01-22 14:23 EST, eric@christensenplace.us
no flags Details
Xorg Log File 1 (50.71 KB, text/plain)
2009-01-22 14:23 EST, eric@christensenplace.us
no flags Details

  None (edit)
Description eric@christensenplace.us 2009-01-02 09:44:33 EST
Description of problem: X11 video crashes when trying to play videos using VLC.


Version-Release number of selected component (if applicable): ???


How reproducible: Nearly always.


Steps to Reproduce:
1. Try to open a video file.
2. Screen appears for a split second and then goes away.
3. Error appears in the terminal screen.
  
Actual results:
Video fails to play.

Expected results:
Video should play.

Additional info:
Error in the terminal window is:

[00000500] pulse audio output: No. of Audio Channels: 2
QPainter::begin: Paint device returned engine == 0, type: 1
QPainter::setClipRegion: Painter not active
QPainter::setClipping: Painter not active, state will be reset by begin
QPainter::begin: Paint device returned engine == 0, type: 1
QPainter::begin: Paint device returned engine == 0, type: 1
QPainter::setClipRegion: Painter not active
QPainter::setClipping: Painter not active, state will be reset by begin
QPainter::begin: Paint device returned engine == 0, type: 1
[????????] x11 video output error: X11 request 140.19 failed with error code 11:
 BadAlloc (insufficient resources for operation)
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  140 (XVideo)
  Minor opcode of failed request:  19 ()
  Serial number of failed request:  87
  Current serial number in output stream:  88
Comment 1 Matěj Cepl 2009-01-08 13:23:58 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 eric@christensenplace.us 2009-01-22 14:22:28 EST
Sorry for the delay.  Apparently I HAD a xorg.conf at one time but I had renamed it as xorg.conf.old so there shouldn't have been one in effect.

Attached are the two log files I found.
Comment 3 eric@christensenplace.us 2009-01-22 14:23:18 EST
Created attachment 329733 [details]
Xorg Log File 0
Comment 4 eric@christensenplace.us 2009-01-22 14:23:51 EST
Created attachment 329734 [details]
Xorg Log File 1
Comment 5 Matěj Cepl 2009-01-23 12:47:18 EST
(In reply to comment #0)
> Description of problem: X11 video crashes 

What do you mean by "crashes"? Like there is no Xorg whatsoever, or just the vlc fails?
Comment 6 eric@christensenplace.us 2009-01-23 16:14:36 EST
This only occurs in vlc.  The video screen will pop up and then go away killing vlc with it.
Comment 7 Matěj Cepl 2009-01-26 12:54:06 EST
(In reply to comment #6)
> This only occurs in vlc.  The video screen will pop up and then go away killing
> vlc with it.

Then I am really sorry, but unless you persuade me otehrwise, I have to hold that this is not a Fedora bug (vlc is not provided by any official Fedora package, and I don't see any disaster in the provided logs). You have to file a bug at https://bugzilla.rpmfusion.org/ Of course, if you will need any cooperation from us, then feel free to reopen with the additional information.

Closing as NOTABUG (meaning, not our bug)
Comment 8 eric@christensenplace.us 2009-01-26 14:52:40 EST
Help me understand...

In the error I'm seeing is: 
x11 video output error: X11 request 140.19 failed with error code 11: BadAlloc (insufficient resources for operation)

This error seems to point to a X11 problem.  This may only occur with VLC on my system because it is the only video player that I use.

Note You need to log in before you can comment on or make changes to this bug.