This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 478636 - Cannot unlock screen
Cannot unlock screen
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
: 479370 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-02 11:39 EST by Adrien Bustany
Modified: 2015-01-14 18:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-21 15:39:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Debug log of the gnome-screensaver daemon (15.01 KB, text/plain)
2009-01-02 11:39 EST, Adrien Bustany
no flags Details
gnome-screensaver log (11.58 KB, patch)
2009-01-09 00:58 EST, Parag Nemade
no flags Details | Diff

  None (edit)
Description Adrien Bustany 2009-01-02 11:39:21 EST
Created attachment 328078 [details]
Debug log of the gnome-screensaver daemon

Description of problem:
When the screen is locked (either explicit request via gnome menu or when resuming from s2ram), I can't unlock the screen : I press a key, I briefly see the screen (solar fedora background), and it blanks again (I don't even see the password dialog). I need to switch to another VT and kill gnome-screensaver to get back to my session. I suspected gnome-power-manager, but I still get the same behavior when it's not running.

Version-Release number of selected component (if applicable):
Both gnome-screensaver-2.24.1-2.fc10 and gnome-screensaver-2.25.2-1.fc11 rebuilt for F10 (so the bug might be lying in an underlying lib ?)

How reproducible:
Lock the screen, try to unlock it.

Attached is a debug log, logging the daemon start, then a lock and several attempts to unlock
Comment 1 Ray Strode [halfline] 2009-01-05 15:12:23 EST
Error from log:

stener-dbus.c:296 (17:28:10):	 Updating ConsoleKit idle status: 1
[gs_listener_update_console_kit_idle] gs-listener-dbus.c:321 (17:28:10):	 org.freedesktop.DBus.Error.AccessDenied raised:
 A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.ConsoleKit.Session" member "SetIdleHint" error name "(unset)" destination "org.freedesktop.ConsoleKit")

Probably this fallout from the dbus security errata:

http://bugs.freedesktop.org/show_bug.cgi?id=19020

What version of dbus do you have installed?
Comment 2 Adrien Bustany 2009-01-05 16:12:51 EST
Hi,

I have dbus-1.2.4-2.fc10.x86_64 (and dbus-glib-0.76-3.fc10.x86_64)
Comment 3 Ray Strode [halfline] 2009-01-06 16:24:50 EST
have you rebooted since installing that version of dbus?
Comment 4 Ray Strode [halfline] 2009-01-09 00:34:31 EST
*** Bug 479370 has been marked as a duplicate of this bug. ***
Comment 5 Ray Strode [halfline] 2009-01-09 00:36:29 EST
seems like the permissive dbus builds are still blocking things.
Comment 6 Parag Nemade 2009-01-09 00:58:59 EST
Created attachment 328521 [details]
gnome-screensaver log

I am not sure about permissive builds of dbus. But when rawhide downgraded to dbus-1.2.4-1.fc11.i386.rpm, I got attached log.
Comment 7 Colin Walters 2009-01-09 14:09:43 EST
Are there any dbus messages in /var/log/syslog ?
Comment 8 Colin Walters 2009-01-09 14:14:30 EST
Oh, this is still with 1.2.4?

We need to know about comment #3 - you need to have rebooted for it to take effect.
Comment 9 Parag Nemade 2009-01-11 23:20:03 EST
in my case I am rebooting daily and updating rawhide daily but still i see this bug.
Comment 10 Colin Walters 2009-01-14 00:44:32 EST
It turns out the SetIdleHint denial was not related to this problem.  Moving back to gnome-screensaver.  Looking at the attached log:

(/usr/libexec/gnome-screensaver-gl-helper:6339): Gdk-CRITICAL **: gdk_x11_visual_get_xvisual: assertion `visual != NULL' failed

rather stands out.
Comment 11 Adrien Bustany 2009-01-14 03:42:27 EST
Hi,
I still observe this behaviour after a reboot, using dbus-1.2.4-2.fc10.x86_64 .
I have a friend running F10 x86_64 too which is not affected by this bug, but he's running a fresh install while I updated from F9, and maybe from F8 to F9 too, I can't remember. I hope it helps :)
Comment 12 Ray Strode [halfline] 2009-01-14 09:29:15 EST
Do you guys see this problem if you choose a non-GL screensaver?  (Say blank screen)?
Comment 13 Adrien Bustany 2009-01-14 10:11:02 EST
I use the default (blank screensaver).
Comment 14 Matthias Clasen 2009-02-21 00:17:10 EST
Upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=561855
Comment 15 Matthias Clasen 2009-02-21 15:39:32 EST
* Sat Feb 21 2009 Matthias Clasen <mclasen@redhat.com> - 2.25.2-4
- Make all hacks work again

Note You need to log in before you can comment on or make changes to this bug.