Bug 478666 - galeon needs a rebuild against new xulrunner 1.9.1
galeon needs a rebuild against new xulrunner 1.9.1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: galeon (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-02 22:58 EST by Alex Lancaster
Modified: 2009-01-07 00:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 00:40:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build with xulrunner 1.9.1 (1.54 KB, patch)
2009-01-06 19:01 EST, Yanko Kaneti
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 565668 None None None Never

  None (edit)
Description Alex Lancaster 2009-01-02 22:58:08 EST
But it appears that galeon no longer compiles against xulrunner 1.9.1.  I also filed the bug upstream:

http://bugzilla.gnome.org/show_bug.cgi?id=565668

but it should also be reported here so that it can be updated if/when upstream fixes it (or possible Fedora might need to fix it since upstream is effectively dead).
Comment 1 Alex Lancaster 2009-01-02 22:59:16 EST
Just for good measure, also causing broken deps... ;)

Broken deps for i386
	galeon-2.0.7-3.fc11.i386 requires libgnome-desktop-2.so.10
Comment 2 Yanko Kaneti 2009-01-06 19:01:25 EST
Created attachment 328331 [details]
build with xulrunner 1.9.1

This is Christopher Aillon's epiphany patch for the same thing copied over to galeon. Builds and works fine here.
Comment 3 Denis Leroy 2009-01-06 19:04:08 EST
Fantastic, thanks!
Comment 4 Alex Lancaster 2009-01-06 23:45:20 EST
(In reply to comment #2)
> Created an attachment (id=328331) [details]
> build with xulrunner 1.9.1
> 
> This is Christopher Aillon's epiphany patch for the same thing copied over to
> galeon. Builds and works fine here.

I forwarded this patch upstream:

http://bugzilla.gnome.org/show_bug.cgi?id=565668
Comment 5 Alex Lancaster 2009-01-07 00:40:27 EST
OK, applied and rebuilt: http://koji.fedoraproject.org/koji/buildinfo?buildID=77492

Closing bug.  Feel free to reopen if the rebuilt package doesn't work on rawhide.

Note You need to log in before you can comment on or make changes to this bug.