Bug 478667 - [KMS][drm:radeon_gem_ib_get] *ERROR* Major case fail to allocate IB from freelist ffff
[KMS][drm:radeon_gem_ib_get] *ERROR* Major case fail to allocate IB from free...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-02 23:19 EST by Zing
Modified: 2009-10-15 10:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-15 10:45:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg log (45.44 KB, text/plain)
2009-01-02 23:21 EST, Zing
no flags Details
xorg log (83.08 KB, text/plain)
2009-01-02 23:22 EST, Zing
no flags Details
lspci log (29.01 KB, text/plain)
2009-01-02 23:22 EST, Zing
no flags Details

  None (edit)
Description Zing 2009-01-02 23:19:51 EST
Description of problem:
In X, twice I got a hang and choppy behaviour.  It seems that playing a video plus some type of activity or some length of time exacerbates the symptom into happening, at least, that's when it happened to me.  Although the system comes back after quiting some apps, I'll get inconsistent choppy behaviour thereafter.

In dmesg I got multiple:
RADEON DRM CS failure - corruptions/glitches may occur -22
bufmgr: last submission : r:40310784 vs g:525332480 w:6969984 vs v:101958444


Version-Release number of selected component (if applicable):
kernel-2.6.27.9-159.fc10.x86_64
xorg-x11-server-Xorg-1.5.3-6.fc10.x86_64
xorg-x11-drv-ati-6.9.0-63.fc10.x86_64

How reproducible:
not very

Steps to Reproduce:
1. watch tv/play videos/do multiple things
2. eventually get the above errors.

Actual results:
see dmesg and xorg logs I'll attach

Expected results:
no hangs or choppiness.

Additional info:
this is an ATI x800 card, but I'll attach the logs for more info.  It also suffers from hangs whenever glx is used as reported elsewhere (glxgears reliably hangs this machine).
Comment 1 Zing 2009-01-02 23:21:08 EST
Created attachment 328091 [details]
dmesg log
Comment 2 Zing 2009-01-02 23:22:00 EST
Created attachment 328092 [details]
xorg log
Comment 3 Zing 2009-01-02 23:22:31 EST
Created attachment 328093 [details]
lspci log
Comment 4 Ufa 2009-02-05 18:49:53 EST
I occasionally have these erros too.
I am using a x600 ati board with free drivers.
Comment 5 Orion Poplawski 2009-03-19 16:50:18 EDT
I was seeing similar messages when running glxgears and then covering the glxgears window with another - almost complete lockup of display though too - just the mouse moved.  Can't reproduce with switch to radeonhd driver.

01:00.0 VGA compatible controller: ATI Technologies Inc M56GL [Mobility FireGL V5250]
Comment 6 François Cami 2009-04-08 18:21:24 EDT
Zing, Ufa, Orion,

Thanks for the report and logs.

Could any of you test rawhide with at least those packages :
xorg-x11-drv-ati-6.12.1-9.fc11
kernel-2.6.29.1-54.fc11
mesa-libGL-7.5-0.8.fc11

This is most probably fixed there, but I'd like to be sure.

Thanks in advance

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Orion Poplawski 2009-04-15 12:39:18 EDT
I can no longer reproduce with my test case (glxgears hidden) with:

xorg-x11-drv-ati-6.12.2-2.fc11.x86_64
kernel-2.6.29.1-70.fc11.x86_64
mesa-libGL-7.5-0.9.fc11.x86_64
Comment 8 François Cami 2009-04-18 18:36:17 EDT
Orion,

Thanks for testing, closing.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 François Cami 2009-04-18 18:37:30 EDT
Re-opening, since the target is F10...
Comment 10 Zing 2009-05-01 20:48:06 EDT
I did a short test with the Fedora 11 Preview LiveCD.

1. glxgears does run stable now and it can be obscured and moved around on my hardware for the few minutes I tested.

2. next, i tried to enable desktop effects, but the X server immediately segfaulted:

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x26) [0x4e9d26]
1: /usr/bin/Xorg(xf86SigHandler+0x6f) [0x47de1f]
2: /lib64/libc.so.6 [0x7f4a49c86570]
3: /usr/lib64/dri/r300_dri.so(radeonDestroyBuffer+0x29) [0x7f4a46491ae4]
4: /usr/lib64/dri/r300_dri.so(radeonDestroyContext+0xdf) [0x7f4a464b407e]
5: /usr/lib64/dri/r300_dri.so [0x7f4a4648bd7c]
6: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f4a47e31c99]
7: /usr/lib64/xorg/modules/extensions//libglx.so(__glXFreeContext+0x6c) [0x7f4a47e2783c]
8: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f4a47e27bcb]
9: /usr/bin/Xorg(CallCallbacks+0x4c) [0x44b6ec]
10: /usr/bin/Xorg(CloseDownClient+0x58) [0x441ec8]
11: /usr/bin/Xorg(Dispatch+0x210) [0x447040]
12: /usr/bin/Xorg(main+0x3c5) [0x42d0e5]
13: /lib64/libc.so.6(__libc_start_main+0xfd) [0x7f4a49c7183d]
14: /usr/bin/Xorg [0x42c559]

Fatal server error:
Caught signal 11.  Server aborting
Comment 11 Jessica Jones 2009-07-01 07:21:51 EDT
(In reply to comment #9)
> Re-opening, since the target is F10...  

Does anyone know if there is a workaround for F10?  I guess I could build the source F11 packages (upgrading is not something I can do for some time yet).
Comment 12 Jessica Jones 2009-07-01 07:42:48 EDT
(In reply to comment #11)
> (In reply to comment #9)
> > Re-opening, since the target is F10...  
> 
> Does anyone know if there is a workaround for F10?  I guess I could build the
> source F11 packages (upgrading is not something I can do for some time yet).  

Doesn't look like this is going to be feasible for me right now.. Are there any plans to get this sorted in FC10?
Comment 13 Jérôme Glisse 2009-10-15 10:45:44 EDT
I don't anyone got time to fix F10 or F11. Please try Fedora 12 (you can test livecd from http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/) your issue should be fixed with it. Reopen this bug is fedora 12 has similar issue.

Note You need to log in before you can comment on or make changes to this bug.