Bug 478670 - wireless connection through Network Manager impossible due to login keyring receiving the wrong network key
wireless connection through Network Manager impossible due to login keyring r...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-03 02:20 EST by Gian Paolo Mureddu
Modified: 2015-03-03 17:33 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:28:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gian Paolo Mureddu 2009-01-03 02:20:08 EST
Description of problem:
I had been haivng problems connecting my laptop to my home wireless network ever since some update in Fedora 9. The problem persisted also in Fedora 10, and I even reported this problem thinking it was related to NetworkManager, WPA-Supplicant, the Kernel or the like components. To my surprise, an account home directory of my girlfriend had been "sleeping" on the HDD since the late days of Fedora 8 on this machine. For some reason or another, I reactivated her account (created it under F10, using the already existing /home/$USER directory) which "inherited" her keyrings and NetworkManager behavior. To our surprise, the wireless worked!, however on my account (recreated several times removing the directory and creating it again, not without backups) the connection problems persisted. And what was more strange still was the fact that for some reason when trying to connect through the NM dialog in my account, two things happened: 1) there are some messages in dmesg stating that the connection was established but dropped by choice (reason 3, for whatever that means) and then when the key prompt comes up again, the key would be different. By using gnome-keyring-manager I was able to see that the login.keyring had the "distorted" version of the key for the network, i.e, the one presented when it's changed after failing a connection attempt. So there seems to be a problem in the way either gnome-keyring writes the key or how NetworkManager stores the key in the login.keyring. I'm still puzzled by the dmesg messages, though. And why did my girl friend account with the F8 behavior actually worked is beyond me... Right now I have to do a rather byzantine routine to have wireless connectivity on my account: login first with my GF's account, enter the keyring password for the connection, then login with my account through the fast-user-switch, and I have wireless connectivity. Out of despair I'm attaching this bug report the gnome-keyring component rather than NM, or the other components that have to do with the actual wireless backend.

Version-Release number of selected component (if applicable):
gnome-keyring-2.24.1-1.fc10.x86_64

How reproducible:
It seems that the change in the network key is always consistent, and that this key is written in turn to the keyring.

Steps to Reproduce:
1. Create an account.
2. Try to connect to a secured wireless network (WEP/WPA/etc)
3. See the key is changed, and the key is apparently written to the keyring
  
Actual results:
Can't establish a network connection with an account created within Fedora 10

Expected results:
To be able to connect to secured wireless networks.

Additional info:
If it has anything to do with this problem, the hardware in question is an USB dongle embedded inside my Toshiba Laptop, a Realtek 8187B chipset. F10 is up to date with all the latest updates available.
Comment 1 Ignacio Vazquez-Abrams 2009-01-03 02:32:34 EST
Did you try removing the key in seahorse?
Comment 2 Bug Zapper 2009-11-18 04:43:45 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bug Zapper 2009-12-18 02:28:06 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.