Bug 47871 - Logout problem
Logout problem
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-08 13:34 EDT by Need Real Name
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 10:22:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-08 13:34:50 EDT
Description of Problem:
When logging out & choosing 'Shutdown' & 'Shutdown' the Xwindows sytem 
shuts down and the processes start shutting down, then I find myself back 
at the text login prompt but Xwindows does not start.  Using CTRL-ALT-DEL 
will then shut down the sytem but it wants to restart in text mode.  If, 
on the other hand, one uses the reset switch after C-A-D (& after 
everything is shut down), the graphic boot mode is again on-screen.

How Reproducible:
It would appear that this is triggered by shutting the lid of the 
notebook & letting the system hybernate, then lifting the lid to again 
reuse the machine.  It is almost 100% reproducible.

Steps to Reproduce:
1. Start machine & Linux
2. Log into any desktop
3. Shut notebook lid & hybernate/reopen lid
4. Log out & attempt to shut down the machine completely.

Actual Results:
...As indicated under 'Description'

Expected Results:
I fully expected the machine to completely shut down & turn off.

Additional Information:
As indicated, I have been able to reproduce this problem nearly 100%.  
The first time it was totally unexpected but now I stand ready with a pen 
point to hit the reset switch when all processes have stopped, allow the 
machine to come to the login prompt, once more, then do the shut down 
process once more.  After using the reset switch, everything operantes 
normally.
Comment 1 Bill Nottingham 2001-07-08 16:48:59 EDT
Sounds like either a kernel problem (with APM suspend), or a GDM problem.
Assigning to kernel for now.b
Comment 2 Arjan van de Ven 2001-07-08 16:55:32 EDT
Could you try to type "linux apm=realmode" on the lilo prompt and see
if that makes a difference ?
Comment 3 Need Real Name 2001-07-09 14:57:49 EDT
I tried, 'linix apm=realmode' as you asked; the same behaviour prevailed.  I 
noticed, finally, that what *is_not* happening when I have abnormal shutdown  
is: 'md: recovery thread got woken up...' when this phenomenon occurrs.  (I 
get a line on the screen that says '...init 3' followed by a line which 
flashes by too fast to read, then the text login prompt when things *do_not* 
work properly.)

HTH.
Comment 4 Need Real Name 2001-07-14 15:45:50 EDT
I have further info which may help to either clarify or confuse the issue.  
After doing a 3rd install because of APM problems, I did not use the DRIVERS 
DISK when reinstalling.  This time, the shutdown has been normal each and 
every time APM is used.

Machine:
Toshiba Satellite 2100CDT
AMD K6-2 3D processor 400(+?)mhz
128MB RAM
4.02GB HD (all RHL)

Note You need to log in before you can comment on or make changes to this bug.