Bug 478718 - bind-devel multilib conflict
bind-devel multilib conflict
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
17
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Hozza
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-03 21:21 EST by Philippe Troin
Modified: 2012-09-22 23:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-22 23:28:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Philippe Troin 2009-01-03 21:21:41 EST
Description of problem:

yum install bind-devel.x86_64 bind-devel.i386

yields:

  file /usr/include/isc/platform.h conflicts between attempted installs of bind-devel-32:9.5.1-0.9.b3.fc10.x86_64 and bind-devel-32:9.5.1-0.9.b3.fc10.i386

Version-Release number of selected component (if applicable):
bind-devel-32:9.5.1-0.9.b3.fc10
Comment 1 Philippe Troin 2009-06-25 21:14:05 EDT
Still present in F11 with bind-devel-32:9.6.1-0.4.rc1.fc11.

Phil.
Comment 2 Philippe Troin 2009-07-23 16:47:08 EDT
Still present in bind-devel-9.6.1-3.fc11.
Comment 3 Philippe Troin 2010-02-11 20:02:04 EST
Still present in F12: bind-devel-32:9.6.1-16.P3.fc12.i686.
Comment 4 Adam Tkac 2010-03-01 09:30:24 EST
Fixed in bind-9.7.0-3.fc14 (Fedora 14 development branch), thanks to Jan Gorig for the patch.
Comment 5 Philippe Troin 2012-06-12 18:08:51 EDT
Reappeared in bind-devel-32:9.9.1-1.fc17.i686

# yum install bind-devel-32:9.9.1-1.fc17.i686
Loaded plugins: changelog, downloadonly, priorities, remove-with-leaves, show-
              : leaves, tsflags
16 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package bind-devel.i686 32:9.9.1-1.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package            Arch         Version                  Repository       Size
================================================================================
Installing:
 bind-devel         i686         32:9.9.1-1.fc17          updates         377 k

Transaction Summary
================================================================================
Install  1 Package

Total size: 377 k
Installed size: 1.3 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test


Transaction Check Error:
  file /usr/bin/isc-config.sh from install of bind-devel-32:9.9.1-1.fc17.i686 conflicts with file from package bind-devel-32:9.9.1-1.fc17.x86_64
  file /usr/include/bind9/config.h from install of bind-devel-32:9.9.1-1.fc17.i686 conflicts with file from package bind-devel-32:9.9.1-1.fc17.x86_64

Error Summary
-------------

[2]    11874 exit 1     noglob yum install bind-devel-32:9.9.1-1.fc17.i686
Comment 6 Tomas Hozza 2012-08-01 09:55:36 EDT
Multilib conflict is fixed. 

You can find builds including fix here http://koji.fedoraproject.org/koji/buildinfo?buildID=345284 or you can wait for the next bind update.
Comment 7 Fedora Update System 2012-09-13 11:49:44 EDT
bind-9.9.1-9.P3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/bind-9.9.1-9.P3.fc17
Comment 8 Fedora Update System 2012-09-17 13:39:24 EDT
Package bind-9.9.1-9.P3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bind-9.9.1-9.P3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14106/bind-9.9.1-9.P3.fc17
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-09-22 23:28:24 EDT
bind-9.9.1-9.P3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.