Bug 478732 - Inkscape doesn't maximize with Metacity compositor enabled
Inkscape doesn't maximize with Metacity compositor enabled
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-04 06:33 EST by Emanuele Bellini
Modified: 2009-01-06 08:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-05 07:14:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emanuele Bellini 2009-01-04 06:33:36 EST
Description of problem:
With the Metacity compositing manager enabled, if I press the maximize button in the top right angle of the window the size doesn't change. If I disable the compositor, the window goes full-screen as it should do. I don't know wheter this problem is an Inkscape or Metacity one, so I start from here.


Version-Release number of selected component (if applicable):
Inkscape 0.46-6.fc10
Metacity 2.24.0-2.fc10
Comment 1 Emanuele Bellini 2009-01-04 06:42:01 EST
I think it's a Metacity issue because it seems to be a problem of the window and not of the program itself, so I changed the bug component to Metacity instead of Inkscape.
Comment 2 Lubomir Rintel 2009-01-04 08:50:26 EST
I could not reproduce this. What resolution do you use?
Comment 3 Emanuele Bellini 2009-01-04 09:02:23 EST
I have an ATI Radeon Mobility U1 video card with 8 MB of RAM. I'm using a resolution of 1024x768. Anyway, I've found the guilty! I'm using the Avant Window Navigator with a setting that lets me see the bar with the maximized windows. With the Metacity compositor enabled, if I close the AWN bar the maximize button works! So the problem could be theirs. Pass them this thread if that's right.
Comment 4 Lubomir Rintel 2009-01-05 07:14:36 EST
(In reply to comment #3)
> I have an ATI Radeon Mobility U1 video card with 8 MB of RAM. I'm using a
> resolution of 1024x768. Anyway, I've found the guilty! I'm using the Avant
> Window Navigator with a setting that lets me see the bar with the maximized
> windows.

So this is not a bug. Inkscape won't maximize if there's not enough space on the screen to fit the whole maximized window. Given your resolution and the amount of space AWN occupies, there's simply not enough space on your desktop for inkscape.

Maybe it is possible to configure AWN to be smaller?
Comment 5 Emanuele Bellini 2009-01-05 09:26:12 EST
What? There's a misunderstanding... I can maximize manually the window (grabbing the borders of the window to those of the screen) but not automatically! I can do that, so why the maximize button doesn't work? Or could be my low video memory the reason for that? Anyway, I know that if I need a better resolution I have to go to the supermarket and buy a new PC, but 1024x768 is enough for me!!!
Comment 6 Lubomir Rintel 2009-01-05 12:56:29 EST
(In reply to comment #5)
> What? There's a misunderstanding... I can maximize manually the window
> (grabbing the borders of the window to those of the screen) but not
> automatically! I can do that, so why the maximize button doesn't work?

Honestly put -- I do not believe you :)
Could you please attach a screenshot of some application that is able to maximize (such as gedit) and a screenshot of inkscape resized to the very same size (both with the AWN enabled)?

> Or could
> be my low video memory the reason for that?

Definitely not.

> Anyway, I know that if I need a
> better resolution I have to go to the supermarket and buy a new PC, but
> 1024x768 is enough for me!!!

Heh, I'm not telling you to buy a new PC just for higher resolution. A proper solution would be not to run applications that occupy a big portion of the screen then; such as avant window navigator.
Comment 7 Emanuele Bellini 2009-01-05 15:13:32 EST
I'm sorry, I couldn't understand... You're right. The bottom border of Inkscape was next to the top margin of AWN, so I didn't realize it was above. Anyway, consider that AWN is becoming quite popular and 1280x768 is a common resolution for tiny notebooks and desktop monitors... Removing a button in the left toolbar would be enough to fix that. I'll keep the toolbar floating...
Comment 8 Lubomir Rintel 2009-01-06 07:16:19 EST
(In reply to comment #7)
> Removing a button in the left
> toolbar would be enough to fix that. I'll keep the toolbar floating...

I'm not going to remove it. 

Please note that in Fedora package we already make the buttons slightly smaller in order for the inkscape window to fit 1024x768 [1] -- the upstream inkscape window won't even fit that resolution!

Seems like upstream thinks that proper fix for this is hiding buttons that won't fit the toolbar (in a way similar to how many more applications, such as firefox hide their toolbar buttons). There's a couple of tickets open for that in launchpad, but I'm way too lazy to search for them now :)

[1] http://cvs.fedoraproject.org/viewvc/rpms/inkscape/F-10/inkscape-0.46pre2-icons.patch?revision=1.2&view=markup
Comment 9 Lubomir Rintel 2009-01-06 08:39:17 EST
A good news for you -- what I said about the collapsing of the toolbars is actually implemented in SVN now, so it will be in 0.47.

I'm preparing packages with SVN snapshot now, hopefully for 0.47 for Fedora 11 -- if you want the packages, let me know, I just won't release them info Fedora < 11.
Comment 10 Emanuele Bellini 2009-01-06 08:49:48 EST
I changed my desktop theme to one of the Fedora repository and now the buttons are smaller as you've said. Thanks for your patience, forgive me, next time I'll post a serious bug, and next time is... NOW!

Note You need to log in before you can comment on or make changes to this bug.