Bug 478736 - jpegorient not installed
jpegorient not installed
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: konq-plugins (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Sebastian Vahl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-04 07:58 EST by Chris Underhill
Modified: 2009-01-05 15:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-05 15:07:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 178612 None None None Never

  None (edit)
Description Chris Underhill 2009-01-04 07:58:34 EST
Description of problem:

dolphin/konqueror generate an error dialog "Could not find the progran 'jpegorient'"

Version-Release number of selected component (if applicable):

konq-plugins-4.1.3-2.fc10.x86_64
kdebase-4.1.3-2.fc10.x86_64

Otherwise an up-to-date Fedora 10 install on x86_64. 

How reproducible:

Every time

Steps to Reproduce:

1. Open a directory in dolphin or konqueror containing jpeg images

2. Right mouse click on jpeg image and select 

Actions->Transform Image->Rotate-Clockwise (or any others from that menu).
  
Actual results:

Error dialog pops up containing test "Could not find the program 'jpegorient'"

Expected results:

The image is transformed according to the menu option selected

Additional info:

Looking at an online man page, jpegorient is related/depends on exif.pyand orient.py, both of which are installed in /usr/share/kde4/apps/imagerotation. locate jpegorient however returns nothing
Comment 1 Rex Dieter 2009-01-05 13:08:52 EST
jpegorient is provided by kde3's kdeaddons.  Looks like an upstream bug in konq-plugins, as it should not rely on any kde3 runtime components.
Comment 2 Rex Dieter 2009-01-05 14:07:04 EST
Looking closer, a copy of jpegorient is included in konq-plugin's tarball, but for whatever reason, it isn't ever used/installed.
Comment 3 Rex Dieter 2009-01-05 14:18:12 EST
konq-plugins lost jpegorient on commit: http://websvn.kde.org/?view=rev&revision=693875

Looks like an upstream goof up, and no one noticed till now.  :(

Congrats.
Comment 4 Chris Underhill 2009-01-05 14:51:03 EST
Had a look at the KDE bugzilla, and this has been reported but was then closed as invalid:

https://bugs.kde.org/show_bug.cgi?id=178612
Comment 5 Rex Dieter 2009-01-05 15:02:50 EST
OK, I'll go take a look, and bring my cluebat with me.
Comment 6 Rex Dieter 2009-01-05 15:07:06 EST
Yep, that's the one, let's continue whacking this upstream.

Note You need to log in before you can comment on or make changes to this bug.