Bug 478740 - Code that compiles in F10 won't compile in rawhide
Code that compiles in F10 won't compile in rawhide
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-04 09:14 EST by Kevin DeKorte
Modified: 2009-01-06 17:48 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-06 17:12:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin DeKorte 2009-01-04 09:14:49 EST
Description of problem:
I'm the developer of the gecko-mediaplayer plugin for Firefox and on Fedora 10 I use the xulrunner-devel package to build my plugin. Recently I was informed that the plugin would not build on Fedora rawhide (F11). I did some testing in mock and found that the npupp.h file had been removed and it looks like several other changes have been made to the -devel package of xulrunner. 

Version-Release number of selected component (if applicable):
xulrunner-1.9.1-0.5.beta2.fc11

How reproducible:
100%

Steps to Reproduce:
1. Compile in mock and find that several files are missing or renamed.
2.
3.
  
Actual results:
Compile failure

Expected results:
Should work

Additional info:
I grabbed xulrunner-sdk 1.9.0.6pre from mozilla.org and I can compile against it just fine. So I'm not sure where you are getting your xulrunner-sdk
Comment 1 Christopher Aillon 2009-01-06 17:12:25 EST
I'm getting the sdk from mozilla-central.  https://developer.mozilla.org/en/mozilla-central  It's still in beta, but it will be the 1.9.1 code that matches with Firefox 3.1 (which will be in F11, or the latest beta if it has not been released at that point).

You are correct that nppup.h is gone.  It has been renamed to npfunctions.h.  See https://bugzilla.mozilla.org/show_bug.cgi?id=455458

Not a bug in XULRunner -> your code needs to be adjusted
Comment 2 Kevin DeKorte 2009-01-06 17:48:40 EST
Yes, I was able to work around this issue in the code. Just find it annoying when code works with a x.0 release and fails with a x.1 release.

Note You need to log in before you can comment on or make changes to this bug.