Bug 478790 - Puppet epel package fails to upgrade from 0.24-4 to 0.24-7
Puppet epel package fails to upgrade from 0.24-4 to 0.24-7
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora EPEL
Classification: Fedora
Component: puppet (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: David Lutterkort
Fedora Extras Quality Assurance
ActualBug
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-04 20:49 EST by Ohad Levy
Modified: 2013-04-30 19:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-07 22:57:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ohad Levy 2009-01-04 20:49:43 EST
Description of problem:

epel package fails to upgrade from 0.24-4 to 0.24-7

Version-Release number of selected component (if applicable):


How reproducible:
Preparing...                ########################################### [100%]
   1:augeas-libs            ########################################### [ 25%]
   2:ruby-augeas            ########################################### [ 50%]
error:   install: %pre scriptlet failed (2), skipping puppet-0.24.7-4.el5
   3:puppet-server          warning: /etc/sysconfig/puppetmaster created as /etc/sysconfig/puppetmaster.rpmnew
########################################### [ 75%]

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Lutterkort 2009-02-13 15:34:18 EST
The %pre script in question is

getent group puppet >/dev/null || groupadd -r puppet -g 52
getent passwd puppet >/dev/null || \
useradd -r -u 52 -g puppet -d %{_localstatedir}/lib/puppet -s /sbin/nologin \
    -c "Puppet" puppet || :
# ensure that old setups have the right puppet home dir
if [ $1 -gt 1 ] ; then
  usermod -d %{_localstatedir}/lib/puppet puppet || :
fi


Do you already have a uid/gid 52 on that machine that's not 52 ?

Other than that, I am not sure how this scriptlet would fail.

David
Comment 2 Todd Zullinger 2009-05-31 22:29:47 EDT
Ohad, was this something you could reproduce or track down to an error in the packages?  (If not, we should just close this as NOTABUG or WORKSFORME. ;)

Note You need to log in before you can comment on or make changes to this bug.