Bug 478791 - blank vnc window
blank vnc window
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vnc-ltsp-config (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-04 21:21 EST by Ian Mortimer
Modified: 2009-01-12 20:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 20:26:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Mortimer 2009-01-04 21:21:55 EST
Description of problem:
With vnc-ltsp-config installed and configured according to the instructions, vnc connection to the terminal server gets a blank window for any of the configured ports (5900 - 5905)


Version-Release number of selected component (if applicable):
vnc-ltsp-config-4.0-5.fc10

How reproducible:
Always

Steps to Reproduce:
1. install vnc-ltsp-config
2. chkconfig vncts on
3. configure /etc/gdm/custom.conf /etc/X11/xdm/Xaccess
4. restart gdm
5. start remote vnc connection to one of the configured ports
  
Actual results:
vncviewer shows a blank window.  Logs show Xvnc started by xinted but ps shows no additional gdm processes being started.

Expected results:
a gdm login screen should display in the vncviewer window


Additional info:
A configuration like this worked up to Fedora 8 but I haven't been able to get it working with Fedora 9 or 10.  I tried with xorg-x11-xfs installed and xfs running which was needed with Fedora 7 or 8.  I also tried with xfs turned off.

I have this in /etc/gdm/custom.conf:

[xdmcp]
Enable=true

I tried with localhost in /etc/X11/xdm/Xaccess and also with * (any host can connect) but no luck with either.

Since Fedora 8 is now EOL, I need to upgrade our vnc terminal servers to 9 or 10 as soon as possible.


Thanks
--
Ian
Comment 1 Rex Dieter 2009-01-04 21:47:48 EST
Your symptom usually means xdmcp isn't working.

I'm unfamiliar with gdm (kde/kdm user myself), but I can vouche that it works with kdm.
Comment 2 Ian Mortimer 2009-01-04 22:22:46 EST
(In reply to comment #1)

> Your symptom usually means xdmcp isn't working.

That's true.  netstat -l confirms nothing listening on the xdmcp port (177).

> I'm unfamiliar with gdm (kde/kdm user myself), but I can vouche that it works
> with kdm.

Ok.  I'll try with kdm.  Since gdm is the default display manager, it should work so I'll post a bug against gdm also.

Thanks for the quick reply.
Comment 3 Ian Mortimer 2009-01-12 20:26:40 EST
Fixed in gdm-2.24.1-4.fc10 from updates-testing.

Note You need to log in before you can comment on or make changes to this bug.