Bug 478796 - Firefox and gpk-application always think you are offline
Firefox and gpk-application always think you are offline
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-04 22:44 EST by Raul Acevedo
Modified: 2009-02-05 14:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 13:52:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raul Acevedo 2009-01-04 22:44:30 EST
Description of problem:
Firefox always starts up in offline mode, and gpk-application always complains that no network connection is available ("Cannot install when offline"), even though eth0 is up and working just fine.  I believe this is happening because I'm not using NetworkManager; in fact I've removed NetworkManager-gnome.  The eth0 (DSL to outside world) eth1 (interface to internal network) interfaces are marked as "enable during startup" but NOT controlled by NetworkManager.


Version-Release number of selected component (if applicable):
NetworkManager: 0.7.0
Firefox: 3.0.5
gnome-packagekit: 0.3.12

How reproducible:
Every time.

Steps to Reproduce:
1.  rpm -e NetworkManager-gnome
2.  Logout
3.  Login
4.  Start firefox, or try to install any package via gpk-application

Actual results:
Firefox starts up in offline mode; gpk-application complains that the network connection is not available.

Expected results:
Firefox should not start up in offline mode, and gpk-application should work, because the network is up and running and doing just fine.

Additional info:
I apologize if these are separate bugs, but I strongly suspect the problem is that these apps think they should check NetworkManager.

Note that while I can simply disable offline mode for Firefox, gpk-application basically does not work AT ALL, because I don't see a way to convince it that the network is indeed up.  I have to do everything on the command line via yum.
Comment 1 Dan Williams 2009-02-05 13:52:35 EST
NetworkManager is intended to control your primary network connection.  It sounds like NetworkManager isn't doing that in your case.  If you're not using NetworkManager, I'd suggest disabling the service entirely with:

sudo /sbin/chkconfig NetworkManager off
sudo /sbin/service NetworkManager stop

When NetworkManager is running, firefox and packagekit will ask NetworkManager for network connection status.
Comment 2 Raul Acevedo 2009-02-05 14:05:30 EST
Thank you, that did it!

Note You need to log in before you can comment on or make changes to this bug.