Bug 478823 - Xorg crashing in events.c
Xorg crashing in events.c
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
11
All Linux
high Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-05 07:26 EST by Zdenek Kabelac
Modified: 2018-04-11 14:21 EDT (History)
4 users (show)

See Also:
Fixed In Version: F11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-01 16:54:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (3.17 KB, text/plain)
2009-01-05 07:26 EST, Zdenek Kabelac
no flags Details
Xorg.log from the last crash (37.08 KB, text/plain)
2009-01-05 07:30 EST, Zdenek Kabelac
no flags Details
Xorg log from crash [1.5.99.901-1.fc11] (54.23 KB, text/plain)
2009-01-25 14:21 EST, James Ettle
no flags Details
Xorg.0.log from server crash: Caught signal 11 (273.91 KB, text/plain)
2009-01-25 18:58 EST, Tom London
no flags Details
/var/log/Xorg.0.log (58.69 KB, text/plain)
2009-01-26 11:42 EST, Matěj Cepl
no flags Details

  None (edit)
Description Zdenek Kabelac 2009-01-05 07:26:06 EST
Created attachment 328190 [details]
xorg.conf

Description of problem:

I've got these 2 coredumps while running latest Xorg:

This one after resume and placing T61 into docking station

#0  CheckMotion (xE=0x0, pDev=0xa1cc020) at events.c:2554
2554	    prevSpriteWin = pSprite->win;
Missing separate debuginfos, use: debuginfo-install audit-libs-1.7.10-2.fc11.x86_64 e2fsprogs-libs-1.41.3-2.fc11.x86_64 expat-2.0.1-5.x86_64 freetype-2.3.7-3.fc11.x86_64 glibc-2.9-2.x86_64 keyutils-libs-1.2-3.fc9.x86_64 krb5-libs-1.6.3-16.fc10.x86_64 libXau-1.0.4-1.fc10.x86_64 libXdmcp-1.0.2-6.fc10.x86_64 libXfont-1.3.3-1.fc10.x86_64 libcap-2.10-2.fc10.x86_64 libdrm-2.4.3-0.3.fc11.x86_64 libfontenc-1.0.4-6.fc10.x86_64 libpciaccess-0.10.3-3.fc10.x86_64 libselinux-2.0.76-5.fc11.x86_64 openssl-0.9.8g-11.fc10.x86_64 zlib-1.2.3-19.fc11.x86_64
(gdb) bt
#0  CheckMotion (xE=0x0, pDev=0xa1cc020) at events.c:2554
#1  0x000000000048e4fc in xf86NewInputDevice (idev=<value optimized out>, pdev=0x7fff90dac8d0, enable=1 '\001') at xf86Xinput.c:550
#2  0x000000000048e7ad in NewInputDeviceRequest (options=0x71d9ca0, pdev=0x7fff90dac8d0) at xf86Xinput.c:634
#3  0x000000000046477e in device_added (hal_ctx=0x120eb60, 
    udi=0x54e6fa4 "/org/freedesktop/Hal/devices/usb_device_46d_c016_noserial_if0_logicaldev_input") at hal.c:403
#4  0x00007f7187ebfd29 in filter_func (connection=0x120f7a0, message=0x6d7bc50, user_data=<value optimized out>) at libhal.c:1065
#5  0x00007f7187c84f7b in dbus_connection_dispatch (connection=0x120f7a0) at dbus-connection.c:4406
#6  0x00007f7187c8533b in _dbus_connection_read_write_dispatch (connection=0x120f7a0, timeout_milliseconds=0, dispatch=<value optimized out>)
    at dbus-connection.c:3431
#7  0x0000000000463b1b in wakeup_handler (data=0x7c6160, err=<value optimized out>, read_mask=0x7d0640) at dbus-core.c:58
#8  0x000000000044ae7b in WakeupHandler (result=1, pReadmask=0x7d0a00) at dixutils.c:418
#9  0x00000000004e68df in WaitForSomething (pClientsReady=0x123dfb0) at WaitFor.c:231
#10 0x0000000000447040 in Dispatch () at dispatch.c:367
#11 0x000000000042cd5d in main (argc=4, argv=0x7fff90dacfc8, envp=<value optimized out>) at main.c:383


And this one while reporting the bug above:

#0  0x0000000000452964 in DeliverEventsToWindow (pDev=0x8f1eb0, pWin=0x735c7a0, pEvents=0x7fffa85b1860, count=1, filter=64, grab=0x0, mskidx=0)
    at events.c:2112
2112		pDev->valuator->motionHintWindow = pWin;
Missing separate debuginfos, use: debuginfo-install audit-libs-1.7.10-2.fc11.x86_64 e2fsprogs-libs-1.41.3-2.fc11.x86_64 expat-2.0.1-5.x86_64 freetype-2.3.7-3.fc11.x86_64 glibc-2.9-2.x86_64 keyutils-libs-1.2-3.fc9.x86_64 krb5-libs-1.6.3-16.fc10.x86_64 libXau-1.0.4-1.fc10.x86_64 libXdmcp-1.0.2-6.fc10.x86_64 libXfont-1.3.3-1.fc10.x86_64 libcap-2.10-2.fc10.x86_64 libdrm-2.4.3-0.3.fc11.x86_64 libfontenc-1.0.4-6.fc10.x86_64 libpciaccess-0.10.3-3.fc10.x86_64 libselinux-2.0.76-5.fc11.x86_64 openssl-0.9.8g-11.fc10.x86_64 zlib-1.2.3-19.fc11.x86_64
(gdb) bt
#0  0x0000000000452964 in DeliverEventsToWindow (pDev=0x8f1eb0, pWin=0x735c7a0, pEvents=0x7fffa85b1860, count=1, filter=64, grab=0x0, mskidx=0)
    at events.c:2112
#1  0x00000000004532f2 in DeliverDeviceEvents (pWin=0x735c7a0, xE=0x6fec130, grab=0x0, stopAt=0x0, dev=0x8f1eb0, count=1) at events.c:2371
#2  0x0000000000535bdc in ProcessOtherEvent (xE=0x6fec130, device=0x8f1eb0, count=1) at exevents.c:1081
#3  0x000000000055d8bd in ProcessKeyboardEvent (xE=0x6fec130, keybd=0x8f1eb0, count=1) at xkbPrKeyEv.c:208
#4  0x00000000004c98ed in mieqProcessInputEvents () at mieq.c:375
#5  0x000000000047e029 in ProcessInputEvents () at xf86Events.c:174
#6  0x000000000044725e in Dispatch () at dispatch.c:399
#7  0x000000000042cd5d in main (argc=4, argv=0x7fffa85b1b98, envp=<value optimized out>) at main.c:383


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.5.99.3-5.fc11.x86_64


How reproducible:
unsure

Steps to Reproduce:
1. happens when doing a 'bad' mouse move
2.
3.
  
Actual results:


Expected results:
stable Xorg


Additional info:
Comment 1 Zdenek Kabelac 2009-01-05 07:30:47 EST
Created attachment 328191 [details]
Xorg.log from the last crash

in case it would be helpful - here is the log file from the second coredump
Comment 2 James Ettle 2009-01-25 14:21:41 EST
Created attachment 329949 [details]
Xorg log from crash [1.5.99.901-1.fc11]

I've just run into this --- all I did was click on the GNOME panel. See attached Xorg log for more info.

xorg-x11-server-Xorg-1.5.99.901-1.fc11.i386
xorg-x11-drv-ati-6.10.0-1.fc11.i386
kernel-2.6.29-0.48.rc2.git1.fc11.i686
Comment 3 Tom London 2009-01-25 18:58:01 EST
Created attachment 329961 [details]
Xorg.0.log from server crash: Caught signal 11

Looks like I got one of these as well:

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x26) [0x4e95d6]
1: /usr/bin/Xorg(xf86SigHandler+0x39) [0x47dc99]
2: /lib64/libc.so.6 [0x39aba32fe0]
3: /usr/bin/Xorg(DeliverEventsToWindow+0x464) [0x454094]
4: /usr/bin/Xorg(DeliverDeviceEvents+0x36a) [0x454b1a]
5: /usr/bin/Xorg(ProcessOtherEvent+0x35c) [0x53627c]
6: /usr/bin/Xorg(ProcessKeyboardEvent+0xcd) [0x55dfbd]
7: /usr/bin/Xorg(mieqProcessInputEvents+0x32e) [0x4ca02e]
8: /usr/bin/Xorg(ProcessInputEvents+0x9) [0x47e809]
9: /usr/bin/Xorg(Dispatch+0x29e) [0x44732e]
10: /usr/bin/Xorg(main+0x3bd) [0x42cdcd]
11: /lib64/libc.so.6(__libc_start_main+0xe6) [0x39aba1e5c6]
12: /usr/bin/Xorg [0x42c259]

Fatal server error:
Caught signal 11.  Server aborting

System is Thinkpad X200, 

[root@tlondon ~]# rpm -qa xorg-x11-server\*
xorg-x11-server-utils-7.4-3.fc10.x86_64
xorg-x11-server-Xorg-1.5.99.901-1.fc11.x86_64
xorg-x11-server-common-1.5.99.901-1.fc11.x86_64
[root@tlondon ~]# 

Screen "just went black", and after about 30 seconds, gdm-greeter started to appear again.
Comment 4 Matěj Cepl 2009-01-26 11:42:07 EST
Created attachment 330000 [details]
/var/log/Xorg.0.log

Just putting here my bug triagers "me too" :)
Comment 5 Peter Hutterer 2009-01-27 02:05:45 EST
(In reply to comment #1)
> #0  CheckMotion (xE=0x0, pDev=0xa1cc020) at events.c:2554
> 2554     prevSpriteWin = pSprite->win;

I'm pretty sure this one was fixed with
http://cgit.freedesktop.org/xorg/xserver/commit/?id=e1a3a1a0d85c9971aea65c2228b5fd4dbf3bf57a, please update to 1.5.99.901-5.

The other one appears to be a motion event being posted through the keyboard device - and crashing when trying to dereference the pointer information. I'm not sure yet why that happens, but it seems somewhat similar in nature to
http://bugs.freedesktop.org/show_bug.cgi?id=19574.

Do you have a reproducible test-case, I haven't found how to trigger it yet.
Comment 6 Zdenek Kabelac 2009-01-27 04:50:35 EST
Hmm - as for the second 'weird' event - it might have happened when I've been testing some 'evdev' functionality - unfortunately I've no reproducer for this.
(i.e. running kbd driver for keyboard and evdev for usb mouse and trackpoint)

For some time I'm now running only 'evdev' devices and I do not experience these problems (with the hope that kvm will have its keyboard handling fixed soon - maybe they would need help of experienced X developer  see #478976)
Comment 7 Peter Hutterer 2009-02-01 20:29:38 EST
Matej, Tom, James: do you have a reproducible test case for me?
Comment 8 Matěj Cepl 2009-02-02 06:22:40 EST
(In reply to comment #7)
> Matej, Tom, James: do you have a reproducible test case for me?

Absolutely not for me -- just clicked somewhere on gajim or something and Xorg went down. Didn't happen since then.
Comment 9 Tom London 2009-02-02 06:43:08 EST
(In reply to comment #7)
> Matej, Tom, James: do you have a reproducible test case for me?

No, sorry....

Don't recall seeing it again after report in #3.
Comment 10 Peter Hutterer 2009-02-02 19:31:47 EST
Ok, I'll pretend it's fixed then :)

I'll leave the needinfo flag set for now then so matej can close it in a month if it doesn't reoccur.
Comment 11 Zdenek Kabelac 2009-02-25 07:44:06 EST
I've not seen this error anymore - thought I'm not using any combination of evdev and older kbd driver as well. If there will be some time - I could try couple experiments.
Comment 12 Matěj Cepl 2009-02-26 09:23:19 EST
(In reply to comment #11)
> I've not seen this error anymore - thought I'm not using any combination of
> evdev and older kbd driver as well. If there will be some time - I could try
> couple experiments.

You got a month. Then this bug is going to die.
Comment 13 Bug Zapper 2009-06-09 06:34:48 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Zdenek Kabelac 2009-07-01 05:23:52 EDT
I think this bug could be closed - I'm seeing bugs with Xorg - but in different area now - so feel free to close this one
Comment 15 Matěj Cepl 2009-07-01 16:54:33 EDT
Your wish is my order! (especially this one :))

Note You need to log in before you can comment on or make changes to this bug.