Bug 47886 - gal-0.8-4 only builds when a previous version is present
gal-0.8-4 only builds when a previous version is present
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gal (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-08 18:31 EDT by Christian Hechelmann
Modified: 2013-04-02 00:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-12 10:27:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for locale file install, possible fix for linking problem (4.33 KB, patch)
2001-07-08 18:33 EDT, Christian Hechelmann
no flags Details | Diff
modified spec file (2.03 KB, text/plain)
2001-07-08 18:35 EDT, Christian Hechelmann
no flags Details

  None (edit)
Description Christian Hechelmann 2001-07-08 18:31:24 EDT
Description of Problem:

gal-0.8-4 from rawhide fails to build when no previous version of gal is
installed. This comes from a patch in this version (libgal-borken.patch)
which resolves some dependency problems but introduces others.
The patch adds $(GAL_LIBS) to the link command for libgal.(a|so). When 
doing a fresh, pristine build there is no libgal present in the system, so
the link will fail, but when there is a leftover libgal from a previous 
install is present the new one is linked against the old code, which may 
introduce some interesting effects.

Also, po/Makefile is broken (doesn't use $(DESTDIR)), so locale files
do not make it to $RPM_BUILD_ROOT, instead they end up und 
/usr/share/locale on the build system (when built as root), or aren't 
installed at all due to permission problems (non-root build).

[drdisk@junkyard rawhide]$ ls -l gal-0.8-4.src.rpm 
-rw-rw-r--    1 drdisk   drdisk     985662 Jun 25 02:04 gal-0.8-4.src.rpm
[drdisk@junkyard rawhide]$ rpm -qip gal-0.8-4.src.rpm 
Name        : gal                          Relocations: (not relocateable)
Version     : 0.8                               Vendor: Red Hat, Inc.
Release     : 4                             Build Date: Mon 25 Jun 2001 
08:04:00 CEST
Install date: (not installed)               Build Host: 
elliot.devel.redhat.com
Group       : System Environment/Libraries   Source RPM: (none)
Size        : 987862                           License: GPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.helixcode.com/tech/
Summary     : The GNOME Application Library
Description :
A collection of GNOME widgets and utility functions.



How Reproducible:


Steps to Reproduce:
1. rpm --force -e gal gal-devel libgal
2. rpm --rebuild rawhide/gal-0.8-4.src.rpm

Actual Results:


Expected Results:


Additional Information:
Comment 1 Christian Hechelmann 2001-07-08 18:33:02 EDT
Created attachment 23008 [details]
Fix for locale file install, possible fix for linking problem
Comment 2 Christian Hechelmann 2001-07-08 18:35:05 EDT
Created attachment 23009 [details]
modified spec file
Comment 3 Jonathan Blandford 2001-08-16 13:50:25 EDT
The current version of gal seems to work.

Note You need to log in before you can comment on or make changes to this bug.