Bug 478908 - update FC9 -> FC10 does not work via yum - fc9 kernels are newer than fc10 kernels
update FC9 -> FC10 does not work via yum - fc9 kernels are newer than fc10 ke...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-05 17:40 EST by shrek-m
Modified: 2009-01-05 18:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-05 18:39:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shrek-m 2009-01-05 17:40:14 EST
Description of problem:
yum update  from fc9 -> fc10 is not possible
the fc9 kernels are newer than the fc10 kernels

the fedora-relase*.fc10 rpms are installed


Version-Release number of selected component (if applicable):
$ grep installonly /etc/yum.conf

installonly_limit=4


# rpm -q kernel
kernel-2.6.27.5-37.fc9.x86_64
kernel-2.6.27.5-41.fc9.x86_64
kernel-2.6.27.7-53.fc9.x86_64
kernel-2.6.27.9-73.fc9.x86_64

$ rpm -qa fedora-rel*
fedora-release-notes-10.0.0-1.noarch
fedora-release-10-1.noarch



How reproducible:
always


Steps to Reproduce:
1. fc9 - yum update
2. rpm -Uvh fedora-release*10-1*
3. yum update


Actual results:
package kernel-2.6.27.7-53.fc9.x86_64
(which is newer than kernel-2.6.27.5-117.fc10.x86_64) is already installed
package kernel-2.6.27.9-73.fc9.x86_64
(which is newer than kernel-2.6.27.5-117.fc10.x86_64) is already installed

Expected results:
the fc10 (+ updates) kernel should be newer than the fc9 (+ updates) kernel


Additional info:
[... yum update ...]
(1499/1501): openoffice.org-core-3.0.0-9.10.fc10.x86_64.rpm      |  99 MB     01:33     

----------------------------------------------------------------------------------------
Total                                                   1.0 MB/s | 1.7 GB     29:37     

Warnung: rpmts_HdrFromFdno: Header V3 DSA-Signatur: NOKEY, key ID 4ebfc273
updates/gpgkey                                                   | 2.3 kB     00:00     

Importiere GPG-Schlüssel 0x4EBFC273 "Fedora (10) <fedora@fedoraproject.org>" von /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64
Ist dies in Ordnung? [j/N] :j
============================================================================================================================= Entering rpm code ==============================================================================================================================
Führe rpm_check_debug durch
Führe Verarbeitungsstest durch
Verarbeitungstest beendet


Prüffehler bei Verarbeitung:
  package kernel-2.6.27.7-53.fc9.x86_64 (which is newer than kernel-2.6.27.5-117.fc10.x86_64) is already installed
  package kernel-2.6.27.9-73.fc9.x86_64 (which is newer than kernel-2.6.27.5-117.fc10.x86_64) is already installed

Fehler-Zusammenfassung
-------------
Comment 1 shrek-m 2009-01-05 18:39:28 EST
sorry,

"1499/1501" - 2 missing packages and more

# rm -f /var/cache/yum/update/packages/kernel*

# yum clean headers
# yum clean metadata


# yum update
[...]
Führe rpm_check_debug durch
Führe Verarbeitungsstest durch
Verarbeitungstest beendet
Verarbeitungstest erfolgreich
Führe Verarbeitung durch
  Aktualisieren  : libgcc                                                                    1/2893 
  Aktualisieren  : setup                                                                     2/2893 
[...]

Note You need to log in before you can comment on or make changes to this bug.