This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 478910 - RFE: time zone (CRON_TZ) support
RFE: time zone (CRON_TZ) support
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: vixie-cron (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Marcela Mašláňová
Brock Organ
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-05 17:45 EST by daryl herzmann
Modified: 2011-09-14 05:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-14 05:39:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description daryl herzmann 2009-01-05 17:45:39 EST
Hi,

I would find it incredibly useful to have vixie-cron support user's setting their own timezone for their crontabs.  Searching around, I found this bz:

https://bugzilla.redhat.com/show_bug.cgi?id=227577

and it mentions a patch that was made for rawhide vixie-cron.  I don't follow Fedora closely, but it appears this patch made it into cronie for Fedora.

It'd be nice to have it for RHEL5 or RHEL6 :)

Thanks for your consideration. 

daryl
Comment 1 Jan Schaumann 2009-02-18 13:05:48 EST
Yes, this would be very useful in large scale environments where hosts are running UTC, but individual crontabs require timezone specific cronjobs.  Put me down for a +1.
Comment 2 Marcela Mašláňová 2009-02-19 01:56:27 EST
In the next release RHEL-6 will be included cronie with this feature.
Comment 3 Jan Schaumann 2009-02-19 09:20:43 EST
Any chance this can be added to RHEL5 ?
Comment 4 Marcela Mašláňová 2009-02-19 09:34:53 EST
I don't know what are the plans for RHEL-5. For inclusion of feature you should contact your support.
Comment 5 Xavier Bachelot 2010-02-03 10:38:07 EST
Marcela, the patch[1] you wrote for vixie-cron at the time applies fine to the current EL5 vixie-cron package (vixie-cron-4.1-77.el5_4.1) and works fine. It would really be nice to get this applied in an update to EL5 vixie-cron rather than to wait for the not yet announced EL6.
As a side note, I'm changing the product version to 5.4, as it still applies to this point release.

[1] http://git.fedorahosted.org/git/cronie.git?p=cronie.git;a=commitdiff_plain;h=c818ce8f02b38c4d473f610a33e26b5fd7899b29
Comment 6 Marcela Mašláňová 2010-02-04 02:37:59 EST
I can reopen, but I can't say if this feature will be added in next update.
Comment 7 Joshua Baldock 2010-03-30 23:40:48 EDT
I would really like to see this released. Is there any ETA of a near release of vixie-cron with CRON_TZ support?
Comment 8 Marcela Mašláňová 2010-03-31 02:36:34 EDT
CRON_TZ feature brought a new bug #436694 into cronie. This feature could be backported only with this bug. Fix of #436694 means rewrite logic of scheduling jobs, which is intrusive change with unpredictable consequences. That's reason, why I hadn't fix it yet in upstream.

If you really want this feature, you should contact your support because it's not planned for inclusion as far as I know.
Comment 9 Joshua Baldock 2010-03-31 19:44:09 EDT
I would really like to see this released. Is there any ETA of a near release of vixie-cron with CRON_TZ support?
Comment 10 Radek Vokal 2010-04-14 04:29:56 EDT
Please contact www.redhat.com/support to raise priority of this issue. The feature was committed to upstream and will appear in next supported release of RHEL.
Comment 11 daryl herzmann 2010-04-21 14:02:39 EDT
Thanks all for getting it added to RHEL6, just tested it out :)
Comment 13 RHEL Product and Program Management 2010-08-09 14:19:15 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 14 RHEL Product and Program Management 2011-01-11 15:18:24 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 15 RHEL Product and Program Management 2011-01-12 10:18:02 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 16 RHEL Product and Program Management 2011-05-31 09:18:21 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 17 Marcela Mašláňová 2011-09-14 05:39:05 EDT
As I said in comment#8 - adding of CRON_TZ support brings serious bug #436694.
It has to be changed the essentials of running jobs and I definitely don't want
jeopardize normal execution of jobs in RHEL-5 for a new feature.

It's fixed in RHEL-6 in successor of vixie-cron - cronie.

Note You need to log in before you can comment on or make changes to this bug.