Bug 478978 - X server ignores input.x11_options from hal policy
X server ignores input.x11_options from hal policy
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
10
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-06 05:58 EST by Bradley T. Hughes
Modified: 2009-01-11 17:44 EST (History)
1 user (show)

See Also:
Fixed In Version: xorg-x11-drv-evdev-2.1.0-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-10 08:46:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New hal policy file that I placed in /etc/hal/fdi/policy/11-x11-logitech-cordless-optical-trackman.fdi (655 bytes, text/plain)
2009-01-06 05:58 EST, Bradley T. Hughes
no flags Details
My xorg.conf from F8 (1.51 KB, text/plain)
2009-01-06 05:59 EST, Bradley T. Hughes
no flags Details
Xorg.0.log (12.87 KB, text/plain)
2009-01-06 06:00 EST, Bradley T. Hughes
no flags Details
output of lshal (134.59 KB, text/plain)
2009-01-06 06:02 EST, Bradley T. Hughes
no flags Details

  None (edit)
Description Bradley T. Hughes 2009-01-06 05:58:46 EST
Created attachment 328263 [details]
New hal policy file that I placed in /etc/hal/fdi/policy/11-x11-logitech-cordless-optical-trackman.fdi

Description of problem:

I just installed F10 to replace my F8 installation. Previously, I had used xorg.conf to configure my Logitech Cordless Optical Trackman into a usable state. Now that F10 is out with HAL hot-plugging goodness, I tried to convert my xorg.conf options to a custom hal policy.


Version-Release number of selected component (if applicable):

How reproducible:

Always reproducable... I've attached my new fdi policy file as well as my old xorg.conf. Output of lshal shows that hal picks up the x11_options (relevant lshal output also attached), however, Xorg does not use these options (Xorg.0.log attached).

Additional info:

This is pretty unfortunate for me at the moment, because without this configuration my trackball axis is off by a little over 30 degrees, which makes the trackball very clumsy to use. As a previous carpal tunnel sufferer, I am hoping to find a way to get this working quickly. Any tips on what I may be doing wrong are greatly appreciated.
Comment 1 Bradley T. Hughes 2009-01-06 05:59:31 EST
Created attachment 328264 [details]
My xorg.conf from F8
Comment 2 Bradley T. Hughes 2009-01-06 06:00:31 EST
Created attachment 328265 [details]
Xorg.0.log

When looking here, I don't see that the mouse driver recognizes any of the options from the hal policy
Comment 3 Bradley T. Hughes 2009-01-06 06:02:12 EST
Created attachment 328266 [details]
output of lshal

You can see that the x11_options are present on the Logitech USB Receiver device here, though (but the X server does not use them).
Comment 4 Peter Hutterer 2009-01-08 18:53:41 EST
AngleOffset is not a supported option anymore, it was removed in the big cleanup/revert before evdev 2.0.

The other options require evdev 2.1, which should be in stable by now. Please update the xorg-x11-drv-evdev package.
Comment 5 Bradley T. Hughes 2009-01-09 04:51:32 EST
Ouch... so basically I'm stuck with having the off-center axis? Are there any other options I can use to improve the ergonomics of my trackball?
Comment 6 Bradley T. Hughes 2009-01-09 05:23:09 EST
FYI, I just upgraded the xorg-x11-drv-evdev package, and now I see that the options are indeed picked up (except for AngleOffset, as you mentioned).
Comment 7 Matěj Cepl 2009-01-10 08:46:28 EST
Thanks for letting us know.
Comment 8 Peter Hutterer 2009-01-11 17:44:39 EST
(In reply to comment #5)
> Ouch... so basically I'm stuck with having the off-center axis? Are there any
> other options I can use to improve the ergonomics of my trackball?

if you have the time, you can probably just pick up the patches for the off-center axis from a previous evdev version and re-implement it on top of master. evdev master is still quite a small codebase and should be easy to get into. Feel free to either file a RFE on bugs.freedesktop.org, or send the patch to the xorg mailing list (xorg@lists.freedesktop.org).

Note You need to log in before you can comment on or make changes to this bug.