Bug 47902 - rhn_register (console app) cannot find redhat-release in RPM database
Summary: rhn_register (console app) cannot find redhat-release in RPM database
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn_register
Version: 6.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-08 23:21 UTC by Need Real Name
Modified: 2015-01-07 23:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2001-07-08 23:34:26 UTC


Attachments (Terms of Use)

Description Need Real Name 2001-07-08 23:21:20 UTC
Description of Problem:
I could not use rhn_register-1.3.1 due to another bug that you've already
fixed, so I upgraded to rhn_register-1.3.6-1.  I then ran rhn_register as
root inside an xterm.  It crashed, but it pointed me to the problem and I
used my mad Python skills (I don't know Python) to fix it (not the best
fix, probably, so don't expect a patch).

In /usr/share/rhn/register/rhnreg.py from 1.3.6-1, there is a call 
   index = db.findbyprovides("redhat-release")
that fails.  I changed it to 'findbyname' and it succeeded.  (You don't
check the result, so the next line's call to db[index] crashed.)


How Reproducible:
Every time with my RPM database, which is originally RH 6.2 with many
packages, e.g. rpm, upgraded.

Steps to Reproduce:
1. Go to my apartment, ... ;->
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Adrian Likins 2001-07-08 23:34:23 UTC
Try running:

      rpm --rebuilddb

And trying it again. The error you report is indicative of
a rpm db problem caused on some upgrades. The "rpm --rebuilddb"
will fix it.


Note You need to log in before you can comment on or make changes to this bug.