Bug 479029 - sudo version is compiled with --with-secure-path flag
sudo version is compiled with --with-secure-path flag
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sudo (Show other bugs)
5.3
All Linux
low Severity urgent
: rc
: ---
Assigned To: Daniel Kopeček
BaseOS QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-06 11:14 EST by Martin Kočí
Modified: 2009-01-20 16:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:53:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Kočí 2009-01-06 11:14:05 EST
there is a regression between versions : 


version sudo-1.6.9p17-2.el5: 

# sudo -u testkoca printenv PATH
/sbin:/bin:/usr/sbin:/usr/bin


version sudo-1.6.8p12-12.el5:
# sudo -u testkoca printenv PATH
/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin
Comment 2 Peter Vrabec 2009-01-06 12:00:16 EST
The problem is in this line in spec file:

configure --with-secure-path="/sbin:/bin:/usr/sbin:/usr/bin"

It cause, that PATH variable is hard-coded. It's a big change for RHEL and it will make many people UNHAPPY and ANGRY.

It happens by mistake when spec file for this rebase was created. There is nothing easier than get rid of this line and recompile.
Comment 9 errata-xmlrpc 2009-01-20 16:53:36 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0191.html

Note You need to log in before you can comment on or make changes to this bug.