Bug 47904 - Anaconda crashes when formatting(?) SCSI swap partition
Anaconda crashes when formatting(?) SCSI swap partition
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i586 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-08 20:26 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-17 10:53:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-08 20:26:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)

Description of problem:
SystemError: (6, 'Device not configured')

How reproducible:
Always

Steps to Reproduce:
1.Install RH 7.0 multi-CD on unformatted Quantum Atlas 10K using Adaptec 
2940U2W
2.
3.
	

Actual Results:  Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in 
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "fstab.py", line 715, in mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (6, 'Device not configured')

Local variables in innermost frame:
size: 1847443
fsystem: ext2
self: <fstab.GuiFstab instance at 84bae68>
msg: Device not configured
doFormat: 1
errno: 6
device: sda8
instPath: /mnt/sysimage
mntpoint: /

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


Expected Results:  Successful install.

Additional info:

Refer to Bugzilla Bugs 18294 and 31051.
Comment 1 Brent Fox 2001-07-11 02:39:32 EDT
Can you try Red Hat Linux 7.1?  I don't think that we've had these kind of
reports with it.
Comment 2 Need Real Name 2001-07-11 23:50:34 EDT
I would be happy to try Red Hat Linux 7.1. Please ship
me the 7.1 CD set.

I ran some additional tests, and obtained some additional information.
I used a Win98 startup disk to partion the disk using FDISK;
I used the default parameters to make one giant partion.
I rebooted using the Win98 startup floppy, and the partion table
was NOT found!
This clearly lets anaconda off the hook, apart from its poor
diagnostic information; apparently anaconda writes a partition
table, but doesn't verify that the partition table was written
correctly (or perhaps this is the fault of Disk Druid).
Anyway, i ran some more tests with different parameters (
smaller partition, multiple partition, SCSI BIOS disk verify,
SCSI BIOS disk format, Win95 FDISK, WinMe FDISK). I beat up
on that poor disk, and couldn't get it to hold a partion table.
I verified that i had the latest Adaptec BIOS.
I conjecture there is some incompatibility between the
Adaptec controller and the Quantum disk; perhaps Adaptec can't
handle the 18GB, or perhaps it is just a bad drive.

I returned the disk, and got a replacement Quantum Atlas 10K
9GB drive. I was able to FDISK and FORMAT the drive using Win98.
Now when i install Red Hat Linux 7.0, install hangs on loading
the aic7xxx driver! Bugzilla has a dozen problem reports on this.
For example, refer to 23973. In this prolem report, the fix is
to get a driver update from Adaptec. At the Adaptec site, they
provide the SOURCE code, rather than a ladable driver image
that can be used in expert install mode.

So puuullleeeaaassssee, send me a update aic7xxx loadable driver image
that i can install in expert mode (even though i'm a Linux newbie),
or go ahead and send me the Red Hat 7.1 CD set.
I really would like to get off MS Windows and on to a robust
UNIX-like system, but i certainly didn't expect the install process
for Red Hat to be so difficult.
Thanks for your help.
Comment 3 Brent Fox 2001-07-17 10:53:40 EDT
Adaptec does provide driver disks for Red Hat Linux 7.0 (loadable drivers...not
just the source code) at
http://www.adaptec.com/worldwide/support/driversbycat.html?cat=%2fOperating%20System%2fLinux

However, I didn't see the 2940U2W controller in the list.  Since Adaptec
maintains these drivers, you should contact them for a driver disk for your
controller.

There have been problems with the Adaptec drivers for some time now.  Some
Adaptec cards work really well, and some seem to have problems.  Now that
Adaptec has taken over the maintenance of the driver, hopefully these problems
will be avoided in the future.

As for 7.1, I'd recommend giving it a try.  I can't guarantee that it will solve
the problem, but it's worth a shot.  I can't just send a 7.1 box set to everyone
that asks for one, but it is available free of charge at w that Adaptec has
taken over the maintenance of the driver, hopefully these problems will be
avoided in the future.

As for 7.1, I'd recommend giving it a try. I can't guarantee that it will solve
the problem, but it's worth a shot. I can't just send a 7.1 box set to everyone
that asks for one, but it is available free of charge at
ftp://ftp.redhat.com/redhat/linux/7.1/en/iso/i386 or at many other mirror sites.

Note You need to log in before you can comment on or make changes to this bug.