Bug 479054 - fixfiles restore should have the -F flag added.
fixfiles restore should have the -F flag added.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
: 488585 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-06 14:19 EST by Daniel Walsh
Modified: 2014-03-16 23:16 EDT (History)
3 users (show)

See Also:
Fixed In Version: 8.86.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-06 14:28:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to add -F option (547 bytes, application/octet-stream)
2009-01-06 14:20 EST, Daniel Walsh
no flags Details

  None (edit)
Description Daniel Walsh 2009-01-06 14:19:15 EST
Description of problem:

A couple of customers are switching from targeted policy to MLS policy.  The mechanism to do this is to change the /etc/selinux/config file, touch /.autorelabel; reboot

/etc/rc.sysinit sees the flag file and attempts to relabel the system, but it does not change labels on user homedirectories if the user componant "unconfined_u" is the only section of the file context that has changed.  Adding the -F flag forces the relabel of all files.
Comment 1 Daniel Walsh 2009-01-06 14:20:33 EST
Created attachment 328305 [details]
Patch to add -F option

Needed for F10 and Rawhide.
Comment 2 Bill Nottingham 2009-01-06 14:26:46 EST
http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=6301b2ffb38f91906ffb329931a00fc9e8d6590e

Cherry-picked to F10 branch, as well - update will come at some point in the future.
Comment 3 Bill Nottingham 2009-03-04 16:12:20 EST
*** Bug 488585 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2009-04-02 14:04:59 EDT
initscripts-8.86.1-1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/initscripts-8.86.1-1
Comment 5 Fedora Update System 2009-04-03 00:16:40 EDT
initscripts-8.86.2-1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/initscripts-8.86.2-1
Comment 6 Fedora Update System 2009-04-22 16:23:09 EDT
initscripts-8.86.3-1 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.