Bug 479132 - RHEL4 kvm virtio: kudzu support for probing for virtio devices
RHEL4 kvm virtio: kudzu support for probing for virtio devices
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kudzu (Show other bugs)
4.8
All Linux
low Severity medium
: rc
: ---
Assigned To: Bill Nottingham
BaseOS QE
:
Depends On:
Blocks: 446215
  Show dependency treegraph
 
Reported: 2009-01-07 09:16 EST by Chris Lalancette
Modified: 2014-03-16 23:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
* this version of kudzu includes support for virtio devices, for accelerating Red Hat Enterprise Linux 4 virtual machines.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:12:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to implement kudzu support for virtio (10.16 KB, patch)
2009-01-07 09:17 EST, Chris Lalancette
no flags Details | Diff
Patch to fix device name (1.37 KB, patch)
2009-01-08 11:45 EST, Chris Lalancette
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0970 normal SHIPPED_LIVE kudzu bug fix update 2009-05-18 09:41:02 EDT

  None (edit)
Description Chris Lalancette 2009-01-07 09:16:53 EST
kudzu needs support for probing for virtio devices in order for anaconda
installs of kvm virtio guests to work.

Attached patch just implements it in a similar manner to the xen device probing
support. One notable difference is that we need to have the normal PCI bus
probing ignoring virtio devices.
Comment 1 Chris Lalancette 2009-01-07 09:17:34 EST
Created attachment 328376 [details]
Patch to implement kudzu support for virtio
Comment 2 Bill Nottingham 2009-01-07 15:53:38 EST
Building as 1.1.95.25-1.
Comment 3 Chris Lalancette 2009-01-08 11:45:42 EST
Created attachment 328476 [details]
Patch to fix device name

Ug.  I screwed up the previous patch, and just set all ->device to vd, not realizing that in RHEL-4 kudzu it is up to the individual driver to assign /dev/vda, /dev/vdb, etc.  This patch should fix that up.  I've gotten further with this in place, but I still haven't successfully started an install; I'm fighting a bug with LVM at the moment.
Comment 4 Chris Lalancette 2009-01-12 05:55:39 EST
OK, I've now figured out what the LVM problem was, and it doesn't seem to have anything to do with kudzu (that one seems to be an anaconda problem).  By applying a workaround to anaconda, I was able to successfully complete an install with the above patch in place, so I think this is probably ready to commit.

Chris Lalancette
Comment 5 Bill Nottingham 2009-01-12 16:14:05 EST
Building as 1.1.95.26-1.
Comment 8 Ruediger Landmann 2009-01-16 01:56:05 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
* this version of kudzu includes support for virtio devices, for accelerating Red Hat Enterprise Linux 4 virtual machines.
Comment 11 errata-xmlrpc 2009-05-18 16:12:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0970.html

Note You need to log in before you can comment on or make changes to this bug.