Bug 479221 - Error: Missing Dependency: NetworkManager >= 1:0.7.0-1.git20090102 is needed by package anaconda-11.4.1.63-1.i386 (updates)
Error: Missing Dependency: NetworkManager >= 1:0.7.0-1.git20090102 is needed ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-07 23:58 EST by Basil Mohamed Gohar
Modified: 2009-02-12 19:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-12 19:07:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Basil Mohamed Gohar 2009-01-07 23:58:34 EST
Description of problem:
yum is having an error with upgrading when both NetworkManager & anaconda are installed.

Version-Release number of selected component (if applicable):


How reproducible:
All the time

Steps to Reproduce:
1. run yum clean all
2. run yum update
3. observe the dependency conflict
  
Actual results:
yum reports a dependency conflict

Expected results:
yum updates all software without error

Additional info:
Comment 1 Julian Aloofi 2009-01-10 15:21:37 EST
I can confirm this problem. I tried to update a new installed system (from KDE-LiveCD). I got the same error. For some reason, KPackageKit is able to resolve the dependencies.
Comment 2 Julian Aloofi 2009-01-10 15:57:56 EST
After system update with KPackageKit yum installs the anaconda update and NetworkManager without complaining. (KPackageKit didn't install them for some reason).
Comment 3 Basil Mohamed Gohar 2009-01-10 16:13:06 EST
I have recently updated and I did not have this problem anymore, so I think the dependency issue has been resolved.  Maybe you can try a yum clean all and rerun your updates.
Comment 4 Julian Aloofi 2009-01-10 18:29:14 EST
(In reply to comment #3)
> I have recently updated and I did not have this problem anymore

Neither have I, I guess the missing dependency got uploaded or something else.
I think when nobody else receives this error we can close the bug.
Comment 5 Dan Williams 2009-02-12 19:07:12 EST
NetworkManager-0.7.0-1.git20090102.fc10 should have hit F-10 stable updates 38 days ago; so I think this can be closed.

Note You need to log in before you can comment on or make changes to this bug.