Bug 47925 - Memory leak in kdeinit: kicker
Summary: Memory leak in kdeinit: kicker
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-09 03:57 UTC by Need Real Name
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-10 13:53:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-07-09 03:57:20 UTC
Description of Problem:
Memory leak in kicker, most noticable after 1 months operation.
This is the second time this has happened, after the first instance i 
upgraded hte kde packages to what was available in rh7.1 updates.

[root@jaxx /tmp]# which kicker
/usr/bin/kicker
[root@jaxx /tmp]# rpm -qf /usr/bin/kicker
kdebase-2.1.1-8
[root@jaxx /tmp]# rpm -qa | grep kde
kdepim-2.1.1-1
kdetoys-2.1.1-2
kdelibs-devel-2.1.2-1
kdesupport-2.1-3
kdeadmin-2.1.1-3
kdemultimedia-2.1.1-1
kdenetwork-ppp-2.1.1-1
kdesupport-devel-2.1-3
kdelibs-2.1.2-1
switchdesk-kde-3.9.5-1
kdegraphics-2.1.1-1
kdelibs-sound-2.1.2-1
kdenetwork-2.1.1-1
kdebase-2.1.1-8
kdeutils-2.1.1-1
kdegames-2.1.1-1
xmms-kde-0.6.5-1
kdelibs-sound-devel-2.1.2-1


How Reproducible:
run kde for over 2 weeks

Steps to Reproduce:
1. as above
2. 
3. 

Actual Results:
[root@jaxx /tmp]# ps aux | grep kicker
lindley  19818  0.0 38.2 423532 97696 ?      S    Jun13   4:11 kdeinit: 
kicker


Expected Results:
more conservitave memory usage

Additional Information:
running xinerama configuration in Xfree 4.0.3-5

Comment 1 Bernhard Rosenkraenzer 2001-07-10 13:53:52 UTC
Probably xinerama related as I can't reproduce it here on a "normal" setup.
Have you tried updating to the 2.2 pre-releases? They're supposed to support 
xinerama officially.


Comment 2 Bernhard Rosenkraenzer 2002-01-22 12:49:26 UTC
Assuming fixed.


Note You need to log in before you can comment on or make changes to this bug.