Bug 479263 - cheese freezes and turn 100% CPU usage upon starting recording a video
cheese freezes and turn 100% CPU usage upon starting recording a video
Status: CLOSED DUPLICATE of bug 476341
Product: Fedora
Classification: Fedora
Component: cheese (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-08 08:54 EST by Peter Janakiev
Modified: 2009-01-11 08:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-11 08:28:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Janakiev 2009-01-08 08:54:37 EST
Description of problem:
Cheese application is unable to make a video from my web cam:
usb 5-1: new full speed USB device using uhci_hcd and address 2
usb 5-1: configuration #1 chosen from 1 choice
usb 5-1: New USB device found, idVendor=046d, idProduct=08da
usb 5-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
Linux video capture interface: v2.00
gspca: main v2.2.0 registered
gspca: probing 046d:08da
zc3xx: probe 2wr ov vga 0x0000
zc3xx: probe sensor -> 11
zc3xx: Find Sensor HV7131R(c)
gspca: probe ok
gspca: probing 046d:08da
gspca: probing 046d:08da
usbcore: registered new interface driver zc3xx
zc3xx: registered
usbcore: registered new interface driver snd-usb-audio
zc3xx: probe 2wr ov vga 0x0000
zc3xx: probe 2wr ov vga 0x0000
zc3xx: probe 2wr ov vga 0x0000
zc3xx: probe 2wr ov vga 0x0000
zc3xx: probe 2wr ov vga 0x0000
zc3xx: probe 2wr ov vga 0x0000
zc3xx: probe 2wr ov vga 0x0000

After attaching my old web cam it seem to not work for video recoding, I start it and it shows only few frames and then freezes and the CPU is going up to 100%. I cannot stop the recoding (I am able to press the stop button but it just greys out and nothing changes) I have to kill the app to stop it.


Version-Release number of selected component (if applicable):
cheese-2.24.2-1.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1. Attach the cam and start cheese
2. Switch to video mode and press record
3.
  
Actual results:
The image freezes and the CPU stands at 100% until the application is killed

Expected results:
Normal video recording

Additional info:
It might be something with the kernel also, because skype is also exiting if I try to use it with the webcam, in f9 both skype and cheese used to work very well.
Comment 1 Hans de Goede 2009-01-11 08:28:10 EST
This is not a problem with the video recording, but with the audio recording, see bug 476341.

As for skype, try launching it from a terminal like this:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

*** This bug has been marked as a duplicate of bug 476341 ***

Note You need to log in before you can comment on or make changes to this bug.