Bug 479266 - ISE on selecting the Organizations name
ISE on selecting the Organizations name
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
urgent Severity high
: ---
: ---
Assigned To: Shannon Hughes
Preethi Thomas
:
: 479076 (view as bug list)
Depends On:
Blocks: 456998
  Show dependency treegraph
 
Reported: 2009-01-08 09:33 EST by Preethi Thomas
Modified: 2009-09-10 15:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:48:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2009-01-08 09:33:05 EST
Description of problem:

ISE on selecting the Organizations name.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20081223.1-i386-embedded-oracle.iso
How reproducible:


Steps to Reproduce:
1. Login to a 530 satellite
2. Navigate to Admin->Organizations
3.Click on the organization name for eg: Miroslav Suchy  *
  
Actual results:

ISE

Expected results:
The Organization detail page for Miroslav Suchy  * should be displayed

Additional info:
The following exception occurred while executing this request:
GET /rhn/admin/multiorg/OrgDetails.do

Date:1/8/09 9:00:14 AM EST
Headers:
  host: rlx-3-08.rhndev.redhat.com
  user-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.16) Gecko/20080722 Fedora/2.0.0.16-1.rhis Firefox/2.0.0.16
  accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
  accept-language: en-us,ar;q=0.8,ja;q=0.5,ml;q=0.3
  accept-encoding: gzip,deflate
  accept-charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Keep-Alive: 300
  connection: keep-alive
  referer: https://rlx-3-08.rhndev.redhat.com/rhn/admin/multiorg/Organizations.do
  cookie: JSESSIONID=C6A979E1E7C7BCC01D7F0D93248976BE; rh_omni_tc=70160000000H4AjAAK; s_vi=[CS]v1|4947F54700007CC6-A3A094800000EF9[CE]; pxt-session-cookie=41xfcc90a0ec29d67071e96fbd754cf184a

Request:
Local Name = rlx-3-08.rhndev.redhat.com
Server Name = rlx-3-08.rhndev.redhat.com
Requested Session Id came from Cookie
Requested Session Valid = true
Session = org.apache.catalina.session.StandardSessionFacade@7850785[session=StandardSession[C6A979E1E7C7BCC01D7F0D93248976BE]]
Protocol = https
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = rhnActiveLang, javax.servlet.jsp.jstl.fmt.timeZone.request, javax.servlet.request.key_size, __sitemesh__filterapplied, orgDetailsForm, javax.servlet.request.ssl_session, javax.servlet.request.cipher_suite, org.apache.struts.action.MESSAGE, session, org.apache.struts.action.mapping.instance, requestedUri, org.apache.struts.action.MODULE,


User Information:
User admin (id 1, org_id 1)

Exception:
javax.servlet.ServletException: ORA-00904: "KS"."KS_TYPE": invalid identifier

        at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)
        at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:237)
        at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
        at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:73)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
        at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)
        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
        at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)
        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685)
        at java.lang.Thread.run(Thread.java:735)
Caused by: com.redhat.rhn.common.db.WrappedSQLException: ORA-00904: "KS"."KS_TYPE": invalid identifier

        at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:112)
        at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:331)
        at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:288)
        at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java:745)
        at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java:219)
        at oracle.jdbc.driver.T4CPreparedStatement.executeForDescribe(T4CPreparedStatement.java:813)
        at oracle.jdbc.driver.OracleStatement.executeMaybeDescribe(OracleStatement.java:1049)
        at oracle.jdbc.driver.T4CPreparedStatement.executeMaybeDescribe(T4CPreparedStatement.java:854)
        at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1154)
        at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:3370)
        at oracle.jdbc.driver.OraclePreparedStatement.execute(OraclePreparedStatement.java:3476)
        at com.mchange.v2.c3p0.impl.NewProxyPreparedStatement.execute(NewProxyPreparedStatement.java:651)
        at com.redhat.rhn.common.db.NamedPreparedStatement.execute(NamedPreparedStatement.java:137)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:448)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:425)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:329)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:334)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:274)
        at com.redhat.rhn.common.db.datasource.SelectMode.execute(SelectMode.java:105)
        at com.redhat.rhn.common.db.datasource.DataList.getDataList(DataList.java:71)
        at com.redhat.rhn.domain.org.OrgFactory.getKickstarts(OrgFactory.java:322)
        at com.redhat.rhn.manager.org.OrgManager.toDetailsDto(OrgManager.java:70)
        at com.redhat.rhn.frontend.action.multiorg.OrgDetailsAction.setupFormValues(OrgDetailsAction.java:79)
        at com.redhat.rhn.frontend.action.multiorg.OrgDetailsAction.execute(OrgDetailsAction.java:68)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
        ... 40 more
Caused by: java.sql.SQLException: ORA-00904: "KS"."KS_TYPE": invalid identifier

        ... 65 more
Comment 1 Shannon Hughes 2009-01-26 15:40:04 EST
the schema to support this issue should be in the latest iso on 1/26/09
Comment 2 Shannon Hughes 2009-01-26 15:44:12 EST
*** Bug 479076 has been marked as a duplicate of this bug. ***
Comment 3 Preethi Thomas 2009-01-29 16:40:59 EST
verified in 
Satellite-5.3.0-RHEL5-re20090127.2-i386-embedded-oracle.iso

No ISE on clicking on organization names.
Comment 4 Brad Buckingham 2009-07-30 16:45:51 EDT
verified in 7/24 stage iso... moving to RELEASE_PENDING
Comment 5 Brandon Perkins 2009-09-10 15:48:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.