Bug 479333 - kernel binaries for rawhide really bloated with null bytes
kernel binaries for rawhide really bloated with null bytes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-08 16:44 EST by Michal Jaegermann
Modified: 2009-01-13 18:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-13 18:50:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2009-01-08 16:44:04 EST
Description of problem:

kernel-2.6.29-0.12.rc0.git7.fc11.x86_64.rpm package has a quite reasonable size of 24 Megs but for a disk installation it claims 1035938542 bytes.  You are reading that right.  Something about 1 Gig.

A closer look reveals that this happens because all modules are amply padded with null bytes and 'cp -a --sparse=always ...' on this kernel module tree reduces its size from 997M to 76M (with a kernel after such operation still bootable - not so surprisingly).

The preceding rawhide kernel, i.e. 2.6.29-0.9.rc0.git4.fc11, has a module tree which takes 188M of a disk space.  This is of the same order as with other, relatively recent, rawhide kernels.  Still making those modules sparse drops that size down to 78M which is also significant.

Apart of gobbling a disk space like crazy these "null fattened" modules make kernel installation scripts to run slow as molasses.  Something "interesting" happened with a toolchain?
Comment 1 Michal Jaegermann 2009-01-13 18:50:42 EST
Recent "2.6.29-0.X.rc1" kernels have module directories of a more reasonable size.  Passing those through 'cpio -pmd --sparse' still slims them down by
roughly 60% but we are not talking gigabytes anymore.

Note You need to log in before you can comment on or make changes to this bug.