Bug 479378 - ovirt-stand-alone mode does not persist /var/log files
ovirt-stand-alone mode does not persist /var/log files
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-09 01:33 EST by Perry Myers
Modified: 2011-07-01 21:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-08 20:43:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2009-01-09 01:33:57 EST
Description of problem:
When the Node boots to stand-alone mode the user is given the option to configure a persistent logging partition and specify the max size of the logs.  However, on reboot all logs (for example the setup/boot logs) are not saved so there is no way to do any troubleshooting after the first boot.

In addition, the /var/log partition should probably be bind mounted to the logging partition on the persistent disk.  For /config we bind mount selective files but for logging we should probably just bind mount the entire /var/log directory so that we don't need to individually bind mount files.

Version-Release number of selected component (if applicable):
0.97-0

How reproducible:


Steps to Reproduce:
1. boot node via USB disk using ovirt_standalone mode
2. configure node to use local disk for logging
3. configure log size to be 1000k or so
4. continue to exit firstboot
5. logs are in /var/log for all ovirt setup tasks
6. reboot the node
  
Actual results:
setup logs are not persisted because /var/log is not persisted to the logging partition

Expected results:
all logs should be persisted if the user elects to have a persistent log partition

Additional info:
Comment 1 Bryan Kearney 2009-01-13 11:26:08 EST
Please see the patch in


https://www.redhat.com/archives/ovirt-devel/2009-January/msg00093.html

The patch will mount the local logging partition if it exists, and backs up the current log files into /var/log-backups. There is one hole, and that is on the initial boot. if the user does the following:

1. boot node via USB disk using ovirt_standalone mode
2. configure node to use local disk for logging
3. configure log size to be 1000k or so
4. configure the disk partitioning
5. continue to exit firstboot
6. logs are in /var/log for all ovirt setup tasks
7. reboot the node

Then the logs are lost. The way to to ensure that the data is not lost is to configure the disk partitioning, then reboot, then continue the configuration.

Note You need to log in before you can comment on or make changes to this bug.