Bug 479391 - HP P1005 doesn't print
HP P1005 doesn't print
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
HP P1005 doesn't print
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-09 04:35 EST by antonio montagnani
Modified: 2009-05-12 16:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 05:27:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Troubleshooting of test page (51.69 KB, text/plain)
2009-01-09 04:35 EST, antonio montagnani
no flags Details
Troubleshhoting as per comment #2 (30.05 KB, text/plain)
2009-01-09 06:21 EST, antonio montagnani
no flags Details

  None (edit)
Description antonio montagnani 2009-01-09 04:35:42 EST
Created attachment 328528 [details]
Troubleshooting of test page

Description of problem:
HP P1005 doesn't print

Version-Release number of selected component (if applicable):
cups-1.3.9-6.fc10.i386


How reproducible:
always

Steps to Reproduce:
1.print any document or test page
2.
3.
  
Actual results:
No print

Expected results:
it should print

Additional info:
I installed HP drivers from rpmfusion foo2zjs-0.20080826-1.fc10
dmesg says that printer is recognized:
usb 2-5: new high speed USB device using ehci_hcd and address 6
usb 2-5: configuration #1 chosen from 1 choice
usblp0: USB Bidirectional printer dev 6 if 0 alt 0 proto 2 vid 0x03F0 pid 0x3D17
usb 2-5: New USB device found, idVendor=03f0, idProduct=3d17
usb 2-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 2-5: Product: HP LaserJet P1005
usb 2-5: Manufacturer: Hewlett-Packard
usb 2-5: SerialNumber: BA1844E

When I send a test page the print ques is correct but I do not get any output
I attach a troubleshooting file from system-config-printer.
Comment 1 Tim Waugh 2009-01-09 05:23:52 EST
Everything looks fine except:

* there is no debugging output from foo2zjs, although it seems to behave normally
* there is no indication that the hp backend finished

Please take a look in /var/log/messages and locate the messages for that period of time (January 9th at 9:08am).  There might be some HPLIP messages of interest.
Comment 2 antonio montagnani 2009-01-09 06:19:31 EST
(In reply to comment #1)
> Everything looks fine except:
> 
> * there is no debugging output from foo2zjs, although it seems to behave
> normally
> * there is no indication that the hp backend finished
> 
> Please take a look in /var/log/messages and locate the messages for that period
> of time (January 9th at 9:08am).  There might be some HPLIP messages of
> interest.

from /var/log/messages
Jan  9 12:11:29 acerF10 kernel: ppdev: user-space parallel port driver
Jan  9 12:12:16 acerF10 foo2zjs-wrapper: foo2zjs-wrapper -P -r600x600 -p9 -s7 -m1 -n1
Jan  9 12:12:27 acerF10 foo2zjs-wrapper: gs -sPAPERSIZE=a4 -g4960x7016 -r600x600 -sDEVICE=pbmraw -dCOLORSCREEN -dMaxBitmap=500000000

I had to repeat the procedure as /var/log/messages/ was truncated on Jan 7!!!
I suppose that this is a separate issue.I do not know how to get the debugging output from foo2zjs.
Please note that now P1005 is connected to a Vista box, but it correctly detected.(I am carrying same tests also on a rawhide machine)
Tnx for help
Comment 3 antonio montagnani 2009-01-09 06:21:34 EST
Created attachment 328537 [details]
Troubleshhoting as per comment #2

I re-attach troubleshooting file according to comment #2
Comment 4 Tim Waugh 2009-01-12 05:27:21 EST
Well, if HPLIP is eliminated from the problem, it must be foo2zjs.
Comment 5 antonio montagnani 2009-01-12 06:28:33 EST
I have similar troubles in Rawhide, I will file a separate bug
Comment 6 Mads Kiilerich 2009-05-12 16:52:01 EDT
Are you sure it is a zjs printer? According to http://foo2xqx.rkkda.com/ it is a xqx printer.

Note You need to log in before you can comment on or make changes to this bug.