Bug 479415 - kmod-gnbd built for 2.6.18-98.el5
kmod-gnbd built for 2.6.18-98.el5
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnbd-kmod (Show other bugs)
5.3
i386 Linux
low Severity low
: rc
: ---
Assigned To: Chris Feist
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-09 08:39 EST by Marian Ganisin
Modified: 2009-05-13 16:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 17:57:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Ganisin 2009-01-09 08:39:04 EST
Description of problem:
All kmod-gnbd packages in latest RHEL 5.3 RC are built against kernel 2.6.18-98.el5, however current kernel version is 2.6.18-128.el5.

Version-Release number of selected component (if applicable):
RHEL5.3-Server-20090106.0
kmod-gnbd-0.1.5-2.el5.i686.rpm
kmod-gnbd-PAE-0.1.5-2.el5.i686.rpm
kmod-gnbd-xen-0.1.5-2.el5.i686.rpm

Additional info:
$ pwd
/mnt/redhat/rel-eng/RHEL5.3-Server-20090106.0/5/i386/os
$ ls ./Server/kernel-2*.rpm
./Server/kernel-2.6.18-128.el5.i686.rpm
$ rpm -qlp ./ClusterStorage/kmod-gnbd-0.1.5-2.el5.i686.rpm
/lib/modules/2.6.18-98.el5
/lib/modules/2.6.18-98.el5/extra
/lib/modules/2.6.18-98.el5/extra/gnbd
/lib/modules/2.6.18-98.el5/extra/gnbd/gnbd.ko
/lib/modules/2.6.18-98.el5/kernel
Comment 2 Chris Feist 2009-02-24 17:57:54 EST
This isn't an issue because 5.3 kernel modules are not dependedent on any one kernel version.  You can modprobe modules that were built for older kernels.

Note You need to log in before you can comment on or make changes to this bug.