Bug 479453 - Circular locking in NFS
Circular locking in NFS
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Layton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-09 13:09 EST by Jay Fenlason
Modified: 2014-08-31 19:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-28 15:00:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg after compile attempt (39.58 KB, text/plain)
2009-01-09 13:09 EST, Jay Fenlason
no flags Details

  None (edit)
Description Jay Fenlason 2009-01-09 13:09:24 EST
Created attachment 328579 [details]
dmesg after compile attempt

Description of problem:
When attempting to build firewire-ipv4 on a freshly booted system, I get the attached error.

Version-Release number of selected component (if applicable):
2.6.29-0.19.rc0.git9.fc11.i686

How reproducible:
This has been pretty reliable for a few kernel versions now.

Steps to Reproduce:
1.reboot fenlason-lab1.boston.devel.redhat.com
2.log in; cd n; rm *.o *.ko; make -f Makefile.stand
3.Observe error in dmesg
  
Actual results:
Attached circular locking error

Expected results:
No error

Additional info:
Comment 1 Jeff Layton 2009-01-13 07:36:17 EST
Apparently this is a false alarm. Looks like peterz has a patch to silence the warnings that should be going upstream soon. Until then it appears that the warning can be ignored...

See discussion on linux-nfs upstream list for more info.
Comment 2 Dave Jones 2009-01-28 14:47:43 EST
did that patch get merged?  Worth keeping this open?
Comment 3 Jeff Layton 2009-01-28 15:00:44 EST
Yes. It did get merged:

commit 95156f0051cba60ec674bbaa5cf7dc74a74c5612
Author: Peter Zijlstra <a.p.zijlstra@chello.nl>
Date:   Mon Jan 12 13:02:11 2009 +0100

    lockdep, mm: fix might_fault() annotation
    
    Some code (nfs/sunrpc) uses socket ops on kernel memory while holding
    the mmap_sem, this is safe because kernel memory doesn't get paged out,
    therefore we'll never actually fault, and the might_fault() annotations
    will generate false positives.
    
    Reported-by: "J. Bruce Fields" <bfields@fieldses.org>
    Signed-off-by: Peter Zijlstra <a.p.zijlstra@chello.nl>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>

...closing as CURRENTRELEASE (please correct that if it's not the right resolution)...

Note You need to log in before you can comment on or make changes to this bug.