Bug 479498 - hal-find-by-capability --capability net.80203 does not find virtio network devices
hal-find-by-capability --capability net.80203 does not find virtio network de...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: hal (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Richard Hughes
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-09 20:08 EST by Perry Myers
Modified: 2016-04-26 10:35 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-07 09:38:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2009-01-09 20:08:30 EST
Description of problem:
Running hal-find-by-capability --capability net.80803 on a RHEL5.3 guest that is booted as a KVM virtual machine using virtio network interface does not show any devices.

Running hal-device shows:

32: udi = '/org/freedesktop/Hal/devices/pci_1af4_1000'
  info.udi = '/org/freedesktop/Hal/devices/pci_1af4_1000'  (string)
  linux.subsystem = 'pci'  (string)
  linux.hotplug_type = 1  (0x1)  (int)
  pci.subsys_product = 'Unknown (0x0001)'  (string)
  pci.subsys_vendor = 'Unknown (0x0000)'  (string)
  info.product = 'Virtio network device'  (string)
  pci.product = 'Virtio network device'  (string)
  info.vendor = 'Qumranet, Inc.'  (string)
  pci.vendor = 'Qumranet, Inc.'  (string)
  pci.device_protocol = 0  (0x0)  (int)
  pci.device_subclass = 0  (0x0)  (int)
  pci.device_class = 2  (0x2)  (int)
  pci.subsys_vendor_id = 0  (0x0)  (int)
  pci.subsys_product_id = 1  (0x1)  (int)
  pci.vendor_id = 6900  (0x1af4)  (int)
  pci.product_id = 4096  (0x1000)  (int)
  info.linux.driver = 'virtio-pci'  (string)
  pci.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:03.0'  (string)
  info.parent = '/org/freedesktop/Hal/devices/computer'  (string)
  info.bus = 'pci'  (string)
  linux.sysfs_path_device = '/sys/devices/pci0000:00/0000:00:03.0'  (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:03.0'  (string)

Note that there is no line like:
  info.capabilities = { 'net', 'net.80203', 'wake_on_lan' } (string list)
in this section.  The lack of info.capabilities for the virtio device is why the find by capabilities command is not returning any devices.

On Fedora 10 hosts, running hal-device shows does show the info.capabilities line.

Version-Release number of selected component (if applicable):
hal-0.5.8.1-38.el5

How reproducible:
Every time

Steps to Reproduce:
1. Boot RHEL53 guest on kvm host with virtio network device enabled
2. Run hal-find-by-capability --capability net.80203
3.
  
Actual results:
No device found

Expected results:
Should find the virtio device as it does in Fedora 10

Additional info:
Comment 1 Darryl L. Pierce 2009-01-12 11:18:52 EST
I'm unable to reproduce there(In reply to comment #0)
> Description of problem:
> Running hal-find-by-capability --capability net.80803 on a RHEL5.3 guest that

This may be a typo: There's not "net.80803" but instead "net.80203". Which was used on the VM?

> How reproducible:
> Every time
> 
> Steps to Reproduce:
> 1. Boot RHEL53 guest on kvm host with virtio network device enabled
> 2. Run hal-find-by-capability --capability net.80203

On my RHEL5.3 VM I get the following:

[root@localhost ~]# hal-find-by-capability --capability net.80203
/org/freedesktop/Hal/devices/net_00_16_3e_4a_45_9e
[root@localhost ~]# hal-device net_00_16_3e_4a_45_9e
udi = '/org/freedesktop/Hal/devices/net_00_16_3e_4a_45_9e'
  info.udi = '/org/freedesktop/Hal/devices/net_00_16_3e_4a_45_9e'  (string)
  linux.subsystem = 'net'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  net.80203.mac_address = 95534335390  (0x163e4a459e)  (uint64)
  info.product = 'Networking Interface'  (string)
  net.arp_proto_hw_id = 1  (0x1)  (int)
  net.linux.ifindex = 2  (0x2)  (int)
  net.address = '00:16:3e:4a:45:9e'  (string)
  net.interface = 'eth0'  (string)
  net.physical_device = '/org/freedesktop/Hal/devices/pci_10ec_8139'  (string)
  info.capabilities = { 'net', 'net.80203' } (string list)
  info.category = 'net.80203'  (string)
  info.parent = '/org/freedesktop/Hal/devices/pci_10ec_8139'  (string)
  linux.sysfs_path = '/sys/class/net/eth0'  (string)

This is a virtio device and is reported properly.
Comment 2 Alan Pevec 2009-01-12 11:51:35 EST
pci_10ec_8139 is emulated rtl NIC, not virtio-net
Comment 3 Perry Myers 2009-01-14 10:52:47 EST
> Description of problem:
> Running hal-find-by-capability --capability net.80803 on a RHEL5.3 guest that

In above statement from Comment #0 80803 is a typo.  I did use 80203 when I ran the test.
Comment 7 RHEL Product and Program Management 2014-03-07 08:43:15 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Note You need to log in before you can comment on or make changes to this bug.