Bug 479516 - HP/Compaq nx7300 touchpad frozen in X
HP/Compaq nx7300 touchpad frozen in X
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
10
i386 Linux
low Severity low
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-10 09:00 EST by Ronald L Humble
Modified: 2009-01-12 19:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 19:24:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (23.47 KB, text/plain)
2009-01-10 09:00 EST, Ronald L Humble
no flags Details
Xorg.0.log no xorg.conf (25.11 KB, text/plain)
2009-01-10 09:02 EST, Ronald L Humble
no flags Details
xorg.conf paired with Xorg.0.log (2.27 KB, text/plain)
2009-01-10 09:03 EST, Ronald L Humble
no flags Details
output from lshal command (1015 bytes, text/plain)
2009-01-10 09:07 EST, Ronald L Humble
no flags Details
Output of lshal as user root on nx7300 laptop (113.95 KB, text/plain)
2009-01-12 09:32 EST, Ronald L Humble
no flags Details

  None (edit)
Description Ronald L Humble 2009-01-10 09:00:06 EST
Created attachment 328621 [details]
Xorg.0.log

Description of problem:

HP/Compaq nx7300 running patched f10

Using f9, perhaps with update Dec 10 to
xorg-x11-drv-evdev-2.0.8-1
Option  "AllowEmptyInputs" "false" was added to unfreeze
the touchpad.

With Jan 8 update to
xorg-x11-drv-evdev-2.1.0-1 I got triple keyboard input such
as in bug 467573 and touchpad frozen. Removing the above Option and adding
Option "AutoAddDevices" "off" has restored all
functionality to the laptop.

I have no altered or added hal fdi rules.
Removal of the xorg.conf file produced
Xorg.0.log.no_conf
keyboard worked, touchpad cursor frozen.

Version-Release number of selected component (if applicable):
xorg-x11-drv-evdev-2.1.0-1

How reproducible: Used xorg.conf produced by 
Xorg -configure. Boot to X or use startx


Steps to Reproduce:
1.Boot to X
2.
3.
  
Actual results:
keyboard works, touchpad cursor frozen

Expected results:
keyboard and touchpad function normally

Additional info:
Comment 1 Ronald L Humble 2009-01-10 09:02:22 EST
Created attachment 328622 [details]
Xorg.0.log no xorg.conf
Comment 2 Ronald L Humble 2009-01-10 09:03:58 EST
Created attachment 328623 [details]
xorg.conf paired with Xorg.0.log
Comment 3 Ronald L Humble 2009-01-10 09:07:12 EST
Created attachment 328624 [details]
output from lshal command
Comment 4 Peter Hutterer 2009-01-11 18:33:21 EST
(In reply to comment #0)
> Using f9, perhaps with update Dec 10 to
> xorg-x11-drv-evdev-2.0.8-1
> Option  "AllowEmptyInputs" "false" was added to unfreeze
> the touchpad.
> 
> With Jan 8 update to
> xorg-x11-drv-evdev-2.1.0-1 I got triple keyboard input such
> as in bug 467573 and touchpad frozen. Removing the above Option and adding
> Option "AutoAddDevices" "off" has restored all
> functionality to the laptop.

This is a bug in F9 that cannot be fixed and AllowEmptyInput is the wrong option in F10. Your choice is correct, although removing the option AutoAddDevices althogether would be better.


anyway. Please attach the full output of lshal -m, the part you attached only lists the in-kernel mouse button emulation for apple laptops. I need to see the part that represents your touchpad. Judging by the X log, the touchpad is misconfigured in the kernel and appears as a keyboard (provided that b43-phy0 is actually the touchpad).
Comment 5 Ronald L Humble 2009-01-12 09:32:40 EST
Created attachment 328741 [details]
Output of lshal as user root on nx7300 laptop

Output is from lshal (no -m switch). -m is monitor mode. I used the laptop for a few minutes but never got any output from lshahl -m. If the -m switch is needed, please inform me as to what needs to be done to produce useful output. Thank you for your time. Ron H.
Comment 6 Peter Hutterer 2009-01-12 16:58:53 EST
(In reply to comment #5)
> Output is from lshal (no -m switch). -m is monitor mode.
of course, sorry, brain wasn't quite there yet yesterday.


do you have the xorg-x11-drv-synaptics package installed? Your touchpad is there and looks normal, but evdev won't pick up touchpads unless you tweak the configuration a bit. Just install the synaptics driver and it'll work.

the reason why it worked with f9 is most likely because f9 used the mouse driver and synaptics feeds into /dev/input/mice, which in turn is picked up by the mouse driver. mouse is disabled now, so you need to make sure the server picks it up, and xorg-x11-drv-synaptics does that for you.
Comment 7 Ronald L Humble 2009-01-12 18:16:41 EST
Installation of xorg-x11-drv-synaptics did indeed solve the problem.

After installation, all "InputDevice" and "Option" lines were commented out of
Section "ServerLayout" in xorg.conf. Section "InputDevice" sections relating to the keyboard and mouse were commented out as well.

Rebooted the laptop. /var/log/Xorg.0.log reports in part...
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
        If no devices become available, reconfigure HAL or disable
AllowEmptyInput.
...
(II) Loading /usr/lib/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
        compiled for 1.5.0, module version = 0.15.2
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.1
(II) Synaptics touchpad driver version 0.15.2

of which the lines below the ellipsis are obviously new with the synaptics driver.

This was an upgrade from f9 to f10 instead of a fresh install (which I know is
not recommended). I am glad this was an easy fix for both of us. I in no way
treat this process as a personal troubleshooting desk, and do not contact you
flippantly. Unless questioned, this matter is closed. Thank you again for your
professionalism and patience.
Comment 8 Peter Hutterer 2009-01-12 19:24:58 EST
Closing as NOTABUG, missing package was the culprit.

Note You need to log in before you can comment on or make changes to this bug.