Bug 479532 - texturedXrender enabled crashes X
texturedXrender enabled crashes X
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drivers (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-10 14:08 EST by Eddie Lania
Modified: 2009-01-10 17:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-10 17:27:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eddie Lania 2009-01-10 14:08:21 EST
Description of problem: Using fglrx driver and texturedXrender enabled causes X unable to start (Segfault).


Version-Release number of selected component (if applicable):

xorg-x11-server-devel-1.5.3-6.fc10.i386
xorg-x11-server-Xorg-1.5.3-6.fc10.i386
xorg-x11-server-utils-7.4-3.fc10.i386
xorg-x11-server-common-1.5.3-6.fc10.i386

fedora-release-10-1.noarch

kmod-fglrx-2.6.27.9-159.fc10.i686-8.561-2.8.12.fc10.2.i686
xorg-x11-drv-fglrx-libs-8.561-6.8.12.fc10.i386
kmod-fglrx-8.561-2.8.12.fc10.2.i686
xorg-x11-drv-fglrx-8.561-6.8.12.fc10.i386


How reproducible: Use fglrx driver and enable texturedXrender.


Steps to Reproduce:
1. Install Fedora 10

2. Install fglrx driver

3. Put 'Option "texturedxrender" "on"' in xorg.conf in the Device section.

4. Put 'Option "RENDER" "Enable"' in xorg.conf in the Extensions section.


  
Actual results: X is unable to start


Expected results: X is able to start


Additional info:
Comment 1 Matěj Cepl 2009-01-10 17:27:43 EST
Thanks for the report. We are sorry that we cannot help you with your problem, but we are not able to support binary-only drivers. If you would be able to reproduce this issue using only open source software, please, reopen this bug with the additional information, but in meantime I have no choice than to close this bug as CANTFIX (because we really cannot fix it).

Note You need to log in before you can comment on or make changes to this bug.