Bug 479544 - gnome-power-manager fails to start on login
gnome-power-manager fails to start on login
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-10 20:16 EST by John Murphy
Modified: 2009-08-20 07:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-20 07:41:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this contains all the requested debug info (19.32 KB, text/plain)
2009-01-29 17:01 EST, John Murphy
no flags Details

  None (edit)
Description John Murphy 2009-01-10 20:16:43 EST
Description of problem:
When, from the panel, I open the System->Preferences->System->Power Management dialog... select the General tab and under Notification Area check the radio button for "Always display an icon"... it fails to make any change for me even after restarting the system.
Oddly, it does set the new default for a new user added to the system, but still will not show the icon on the main system user's panel.
I have also observed that I do not have access to the full range of settings that should be available.

Version-Release number of selected component (if applicable):


How reproducible:
See description of problem.

Steps to Reproduce:
1.
2.
3.
See description of problem.
  
Actual results:
See description of problem.


Expected results:
See description of problem.


Additional info:
Comment 1 Steven M. Parrish 2009-01-11 07:50:35 EST
Reassigning to guidance-power-manager
Comment 2 Rex Dieter 2009-01-11 08:26:15 EST
afaict, kde doesn't have a system->preferences->system menu.

Reporter, are you using kde or gnome or other?
Comment 3 John Murphy 2009-01-11 15:52:02 EST
(In reply to comment #2)
> afaict, kde doesn't have a system->preferences->system menu.
> 
> Reporter, are you using kde or gnome or other?

gnome 2.24.2
Comment 4 John Murphy 2009-01-11 15:55:58 EST
given the lack of full access to the settings is this somehow a permissions problem? I messed around some but could not figure a way to open this as su, but I am a newless clubie so maybe I simply did not stumble blindly upon it.

Also, I am thinking the fact that always show icon is still an available option and that it _did_ apparently let me set it as a new user default (at least - when I added a second user on my system so my wife could use the machine she gets the icon all the time) means that there is something else wrong here.
Comment 5 Rex Dieter 2009-01-11 16:13:06 EST
reassigning -> gnome-power-manager
Comment 6 Richard Hughes 2009-01-13 06:01:39 EST
Please attach the output of gnome-power-bugreport.sh. Thanks.
Comment 7 John Murphy 2009-01-14 07:46:55 EST
(In reply to comment #6)
> Please attach the output of gnome-power-bugreport.sh. Thanks.

Can not find the specified file. However...

[root@john-murphy-laptop-localhost john-murphy]# gnome-power-manager --verbose --no-daemon

(gnome-power-manager:3326): GnomeUI-WARNING **: While connecting to session manager:
None of the authentication protocols specified are supported.
TI:07:45:35	TH:0x26095b0	FI:egg-debug.c	FN:egg_debug_init,281
 - Verbose debugging 1 (on console 1)
TI:07:45:35	TH:0x26095b0	FI:gpm-main.c	FN:main,206
 - GNOME Power Manager 2.24.2
TI:07:45:35	TH:0x26095b0	FI:gpm-main.c	FN:main,221
 - Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
TI:07:45:35	TH:0x26095b0	FI:gpm-main.c	FN:main,226
 - This program cannot start until you start the dbus session service.

This is usually started automatically in X or gnome startup when you start a new session.
Traceback:
	gnome-power-manager [0x408637]
	gnome-power-manager [0x41f9af]
	/lib64/libc.so.6(__libc_start_main+0xe6) [0x31e8e1e576]
	gnome-power-manager [0x407e89]
[root@john-murphy-laptop-localhost john-murphy]# 

Is this what you might mean?
Comment 8 John Murphy 2009-01-27 15:35:00 EST
my xsession error log, after attempting to start the pwr mgr gui, shows the following...

** (gnome-power-preferences:3736): WARNING **: DBUS error: Could not get owner of name 'org.gnome.ScreenSaver': no such name
** (gnome-power-preferences:3736): DEBUG: proxy is NULL, maybe the daemon responsible for org.gnome.ScreenSaver is not running?
** (gnome-power-preferences:3736): DEBUG: already disconnected from org.gnome.ScreenSaver

pretty sure something is really messed up on my system, or with the pwr mgr itself. been 2 wks with no update... any help here?
Comment 9 Richard Hughes 2009-01-28 03:34:34 EST
Are you logging in as the root user?
Comment 10 John Murphy 2009-01-28 10:13:01 EST
"[root@john-murphy-laptop-localhost john-murphy]"
so... yes in the case of Comment #7
in the case of looking at my xsession error log in Comment #8, no.

hang on I will poke around some more including trying to access the gui as root (which I believe I somehow did before with no difference but better be sure before I say that with any certainty)
Comment 11 John Murphy 2009-01-28 10:34:43 EST
su - instead of su? seems to make a difference in the terminal

here is the output from gpm now...
(note I have no idea what to do from the terminal in this app - it just keeps spewing data every 5 seconds but I do not know how to use this to get to the gui or if that is even the intended use)

in F10 you can no longer log in as root, although as seen you can su from the terminal (yeah duh), so I am searching for how to access the gpm gui ie on the panel as root, if anyone has a pointer it would help me answer more quickly, but I will look around and see if I can figure it out.

[john-murphy@john-murphy-laptop-localhost ~]$ su -
Password: 
[root@john-murphy-laptop-localhost ~]# gnome-power-manager --verbose --no-daemon
TI:10:28:25	TH:0xe2a5b0	FI:egg-debug.c	FN:egg_debug_init,281
 - Verbose debugging 1 (on console 1)
TI:10:28:25	TH:0xe2a5b0	FI:gpm-main.c	FN:main,206
 - GNOME Power Manager 2.24.2
TI:10:28:25	TH:0xe2a5b0	FI:egg-console-kit.c	FN:egg_console_kit_init,202
 - Failed to get session for pid 3319: Unable to lookup session information for process '3319'
TI:10:28:25	TH:0xe2a5b0	FI:gpm-ac-adapter.c	FN:gpm_ac_adapter_init,200
 - using /org/freedesktop/Hal/devices/computer_power_supply_ac_adapter_ADP1
TI:10:28:25	TH:0xe2a5b0	FI:gpm-button.c	FN:gpm_button_grab_keystring,183
 - Grabbed modmask=0, keycode=124
TI:10:28:25	TH:0xe2a5b0	FI:gpm-button.c	FN:gpm_button_grab_keystring,183
 - Grabbed modmask=0, keycode=150
TI:10:28:25	TH:0xe2a5b0	FI:gpm-button.c	FN:gpm_button_grab_keystring,183
 - Grabbed modmask=0, keycode=233
TI:10:28:25	TH:0xe2a5b0	FI:gpm-button.c	FN:gpm_button_grab_keystring,183
 - Grabbed modmask=0, keycode=232
TI:10:28:25	TH:0xe2a5b0	FI:gpm-button.c	FN:gpm_button_grab_keystring,183
 - Grabbed modmask=0, keycode=160
TI:10:28:25	TH:0xe2a5b0	FI:gpm-button.c	FN:gpm_button_grab_keystring,183
 - Grabbed modmask=0, keycode=238
TI:10:28:25	TH:0xe2a5b0	FI:gpm-button.c	FN:gpm_button_grab_keystring,183
 - Grabbed modmask=0, keycode=237
TI:10:28:25	TH:0xe2a5b0	FI:gpm-button.c	FN:gpm_button_grab_keystring,183
 - Grabbed modmask=0, keycode=236
TI:10:28:25	TH:0xe2a5b0	FI:gpm-button.c	FN:coldplug_buttons,446
 - Watching /org/freedesktop/Hal/devices/computer_logicaldev_input_5
TI:10:28:25	TH:0xe2a5b0	FI:gpm-button.c	FN:coldplug_buttons,446
 - Watching /org/freedesktop/Hal/devices/computer_logicaldev_input
TI:10:28:25	TH:0xe2a5b0	FI:gpm-button.c	FN:coldplug_buttons,446
 - Watching /org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input
TI:10:28:25	TH:0xe2a5b0	FI:gpm-button.c	FN:coldplug_buttons,446
 - Watching /org/freedesktop/Hal/devices/computer_logicaldev_input_0
TI:10:28:25	TH:0xe2a5b0	FI:gpm-button.c	FN:coldplug_buttons,446
 - Watching /org/freedesktop/Hal/devices/computer_logicaldev_input_2
TI:10:28:25	TH:0xe2a5b0	FI:gpm-button.c	FN:coldplug_buttons,446
 - Watching /org/freedesktop/Hal/devices/computer_logicaldev_input_1
TI:10:28:25	TH:0xe2a5b0	FI:gpm-button.c	FN:coldplug_buttons,446
 - Watching /org/freedesktop/Hal/devices/computer_logicaldev_input_4
TI:10:28:25	TH:0xe2a5b0	FI:gpm-button.c	FN:coldplug_buttons,446
 - Watching /org/freedesktop/Hal/devices/usb_device_c45_62c0_SN0001_if0_logicaldev_input

** (gnome-power-manager:3319): WARNING **: DBUS error: Could not get owner of name 'org.gnome.ScreenSaver': no such name
** (gnome-power-manager:3319): DEBUG: proxy is NULL, maybe the daemon responsible for org.gnome.ScreenSaver is not running?
TI:10:28:25	TH:0xe2a5b0	FI:gpm-screensaver.c	FN:gpm_screensaver_proxy_connect_more,119
 - not connected
TI:10:28:25	TH:0xe2a5b0	FI:gpm-brightness-xrandr.c	FN:gpm_brightness_xrandr_setup_display,167
 - No outputs have backlight property
TI:10:28:25	TH:0xe2a5b0	FI:gpm-brightness-hal.c	FN:gpm_brightness_hal_init,458
 - No devices of capability laptop_panel
TI:10:28:25	TH:0xe2a5b0	FI:gpm-prefs-server.c	FN:gpm_prefs_server_set_capability,84
 - capability now 4
TI:10:28:25	TH:0xe2a5b0	FI:gpm-feedback-widget.c	FN:gpm_feedback_set_icon_name,164
 - Using icon name 'gpm-brightness-lcd'
TI:10:28:25	TH:0xe2a5b0	FI:gpm-light-sensor.c	FN:gpm_light_sensor_get_absolute,146
 - no hardware!
TI:10:28:25	TH:0xe2a5b0	FI:gpm-backlight.c	FN:gpm_backlight_brightness_evaluate_and_set,367
 - no dimming hardware
TI:10:28:25	TH:0xe2a5b0	FI:gpm-backlight.c	FN:gpm_backlight_sync_policy,160
 - choosing sensible default
TI:10:28:25	TH:0xe2a5b0	FI:gpm-backlight.c	FN:gpm_backlight_sync_policy,162
 - laptop, so use GPM_DPMS_METHOD_OFF
TI:10:28:25	TH:0xe2a5b0	FI:gpm-backlight.c	FN:gpm_backlight_sync_policy,194
 - BACKLIGHT parameters 0 0 1800, method '4'
TI:10:28:25	TH:0xe2a5b0	FI:gpm-dpms.c	FN:gpm_dpms_set_enabled,408
 - setting DPMS enabled: 1
TI:10:28:25	TH:0xe2a5b0	FI:gpm-dpms.c	FN:x11_sync_server_dpms_settings,130
 - Syncing DPMS settings enabled=1 timeouts=0 0 0
TI:10:28:25	TH:0xe2a5b0	FI:gpm-dpms.c	FN:x11_sync_server_dpms_settings,130
 - Syncing DPMS settings enabled=1 timeouts=0 0 0
TI:10:28:25	TH:0xe2a5b0	FI:gpm-idle.c	FN:gpm_idle_set_check_cpu,236
 - Setting the CPU load check to 0
TI:10:28:25	TH:0xe2a5b0	FI:gpm-manager.c	FN:gpm_manager_init,1803
 - creating new inhibit instance
TI:10:28:25	TH:0xe2a5b0	FI:gpm-manager.c	FN:gpm_manager_init,1813
 - creating new control instance
TI:10:28:25	TH:0xe2a5b0	FI:gpm-manager.c	FN:gpm_manager_init,1818
 - creating new tray icon
TI:10:28:25	TH:0xe2a5b0	FI:gpm-control.c	FN:gpm_control_is_user_privileged,110
 - failed to authorise for privilege org.freedesktop.hal.power-management.suspend
TI:10:28:25	TH:0xe2a5b0	FI:gpm-control.c	FN:gpm_control_is_user_privileged,110
 - failed to authorise for privilege org.freedesktop.hal.power-management.hibernate
TI:10:28:25	TH:0xe2a5b0	FI:gpm-manager.c	FN:gpm_manager_init,1827
 - initialising info infrastructure
TI:10:28:25	TH:0xe2a5b0	FI:gpm-profile.c	FN:gpm_profile_init,910
 - creating new control instance
TI:10:28:25	TH:0xe2a5b0	FI:gpm-profile.c	FN:gpm_profile_init,931
 - on AC
TI:10:28:25	TH:0xe2a5b0	FI:gpm-idle.c	FN:gpm_idle_set_system_timeout,287
 - Setting system idle timeout: 0
TI:10:28:25	TH:0xe2a5b0	FI:gpm-warnings.c	FN:gpm_warnings_init,249
 - Using per-time notification policy
TI:10:28:25	TH:0xe2a5b0	FI:gpm-phone.c	FN:gpm_phone_dbus_connect,267
 - get connection

TI:10:28:25	TH:0xe2a5b0	FI:gpm-phone.c	FN:gpm_phone_dbus_connect,278
 - get proxy

TI:10:28:25	TH:0xe2a5b0	FI:gpm-phone.c	FN:gpm_phone_dbus_connect,286
 - Cannot connect, maybe the daemon is not running: Could not get owner of name 'org.gnome.phone': no such name

TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_check_device_key,738
 - checking primary against primary
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_add_device_id,822
 - adding the right kind of battery: primary
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,66
 - device         Laptop battery
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,67
 - present        1
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,68
 - percent        100.0
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,69
 - is charging    0
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,70
 - is discharging 0
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,72
 - charge current 34408
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,75
 - charge last    34408
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,78
 - charge design  43200
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,90
 - capacity       79
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,93
 - voltage        12445
TI:10:28:25	TH:0xe2a5b0	FI:gpm-profile.c	FN:gpm_profile_set_config_id,783
 - config_id = Primary-43200
TI:10:28:25	TH:0xe2a5b0	FI:gpm-profile.c	FN:gpm_profile_load_data,734
 - loading battery data from '/root/.gnome2/gnome-power-manager/profile-Primary-43200-discharging.csv'
TI:10:28:25	TH:0xe2a5b0	FI:gpm-profile.c	FN:gpm_profile_load_data,734
 - loading battery data from '/root/.gnome2/gnome-power-manager/profile-Primary-43200-charging.csv'
TI:10:28:25	TH:0xe2a5b0	FI:gpm-profile.c	FN:gpm_profile_set_config_id,802
 - Reference times
TI:10:28:25	TH:0xe2a5b0	FI:gpm-profile.c	FN:gpm_profile_set_config_id,804
 - 99-0	0 minutes
TI:10:28:25	TH:0xe2a5b0	FI:gpm-profile.c	FN:gpm_profile_set_config_id,806
 - 50-0	0 minutes
TI:10:28:25	TH:0xe2a5b0	FI:gpm-profile.c	FN:gpm_profile_set_config_id,809
 - 0-99	0 minutes
TI:10:28:25	TH:0xe2a5b0	FI:gpm-profile.c	FN:gpm_profile_set_config_id,811
 - 50-99	0 minutes
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_update,352
 - 1 devices of type primary
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_update,399
 - unit->percentage = 100.0
TI:10:28:25	TH:0xe2a5b0	FI:gpm-profile.c	FN:gpm_profile_get_time,311
 - percentage = 100, correcting to 99%
TI:10:28:25	TH:0xe2a5b0	FI:gpm-profile.c	FN:gpm_profile_get_time,311
 - percentage = 100, correcting to 99%
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_collection_changed,782
 - ** EMIT: collection-changed
TI:10:28:25	TH:0xe2a5b0	FI:gpm-engine.c	FN:gpm_engine_recalculate_state,644
 - ignoring due to coldplug
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_percent_changed,538
 - printing combined new device:
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,66
 - device         Laptop battery
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,67
 - present        1
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,68
 - percent        100.0
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,69
 - is charging    0
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,70
 - is discharging 0
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,72
 - charge current 34408
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,75
 - charge last    34408
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,78
 - charge design  43200
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_print,93
 - voltage        12445
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_percent_changed,568
 - No warning
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_update,352
 - 1 devices of type primary
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_update,399
 - unit->percentage = 100.0
TI:10:28:25	TH:0xe2a5b0	FI:gpm-profile.c	FN:gpm_profile_get_time,311
 - percentage = 100, correcting to 99%
TI:10:28:25	TH:0xe2a5b0	FI:gpm-profile.c	FN:gpm_profile_get_time,311
 - percentage = 100, correcting to 99%
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_check_device_key,738
 - checking primary against ups
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_add_device_id,810
 - not adding /org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0 for ups
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_update,279
 - no devices of type 1
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_check_device_key,738
 - checking primary against mouse
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_add_device_id,810
 - not adding /org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0 for mouse
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_update,279
 - no devices of type 2
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_check_device_key,738
 - checking primary against keyboard
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_add_device_id,810
 - not adding /org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0 for keyboard
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_update,279
 - no devices of type 3
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_check_device_key,738
 - checking primary against pda
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_add_device_id,810
 - not adding /org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0 for pda
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_update,279
 - no devices of type 5
TI:10:28:25	TH:0xe2a5b0	FI:gpm-phone.c	FN:gpm_phone_coldplug,79
 - not connected

TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_update,279
 - no devices of type 4
TI:10:28:25	TH:0xe2a5b0	FI:gpm-prefs-server.c	FN:gpm_prefs_server_set_capability,84
 - capability now 12
TI:10:28:25	TH:0xe2a5b0	FI:gpm-engine.c	FN:gpm_engine_get_icon,391
 - Trying CRITICAL icon: primary, ups, mouse, keyboard
TI:10:28:25	TH:0xe2a5b0	FI:gpm-warnings.c	FN:gpm_warnings_get_state_time,85
 - time zero, something's gone wrong
TI:10:28:25	TH:0xe2a5b0	FI:gpm-engine.c	FN:gpm_engine_get_icon,435
 - Trying CHARGING icon: primary, ups
TI:10:28:25	TH:0xe2a5b0	FI:gpm-engine.c	FN:gpm_engine_get_icon,452
 - Trying PRESENT icon: primary, ups
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-unit.c	FN:gpm_cell_unit_get_icon,211
 - got filename: gpm-primary-charged
TI:10:28:25	TH:0xe2a5b0	FI:gpm-engine.c	FN:gpm_engine_recalculate_state_icon,575
 - ** EMIT: icon-changed: gpm-primary-charged
TI:10:28:25	TH:0xe2a5b0	FI:gpm-tray-icon.c	FN:gpm_tray_icon_set_icon,182
 - Setting icon to gpm-primary-charged
TI:10:28:25	TH:0xe2a5b0	FI:gpm-profile.c	FN:gpm_profile_get_accuracy,848
 - corrected percentage...
TI:10:28:25	TH:0xe2a5b0	FI:gpm-cell-array.c	FN:gpm_cell_array_get_description,997
 - accuracy = 0
TI:10:28:25	TH:0xe2a5b0	FI:gpm-engine.c	FN:gpm_engine_get_summary,349
 - tooltip: Computer is running on AC power
Laptop battery fully charged (100.0%)
Battery charge time is currently unknown
TI:10:28:25	TH:0xe2a5b0	FI:gpm-engine.c	FN:gpm_engine_recalculate_state_summary,615
 - ** EMIT: summary-changed(1): Computer is running on AC power
Laptop battery fully charged (100.0%)
Battery charge time is currently unknown
TI:10:28:25	TH:0xe2a5b0	FI:gpm-conf.c	FN:gconf_key_changed_cb,347
 - emitting value-changed : '/apps/gnome-screensaver/power_management_delay'
TI:10:28:25	TH:0xe2a5b0	FI:gpm-screensaver.c	FN:gconf_key_changed_cb,181
 - key : /apps/gnome-screensaver/power_management_delay
TI:10:28:25	TH:0xe2a5b0	FI:gpm-backlight.c	FN:conf_key_changed_cb,503
 - unknown key /apps/gnome-screensaver/power_management_delay
TI:10:28:30	TH:0xe2a5b0	FI:gpm-array.c	FN:gpm_array_append,141
 - adding to 0xfb7310, x=0, y=100, data=65280
TI:10:28:30	TH:0xe2a5b0	FI:gpm-array.c	FN:gpm_array_append,141
 - adding to 0xfb7370, x=0, y=12445, data=65280
TI:10:28:35	TH:0xe2a5b0	FI:gpm-array.c	FN:gpm_array_append,141
 - adding to 0xfb7310, x=5, y=100, data=65280
TI:10:28:35	TH:0xe2a5b0	FI:gpm-array.c	FN:gpm_array_append,141
 - adding to 0xfb7370, x=5, y=12445, data=65280
TI:10:28:40	TH:0xe2a5b0	FI:gpm-array.c	FN:gpm_array_append,141
 - adding to 0xfb7310, x=10, y=100, data=65280
TI:10:28:40	TH:0xe2a5b0	FI:gpm-array.c	FN:gpm_array_append,141
 - adding to 0xfb7370, x=10, y=12445, data=65280
TI:10:28:41	TH:0xe2a5b0	FI:gpm-cell.c	FN:hal_device_property_modified_cb,273
 - udi=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, key=battery.voltage.current, added=0, removed=0, finally=1
TI:10:28:45	TH:0xe2a5b0	FI:gpm-array.c	FN:gpm_array_append,141
 - adding to 0xfb7310, x=15, y=100, data=65280
TI:10:28:45	TH:0xe2a5b0	FI:gpm-array.c	FN:gpm_array_append,141
 - adding to 0xfb7370, x=15, y=12445, data=65280
Comment 12 John Murphy 2009-01-28 11:39:36 EST
I can not figure out how to start the gui system->preferences->system->power management as root without butchering my system by hacking into a bunch of system user configuration files.

If it makes a difference why does this gui not simply run as root and prompt for a password when it starts?

I would be happy to provide any requested info, but I will need step by step instructions suitable for a non-technical linux user including how to undo any changes made to user permissions etc.
Comment 13 John Murphy 2009-01-28 11:53:32 EST
btw
when I su - and run gpm I get the icon ('always' as it should be). I can select the icon and get access to additional menu items (ie on battery power menu etc). changes to these items seem to persist between sessions if I open up a terminal again and use it start gpm again.

however... when I change sessions and do not start gpm from the terminal the icon does not come back and the menu items are once again limited to the non-root items, and even tho 'always icon' is checked there is no icon. until I once again open a terminal, su -, and type the command for gpm.

so... does this mean gpm is for real bizarre reason actually not starting on my system, even selected from the system panel, until I start it from the terminal?
Comment 14 John Murphy 2009-01-28 12:26:28 EST
also, when the icon apears (after su'ing and starting gpm from terminal) the "make default" button in the gui i get from right-clicking the icon is greyed out which removed what I presume would be the normal way to get these changes to apply to other users?
Comment 15 John Murphy 2009-01-28 15:02:02 EST
also, after su'ing and starting g-p-m (sorry for the confusion caused by caling it gpm) and getting the icon... I notice that while I get the menu with the extra goodies when right-clicking the icon to open the preferences, if I even here instead (close the terminal window, if it matters, and) open preferences thru the system panel I instead get the reduced menu (no battery options etc).
Comment 16 John Murphy 2009-01-29 17:01:11 EST
Created attachment 330408 [details]
this contains all the requested debug info

Here is all the info requested for a g-p-m bug report in this text file.
Note there is no g-p-bugreport because there is no crash(?) so no bug-buddy ticks off. At least I think that why, but at any rate there is no bugreport file for g-p-m on my system.
Rather than a crash I think it is simply a failure to start, and either it is starting before bug-buddy or perhaps simply not even configured to start at all?
Comment 17 John Murphy 2009-01-31 11:08:09 EST
I checked under the panel System->Preferences->Personal->Sessions and Power Manager (power management daemon) is an entry on the Startup Programs tab and it is checked. When I click edit, this entry is set to "gnome-power-manager".

BUT, for some bizarre reason I can not even come close to understanding... gnome-power-manager is in fact not actually starting on login.

I can verify this by logging in fresh and opening a terminal, entering "su -" and then "killall gnome-power-manager" when it tells me "gnome-power-manager: no process killed". Also when I log in fresh and "su -" and then "gnome-power-manager --no-daemon" it does not squawk about g-p-m already running (if it were already running it would say " - Power Manager is already running in this session." and I have verified this behaviour by trying it when I have already hand-started the application as described).

I may be mistaken, but I also believe gnome-power-manager is not actually trying to start up but crashing. I have bug-buddy installed (at least it is checked in the add/remove program list) and gnome-power-manager is I believe supposed to trigger a bug report in bug-buddy if it crashes, unless of course it is trying to start and crashing BEFORE bug-buddy starts. There is no gnome-power-bugreport.sh file anywhere on my system.
Comment 18 John Murphy 2009-01-31 11:16:24 EST
able to change summary statement but unable to edit bug description to correctly show what the bug seems to actually be.
Comment 19 Richard Hughes 2009-02-02 07:14:42 EST
I think this is a gnome-panel bug, if you do "killall gnome-panel" it reloads the panel with the icon showing...
Comment 20 John Murphy 2009-02-02 09:06:03 EST
(In reply to comment #19)
> I think this is a gnome-panel bug, if you do "killall gnome-panel" it reloads
> the panel with the icon showing...

Sounds a little scary, as if there is no panel a noob like me will have trouble even shutting down the system (can't even just pull the plug on the laptop).

Would you please elaborate, if I "killall gnome-panel" what will happen in non-technical terms and what steps if any would I need to perform to restore my system to 'normal' configuration?

Also, what should I be looking for and what results would you like reported?

Or are you saying you already tried this?

Thanks
Comment 21 Richard Hughes 2009-02-02 09:35:45 EST
(In reply to comment #20)
> Would you please elaborate, if I "killall gnome-panel" what will happen in
> non-technical terms and what steps if any would I need to perform to restore my
> system to 'normal' configuration?

The process dies, and then it gets restarted automatically.

> Also, what should I be looking for and what results would you like reported?

If the icon appears :-)

> Or are you saying you already tried this?

Yes, a few minutes ago.

RIchard.
Comment 22 John Murphy 2009-02-02 09:52:11 EST
When I try killall gnome-panel from a fresh login (ie no g-p-m daemon manually started yet) the panel comes back and there is still no g-p-m icon (to reiterate, the icon preference is set to 'always').

When I first start the g-p-m daemon manually from a terminal, then (from a different terminal) try killall gnome-panel, the panel comes back with the icon present so I presume that means g-p-m is still running.

Essentially, killall gnome-panel on my system makes no change in whether or not the icon is displayed or the g-p-m daemon is running. Whatever the gnome-panel does on restart, it does not seem to include starting the g-p-m daemon at least on my system. The only way the daemon seems to start is by manually commanding it from the terminal (per comments 13-17 on this thread). Not a display issue, clearly a daemon startup issue.

So is this the gnome-panel or something in whatever package runs the startups for all the daemons (or are they one in the same)?
Comment 23 John Murphy 2009-02-02 12:09:10 EST
since my system update today the command that starts g-p-m has changed and I can no longer specify --no-daemon. oddly, the first time I tried it without the --no-daemon it started but exited when I closed the terminal. now (the second time) it seems to be still running. weird.

I also have mentioned, but it may bear repeating, that I get a warning message from dbus when starting g-p-m in the terminal which I believe is related to not having the screen saver installed?

** (gnome-power-manager:3744): WARNING **: DBUS error: Could not get owner of name 'org.gnome.ScreenSaver': no such name
** (gnome-power-manager:3744): DEBUG: proxy is NULL, maybe the daemon responsible for org.gnome.ScreenSaver is not running?

could this warning be preventing g-p-m from starting automatically but somehow still permit it to start manually?
Comment 24 John Murphy 2009-02-02 12:13:39 EST
dang now it seems most, but not all, of the time when I close the terminal window without the --no-daemon part of the command that g-p-m exits. so now the only way to have g-p-m running on my laptop is to leave the terminal open?

this is with 2.24.3-1.fc10(x86_64)
Comment 25 John Murphy 2009-02-02 12:15:29 EST
er, specifically gnome-power-manager-2.24.3-1.fc10(x86_64)
Comment 26 John Murphy 2009-02-03 12:42:22 EST
hmmm, another thought...
my etc/group got hosed when I foolishly tried to usermod -G without the -a to give myself lock and uucp to do stuff with rxtx (they have since fixed this in their instructions).

does the login service start-up of gnome-power-manager depend on any non-root user group assignments that might have been messed up by this?
Comment 27 John Murphy 2009-02-04 10:46:25 EST
this kinda sucks, had the first time of battery running out without the power manager working. suddenly boom lights out. lost work.

any progress on figuring out why g-p-m is not running automatically after login?
Comment 28 Richard Hughes 2009-02-05 07:02:08 EST
2009-02-05  Richard Hughes  <richard@hughsie.com>

	* src/Makefile.am:
	Correct the log file name to be actually usefull.

	* src/gpm-engine.c: (gpm_engine_recalculate_state_icon):
	Don't clear the icon after 2 seconds, as we have a daemon and kernel
	that doesn't need userspace bodges.

	* src/gpm-tray-icon.c: (gpm_tray_icon_enable_suspend),
	(gpm_tray_icon_enable_hibernate),
	(gpm_tray_icon_enable_context_menu), (gpm_tray_icon_show),
	(gpm_tray_icon_set_tooltip), (gpm_tray_icon_show_statistics_cb),
	(gpm_tray_icon_show_preferences_cb), (gpm_tray_icon_show_about_cb),
	(gpm_tray_icon_init):
	Don't unconditionally clear the icon on startup to try to prevent
	the race on startup with newer versions of gnome-panel.

I'll do a new build for rawhide on Monday.
Comment 29 John Murphy 2009-02-05 09:35:35 EST
okay, everything works perfectly on my desktop which is also fc10(x86_64), so I am sure I have something messed up particular to my laptop. it would be nice to know what is wrong but if worse comes to worse I am not beyond the point yet on the laptop where simply reinstalling fc10 would be out of the question.

when you have the build on rawhide I will give it a try.

there are no user groups on which gnome-power-manager depends?
Comment 30 John Murphy 2009-02-14 13:43:31 EST
a re-install of fedora 10 64-bit has fixed this bug on my laptop system.
you may wish to close it as NOTABUG, or you may wish to try to investigate.

fyi it appears (I am only guessing) to be related to the fact that I initially installed both gnome and xfce from the dvd install, thinking that way I could choose to switch to xfce and back and forth later (wrong), so while there was definately a _gnome_ power manager set up to run at login it may be that there was an xfce program interfering with it, but not sure.

what I do still find peculiar is that there was nothing to indicate to me that this was a problem... the installer let me do it and the g-p-m daemon which obviously had some trouble starting at login never provided any indication that it had failed or why.

but... I am no longer worried about it, a non-issue for me, although I will be happy to provide any further info you wish.

Note You need to log in before you can comment on or make changes to this bug.