Bug 479555 - Fuse umount cause stateless /etc/mtab to emit device busy error
Fuse umount cause stateless /etc/mtab to emit device busy error
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fuse (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-11 03:28 EST by Lou
Modified: 2010-10-27 06:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-27 06:55:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lou 2009-01-11 03:28:52 EST
Description of problem:
When TEMPORARY_STATE="yes" in /etc/sysconf/readonly-root, umount with zfs filesystem with zfs-fuse/fuse causes a temporary file /etc/mtab.tmp to be created. This temporary file is then renamed back to /etc/mtab. Because /etc/mtab in a stateless system is bind-mounted to /var/lib/stateless/writable/etc/mtab, rename something to it will fail with a device busy error message.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Change TEMPORARY_STATE from no to yes in /etc/sysconf/readonly-root
2. zfs mount something and the unmount it.
3.
  
Actual results:


Expected results:


Additional info:

Simply changing the mv command to cat the temporary file to the original file should fix the problem. (I am not a developer and I am only guessing here. I did not read the source code.) Could somebody fix this problem? Thanks.
Comment 1 Bug Zapper 2009-11-16 04:46:08 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Peter Lemenkov 2010-01-26 11:31:20 EST
I'll take care of this issue.
Comment 3 Bug Zapper 2010-03-15 08:23:35 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Peter Lemenkov 2010-10-27 06:55:05 EDT
Seems to be fixed in recent fuse. Feel free to reopen if this issue still exists.

Note You need to log in before you can comment on or make changes to this bug.